Express edition formats all messages as HTML as default

Bug #665673 reported by levu on 2010-10-23
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
evolution (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: evolution

In the express edition there is no way to format new messages as plain text. Even if i change the settings in "normal" edition, it has no effect to the message composing in express edition.

levu (levu) wrote :

I read the source and it seems that this option was removed intentionally, because the relevat code is removed in patch 89_express.patch. Is this right or was that accidentially? It's bad if you can't set whether a new message should be composed in HTML or plain text.

levu (levu) wrote :

I've added a patch. Now it's possible to let messages be composed in plain text even in express mode.

levu (levu) wrote :

@didrocks: in #ubuntu-devel i was told that you are the author of 89_express.patch and so i subscribed you to this bug.

Didier Roche (didrocks) wrote :

Thanks for your time to report this bug and help to make ubuntu better.

I think that upstream willingly removed the option in express mode due to visual clutter and it's only possible to set it by default in the option menu. I won't revert it then on my own.
I'll upload evo 2.32 with a more advanced evolution in natty next week probably. I think you should contact upstream about your issue.

levu (levu) wrote :

In upstream this bug was fixed (see http://live.gnome.org/Evolution/Art: "Fixed Issues > Mailer > HTML mail on by default (done mbarnes)"). In my opinion it's a really big problem that in express edition HTML mailing is the default. I don't have any problems if the checkbox in the settings dialog is hidden in express edition, but i want have the the possibility to configure this behaviour.

tags: added: patch
Didier Roche (didrocks) wrote :

Thanks for your time to report this bug and help to make ubuntu better.

I think that upstream willingly removed the option in express mode due to visual clutter and it's only possible to set it by default in the option menu. I won't revert it then on my own.
I'll upload evo 2.32 with a more advanced evolution in natty next week probably. I think you should contact upstream about your issue.

Changed in evolution (Ubuntu):
importance: Undecided → Low
levu (levu) wrote :

What about this bug? There were no updates here six months now and as i said it's fixed upstream, so why not fix it in ubuntu, too?

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Oneiric Ocelot. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Changed in evolution (Ubuntu):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for evolution (Ubuntu) because there has been no activity for 60 days.]

Changed in evolution (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers