evolution calendar-, task- and notivication-lists crashes by opening

Bug #655405 reported by Raoul on 2010-10-05
42
This bug affects 7 people
Affects Status Importance Assigned to Milestone
evolution (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: evolution

Opening the calendar window causes the crash of all calendars or notification lists. Task lists are also affected.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: evolution 2.30.3-1ubuntu6
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
CheckboxSubmission: 9c043671d6a9e2f9d8663e2d71558b35
CheckboxSystem: edda5d4f616ca792bf437989cb597002
Date: Wed Oct 6 00:35:57 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
ProcEnviron:
 LANG=de_DE.utf8
 SHELL=/bin/bash
SourcePackage: evolution

Raoul (trash-mails-at) wrote :
RedSingularity (redsingularity) wrote :

Did you upgrade from ubuntu 10.04 to 10.10?

Raoul (trash-mails-at) wrote :

Yes i did the upgrade from 10.04 to 10.10. Before i upgraded my system i backend evolution. I also tried to resolve the problem by using this backup.
Is this backtrace helpfull.

RedSingularity (redsingularity) wrote :

Ok, I will upgrade my 10.04 64bit install to 10.10 and try to reproduce this bug. I will let you know how it went ASAP.

RedSingularity (redsingularity) wrote :

And just to confirm, opening the calendar within evolution is what causes the problem?

RedSingularity (redsingularity) wrote :

Well I upgraded from 10.04 to 10.10 64 Bit. I started evolution and went to calendar and everything seems to work fine. It doesn't seem like a bug that is reproducible. It may be an anomaly limited to your system. If there is something you think I may have missed please let me know and I will try it. For now I am going to mark this bug as "incomplete".

Changed in evolution (Ubuntu):
status: New → Incomplete
Omer Akram (om26er) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a backtrace following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in evolution (Ubuntu):
importance: Undecided → Medium
Omer Akram (om26er) wrote :

when evolution crashes is there a error window to report the crash? you should use that to report crashers

tellapu (tellapu) wrote :

This effects me as well. I also upgraded from 10.04 to 10.10 (but using encrypted alternate version).

This is the error message:
The Evolution tasks have quit unexpectedly.
Your tasks will not be available until Evolution is restarted.

I will try to do a backtrace ... Is there not an easier (and quicker) way? Could that not be integrated in the normal Ubuntu?

tellapu (tellapu) wrote :

After the first error windows is closed, the next comes:
The Evolution memo has quit unexpectedly.
Your memos will not be available until Evolution is restarted.

tellapu (tellapu) wrote :

Attached you find the backtrace of the problem within evolution. Hopefully it is helpful. It would be a real nice Christmas gift if you could work on this problem. Evolution without calendar is not very helpful.

tellapu (tellapu) wrote :

Happy New Year! Anybody working on this? Please, I wait desperately for a solution, as I NEED to be able to use the calendar! Thanks.

tellapu (tellapu) wrote :

Help! I need somebody's heeelp!

Pedro Villavicencio (pedro) wrote :

Theres no symbols there, may you please install evolution-dbgsym, libgtk and libglib dbgsyms and try again? thanks.

Thanks for the comment!

Probably you meant:
libgtk2.0-0 - was installed
libglib2.0-0 - was installed
pkg-create-dbgsym - newly installed now

evolution-dbg was installed. I could not find evolution-dbgsym ... I
will search tomorrow.

On Wed, 2011-01-19 at 12:36 +0000, Pedro Villavicencio wrote:
> Theres no symbols there, may you please install evolution-dbgsym, libgtk
> and libglib dbgsyms and try again? thanks.

tellapu (tellapu) wrote :

Thanks for the comment again, I am glad that there is moving something.

I tried to find evolution-dbgsym in the package manager, but could not find it (also in the terminal: E: Version ‘2.22.1-0ubuntu2.8.04.1’ for ‘evolution-dbgsym’ was not found). Even after adding the ddebs.list (according to the instructions https://wiki.ubuntu.com/DebuggingProgramCrash).
Do I have to download and run the list-dbgsym-packages-v2.sh shell script as well?

What is installed on my computer:
libgtk2.0-0 - was installed
libglib2.0-0 - was installed
pkg-create-dbgsym - newly installed now
evolution-dbg was installed.

Anyway, I ran the backtrace again (according to https://wiki.ubuntu.com/Backtrace) and attached the new backtrace file. Perhaps it is useful. Otherwise please instruct me (step-by-step) what to do, I would love to help as I really desperately wait that the calendar would work again.

Some more information, hopefully it helps to sort out this problem.

I can still look at the calendar although there are no events visible.
If I would un-click the "Birthdays and Anniversaires" (under Contacts)
and click it on again, it would show me these events.
But if I would go to Personal (under on this computer), I can't see any
of the normal events and if I try to add a new event or un-click/click
"Personal", the calendar would "crash" (although evolution itself would
still run) and the birthdays and anniversaires events would disappear
again:
"The Evolution calendar has quit unexpectedly."

I can make the "Birthdays and Anniversaires" visible again, doing the
steps above.

The "Birthdays and Anniversaires" would always be seen in the clock
applet (panel) calendar overview and using gbirthday ...

What is going on?

Raymond Hill (rhill) wrote :

We've had the same problem today after an upgrade from 10.04 to 10.10:

"The Evolution calendar has quit unexpectedly. // Your calendars will not be available until Evolution is restarted"

After a bit of trying to figure what was wrong by searching on internet, on a hunch, I went and opened the calendar text file in "~/.evolution/calendar/local/system/calendar.ics". I checked the encoding of the file by clicking "File / Save As..." (which allows to check the encoding), and I noticed it was ISO-8859-1.

I made a copy of "calendar.ics" just in case, and saved a copy after forcing UTF-8 encoding in the "Save as..." dialog box. That solved the problem (except that accented letters were mangled -- not a big deal).

Hope this works for other as well.

tellapu (tellapu) wrote :

Hi Raymond!

Thanks a lot for your search and workaround. It helps partially. The
calendar still crashes "The Evolution memo has quit unexpectedly."/"The
Evolution task has quit unexpectedly." when I start evolution and switch
the first time to the calendar and "The Evolution CALENDAR has quit
unexpectedly." when I click on the clock-applet in the panel and look at
the calendar there. But I can restart with un-click/click the
"personal"-calendar in evolution.

I checked the journal.ics, is saved as UTF-8 (Windows). My actual
task.ics could not be opened with gedit, but as I switched the encoding
to ISO-8859-15, it could be opened. Then I saved it as UTF-8 (Windows)
as well. AND it seems to work now without any errors at the moment. We
will see how it is tomorrow ;-).

Why did this encoding problem happen?

By the way, did you save the "calendar.ics" as UTF-8 with line ending
Unix/Linux or Windows (or Mac OS Classic)? What is the difference
anyway?

Thanks again!

Raymond Hill (rhill) wrote :

Hi tellapu.

I went to check again the copy I saved prior to applying the change, and I have to correct myself: Just the same as what you found out on your side, the file encoding was actually ISO-8859-15 (not ISO-8859-1 as I reported previously). I didn't pay attention to the line ending settings, but now I checked and it is Windows, before and after the fix (IIRC, in Unix/Linux, line ending are \n, in Windows \n\r, and in Mac \r)

tellapu (tellapu) wrote :

Hi Raymund,

Thanks again, it still works :-) and also for ending setting info.

tellapu

Steve Roberts (drgrumpy) wrote :

I have been having a similar problem in lucid, reported here: https://bugs.launchpad.net/bugs/716433

...and upgraded to Maverick in the hope that this would go away - it doesn't and is now even worse...
if I attempt to open the calendar it either crashes without any warnings or just hangs and has to be forced to close.

My calendar ics file is utf-8/windows and I even deleted my original - still same problem with new file.

There seem to be lots of similar issues with calendar in evolution. This is going to drive me back to windows in order to use outlook.

Steve

Steve Roberts (drgrumpy) wrote :

Should have said it was a fresh install but retaining home directory.

Steve Roberts (drgrumpy) wrote :

Any action going to happen on this ? or do I abandon evolution all together - it is driving me nuts.

Steve, what happens if you open, then save the calendar ics file in iso-8859-1 (or -15 or whatever)? Can Evolution then read it?

Also, does evolution crash immediately? I suspect it actually doesn't and hangs around for a little while before it shows a "calendar has shutdown unexpectedly" message, if it does. If that's the case, please follow the steps in this wiki document to produce a valgrind log to attach to this bug: https://wiki.ubuntu.com/Valgrind

Znoren (mail-znoren) wrote :

I have the same problem:
When I switch to calendar view in Evolution, it does not display my calendar information but shows a number of error message windows. Evolution does not crash entirely, I can still go back to reading mail etc. Unticking a calendar box and then re-ticking it makes the calendar information display briefly, then another error message appears.
I attach a valgrind log.

Znoren, could you please provide a screenshot for the error messages you see? Thanks!

Znoren (mail-znoren) wrote :

I get a total of six error messages, the first three saying that Evolution memo/tasks/calendar has/have quit unexpectedly, and the last three a repetition of the first three.
See attached screenshots.

Thanks.

Can you please try to start e-calendar-factory in GDB to see if the issue can be reproduced?

To do this you'll want to:

- Close evolution
- Make sure evolution, and e-calendar-factory are no longer running
- Start e-c-f in gdb: run the command "gdb --args /usr/lib/evolution/e-calendar-factory", then type run and press enter again to start it.
- Start evolution

If all goes well, e-calendar-factory should get started, then evolution will start and e-calendar-factory might crash. This is likely the crash we need, so back in the terminal window with gdb, run the commands:

bt full
thread apply all bt full

And copy all of the output to a file to attach to this bug report. As above, this may need a bunch of debugging packages installed to get rid of entries showing up as "???": libebackend1.2-dbgsym libecal1.2-7-dbgsym libedata-cal1.2-7-dbgsym libedataserver1.2-13-dbgsym libedataserverui1.2-8-dbgsym (all of those would be available from the ddebs archive, see the instructions at https://wiki.ubuntu.com/DebuggingProgramCrash)

Steve Roberts (drgrumpy) wrote :

Apologies for not responding to message #25, been busy with the day job (made more difficult because I can't use my calendar !)

If I change the calendar file to ISO-8859-1 it still reads it, but still hangs or crashes in the same way - without any informative info.

Mostly when I try to navigate in the calendar view evolution either hangs or close suddenly.

I just ran valgrind - log file attached

I just followed the steps in #29 When evolution hangs or closes it just says:

[New Thread 0x7fffe8def700 (LWP 6121)]
Server is up and running...
Bye.
[Thread 0x7fffe8def700 (LWP 6121) exited]

Program exited normally.
(gdb) bt full
No stack.
(gdb) thread apply all bt full
(gdb)

(this was without the dbsym files - but there weren't any ??? to interpret)

fpater (fpater) wrote :

@Mathieu (#29): I am having the same exact problem. Upon switching to the calendar, my events (from Exchange) appear on the calendar for a few moments before the crash.

I used list-symbols-packages-v2.sh to identify and install all the dbgsym packages for normal running evolution and e-calendar-factory instances. I also manually installed the matching dbgsym versions of libebackend, libecal, libedata-cal, libedataserver, and libedataserverui. I followed your instructions and obtained the attached gdb output. If I'm missing something, please let me know.

Znoren (mail-znoren) wrote :

Sorry for the late reply. I attach the output from following the steps in #29. I hope I correctly installed all relevant debugging packages.
/Znoren

Launchpad Janitor (janitor) wrote :

[Expired for evolution (Ubuntu) because there has been no activity for 60 days.]

Changed in evolution (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers