Doesn't ask for a password - IMAP

Bug #653705 reported by Evgeniy on 2010-10-02
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
evolution (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: evolution

It doesn't ask for a password for automatically created Google IMAP account.So it just hangs.

I see same bug dated by 2006 year. It is sad.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: evolution 2.30.3-1ubuntu5
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
Architecture: i386
Date: Sat Oct 2 22:11:28 2010
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/evolution
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release Candidate i386 (20100928)
ProcEnviron:
 SHELL=/bin/bash
 LANG=ru_RU.utf8
SourcePackage: evolution

Evgeniy (goujat) wrote :
Omer Akram (om26er) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

* Is this reproducible?
* If so, what specific steps should we take to recreate this bug?

This will help us to find and resolve the problem.

Changed in evolution (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Evgeniy (goujat) wrote :

* It is reproducible each time. So I have no any abilty to check email through Evolution.

* To reproduce the bug one have to create a google account. Just enter your email, it offers you IMAP, then choose TLS (sad it's not selected by default). Then press OK, OK, OK. Then press "Check email".

After pressing "Forget passwords" menu item Evolution does not ask about password anyway.

I use Evolution in Russian locale, so no exact English strings present in my report.

Bryan Agee (bryanagee) wrote :

I have the same issue on a fresh install of Maverick. To reproduce:

1) Open Evolution
2) Configure an imap account. I used Gmail and a Google Apps account, so my email address, imap.google.com for the server with SSL enabled.
3) Save and close
4) Click the 'Send/Receive' button

It spins and never asks for a password

Omer Akram (om26er) wrote :

ok, it seems the problem only happens with TLS as SSL works fine

Changed in evolution (Ubuntu):
importance: Low → Medium
status: Incomplete → Confirmed
Omer Akram (om26er) wrote :

I searched in evolution's upstream bugs and found that someone else is also facing this issue because his network does not support TLS. I have never tried TLS before (I use SSL) so the reason I am seeing can be the same i.e. my network dont support it.
https://bugzilla.gnome.org/show_bug.cgi?id=436194

@Evgeniy, did TLS ever work for you in evolution?

Changed in evolution (Ubuntu):
status: Confirmed → Incomplete
Evgeniy (goujat) wrote :

I never tried evolution before, I used Mozilla Thunderbird.
There are two choices there: STARTTLS and SSL/TLS (except for no security at all, of course).

So I'm not sure what to choose.
If Google does not support TLS (I'm not sure), then the bug should be corrected because Evolution offers no security by default when using Google Imap. Then the bug is that provider's data base is just wrong.

Bryan Agee (bryanagee) wrote :

To clarify, I was selecting 'SSL' as the encryption method. I figured out a workaround though:

In the 'server' field, append the port to the server name: imap.gmail.com:993

That works just fine; odd that there's no 'port' field in the settings.

Evgeniy (goujat) wrote :

That's really bad solution.

Omer Akram (om26er) wrote :

TLS depends on if you ISP provider supports it. thunderbird in your case was not actually using TLS it has a fallback method to deal with this problem. the upstream bug report explains things clearly

nespejo (nespejo) wrote :

Uninstall network-manager and resolved

Oliver Joos (oliver-joos) wrote :

I just stumbled across this report (while searching for a similar one).

Did anyone here check bug 34058 and its workaround? Is this one just a duplicate of it?

sleepy (sleepy) wrote :

Habe this bug on Xubuntu 12.04.

Michael (michaeltheller) wrote :

I'm getting the same problem in Ubuntu 12.04LT with Evolution 3.2.3.

xor (xor) wrote :

Getting this on Kubuntu 12.10 with Evolution 3.6.2

xor (xor) wrote :

I found a workaround:
As I am using Kubuntu (=Ubuntu with KDE), not all Gnome packages are installed.
So I manually installed "gnome-keyring" (+ dependancies "gcr", "libpam-gnome-keyring"), which seems to be the password backend for Evolution. Now Evolution asks for a password :)

xor (xor) wrote :

- So can you please fix the Evolution package to be dependent on "gnome-keyring"?

Jörg Frings-Fürst (jff-de) wrote :

10.10 is not longer supported
change status to invalid

Changed in evolution (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.