Ubuntu

Evolution adds 'Sent from Ubuntu' signature by default

Reported by Rafał Cieślak on 2010-09-19
392
This bug affects 84 people
Affects Status Importance Assigned to Milestone
evolution (Ubuntu)
High
Didier Roche
Maverick
High
Didier Roche

Bug Description

The Evolution package in Ubuntu 10.10 /was/ briefly patched (for new accounts/installs created between 2010-08-27 and 2010-09-20) to apply a signature of "Sent from Ubuntu" for new users (as implemented in bug #615300). This bug report is the mirror to the original report and requested that the signature be added to the list of available signatures, but not used unless the user explicitly requests it.

Rationale: Evolution definitely shouldn't add this signature by default. A large number of users are against having such an unprofessional looking, rude, obnoxious and useless signature enabled by default. Evolution should let the user choose whether they wish to boast about their Operating System. The signature should be added only if the user approves the addition, since a lot of people have many different reasons not to include this signature.

The upload that added the "Sent from Ubuntu" signature occurred at T-minus six weeks before release.

evolution (2.30.2-1ubuntu2) maverick; urgency=low

  * debian/patches/01_ubuntu_signature.patch,
    debian/signature.py:
    - define an Ubuntu signature which writes "Sent from Ubuntu", the signature
      is in the list but not default yet for new accounts, that should change
      before the end of the cycle
      (lp: #615300)
 -- Sebastien Bacher <email address hidden> Fri, 27 Aug 2010 00:07:56 +0200

Based on the first 1,000+ contributors to the following poll, 75% are against the signature (the same ratio is present on the UbuntuForums):
  http://www.omgubuntu.co.uk/2010/09/sent-from-ubuntu-signature-to-be-added-to-all-mail-sent-from-evolution/

Maia Everett (sikon) wrote :

Why was this marked as a duplicate? It is the exact opposite of that other bug.

Julien Olivier (julo) wrote :

It was marked as a duplicate so that this one can be ignored, and the other one can stay "fixed" forever :) Marketing really seems to always destroy what it touches, event when it's free. Sad, very sad...

Matt (mattjohn0169) wrote :

I set it to not be a duplicate on the assumption that it was automatically marked as such by some piece of software. If I've overstepped my boundaries, I apologise.

Matt (mattjohn0169) wrote :

Very sorry about this. I checked the activity log and it seems the marking was done by a respected Launchpad user. I've now put it back to the previous value, and have learned my lesson!

Can anyone confirm that the signature block is being placed in evolution? If not, this is not valid, until such time as that actually happens.

Alin Andrei (nilarimogard) wrote :

@Charlie Kravetz: I can confirm this. I've just reset (gconftool-2 --recursive-unset /apps/evolution) my Evolution settings in Maverick and the signature is here already.

This is not a duplicate of bug 615300. It is a bug filed because of that default signature.

 Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in evolution (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Paul Sladen (sladen) on 2010-09-19
description: updated
Seung Soo, Ha (sungsuha) wrote :

I think this should be an opt-in feature. Also, this definitely needs much more discussion.
+1 for delegating to next release.

Frank (frank-maker) wrote :

I like this default because it increases visibility of others to how many people are using Ubuntu.

Benjamim Gois (benjamim-gois) wrote :

I like the idea. I think spread the ubuntu name is something very important.

I remember dropping a online mail service for the exact same reason...

who the hell are they to claim the right to modify my correspondence and insert publicity...

Should I also wear a branded hat and bumper stickers ???

If you're serious, go back to Debian...

John King (kingj-linuxmlsts) wrote :

I posted this on the other bug, but here we go...

I like to idea to some degree; but this just simply shouldn't be done by default.

Something I've noticed lately is that there's not really a central community advocacy front like SpreadFirefox. Yeah sure, there's 'SpreadUbuntu' (http://spreadubuntu.neomenlo.org/), but it's not really well known, or on a standard domain like www.spreadubuntu.com (that URL currently redirects to www.ubuntu.com). Perhaps we need that. Then those that wish to participate in advocacy of Ubuntu could go there, and maybe then there'd be a blog or forum or something, and then things like 'Advertise Ubuntu in your e-mail sig!' are suggested for people to opt-in *on an individual basis*. One immediate benefit I see is that you might end up with many clever or at least unique sigs, likely to get more attention than a hundred bland 'Sent From Ubuntu's.

Community advocacy in Ubuntu needs much more work to be honest; I'd much rather see Canonical look more at what they could do to improve community advocacy than force it on users that may not want it.

Maia Everett (sikon) wrote :

Whoever reopened this bug, thank you. I hope the core developers will listen to the community for once, and revert the change.

----
This bug comment was posted using Ubuntu 10.10 and Epiphany 2.30.2-1ubuntu6.

Scott Kitterman (kitterman) wrote :

I'm not an evolution user, so this doesn't affect me directly, but I do agree this should be on the release team's radar since it was added after feature freeze without release team review.

Changed in evolution (Ubuntu):
milestone: none → ubuntu-10.10
Changed in evolution (Ubuntu Maverick):
importance: Medium → High

Ubuntu sticking on advertisements at the end of messages by default looks very unprofessional. I hope the change is undone before the final release.

Hernando Torque (htorque) wrote :

A signature is bound to an account, so why not add its definition to the account setup process and prepopulate it with "Sent from Ubuntu", similar like the hostname is prepopulated during the Ubuntu installation?

michal.gregor (michal.gregor) wrote :

Have I missed something? When exactly has Ubuntu turned from "is and always will be absolutely free" to adware? :D :D

Danté (dante-ashton) wrote :

I can see both sides of this here; on a side note I've already appended that line to my own sig. Partly to help advertise Ubuntu, but also because I am making a small name for myself as a technician and if I introduce people to Ubuntu I imagine it helps if they know I use it too.

  Hello,

I also agree: this could be a good idea even if choice is clearly
proposed to the user when he first configures his account on Evolution.

Of course it can easily be changed, but for new users, and those who
will use Ubuntu for professional work, it should not be hidden by
default, as opensource mind it has to be opened and optional.

Best regards,

Xavier

Roshan George (roshan-george) wrote :

Oh dear god, please remove this. It makes the user look like a total jerk. Just the other day, my dad remarked to me that he'd find it terribly embarrassing if his phone added "Sent from my Nokia" to everything like the Blackberries and iPhones. That text sounds so obnoxious.

CiaranG (ciarang) wrote :

In one way, this doesn't affect me because I don't use Evolution. In another way, it affects me greatly because the fact that it's been done makes me mistrust Ubuntu. What do I do now, either a) watch every single future change to any packages I use in case someone thinks it's a good idea to use them as a vehicle to make me spam my contacts and look like an idiot in the process, or b) switch all my machines back to Debian?

hnrkg (hnrkg) wrote :

This is definitely a move in the wrong direction. It should be up to the users to define the content of the signature of their e-mails. Ubuntu has nothing to do with the contents of it's users signatures! If it would be relevant for the user to have this kind of information in the signature, the user would add it himself. I don't think that this even should be an option to add this kind signature.

Advertising should be done elsewhere, not in users e-mails. It is just cheap.

bjb1959 (bart-burroughs-cox) wrote :

OMG people.. Really?? you have nothing better to do with your day then fret over whether or not there is a default signature in a sent email?? REALLY???? I have an idea. don't use Evolution or, better yet, don't use Ubuntu. I get those little blackberry and iPhone messages all the time and I must say I have never even given them a second thought. Maybe that is because I am just not as enlightened as all of you are. I use Ubuntu with Thunderbird and Gmail (mostly just Gmail though) and I couldn't care less if they want to stick a default signature in emails on Evolution. If it bothers you turn it off... If you are ashamed that you use Ubuntu then turn it off...

aleth (aleth) wrote :

Really bad move. It's tacky and will just annoy new users.

--
Sent by launchpad.

What a terrible "microsoftish" decision!

Robbie Williamson (robbiew) wrote :

Is it possible to set it as the default signature, but not enable the signature feature by default? This way users will have the choice upfront as to whether or not they want to promote this totally awesome, FOSS supporting, completely ZERO cost operating system, called Ubuntu in their signature line or not.

Didier,

could you please do as Robbie suggests? Thanks.

Changed in evolution (Ubuntu Maverick):
assignee: nobody → Didier Roche (didrocks)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evolution - 2.30.3-1ubuntu3

---------------
evolution (2.30.3-1ubuntu3) maverick; urgency=low

  * debian/patches/01_ubuntu_signature.patch: (LP: #642839)
    - don't set the ubuntu signature as default for new accounts
 -- Didier Roche <email address hidden> Mon, 20 Sep 2010 16:25:26 +0200

Changed in evolution (Ubuntu Maverick):
status: Triaged → Fix Released
Amedee Van Gasse (amedee) wrote :

Subscribing.

I agree with the suggestion that Robbie made:
1. Set a default signature string
2. Do not enable signatures by default

That way, when a user wants to set a signature, he doesn't get an empty text box. It's still up to the individual choice user to use the default sig, or a personalized sig.

@Amedee: For clarity, this is exactly the change described in comment #30, and why the bug is now set to Fixed.

Cory Zerwas (gannas) wrote :

Glad to see a sensible decision was made to remove this default behavior.

It's a bit embarrassing that this "Sent from Ubuntu" crap made it into a final cut. Someone must have merged it while drunk. Stay classy, Ubuntu. You've encouraged me to check out other distros again.

Paul Sladen (sladen) wrote :

Cory: perhaps it would be worth focusing on the speed at which this fix was applied and a new version deployed after it was brought to people's attention and highlighted as an issue. This is the reason why testing the distribution is important and feeding back /any/ problems (however small) to the bug tracker is important. The more people who test, the quicker issues can be addressed.

If an issue isn't written down, it is very hard to fix it! In this case, once it was written down, it was addressed very quickly.

description: updated
Scott Kitterman (kitterman) wrote :

Paul,

Since the follow on change was directed by the same Canonical manager that directed the original change, I think claiming this bug pointed any technical issues to anyone is stretching things.

This change was only needed because a late change was pushed into the release outside of existing processes. All this really demonstrates is the disconnect between some Canonical management and the rest of the community. It should have been immediately obvious that this was a bad idea.

Paul Sladen (sladen) wrote :

ScottK: can you think of a faster way of getting this fixed than a manager of a commercial company assigning and directing (comment #29) one of the developers in their charge to handle this issue as a top-priority, and in the manner _recommended_ by one of the release team (comment #28), a team of which you are also a member?

Without being drawn on whether the original implementation was a good idea, a bad idea, or a mediocre idea (either way). The person who submitted the original request (probably on behalf of a third party...) ensured that it continued to be dealt with when the community highlighted that the proposal might be sub-optimal. I think the outcome above shows responsiveness and, in this instance, a willingness to eat one's humility.

I agree. My point was that this isn't a usual bug where someone finds a
problem and then resources need to be brought onto the problem to identify and
resolve it. This is a case where the usual processes were bypassed to do
something that at best hadn't been fully considered.

I do wonder, given that the suggested resolution came from a member of the
release team, if this entire mess might have been avoided if the existing
processes for post feature freeze design changes had been followed.

joopbraak (joopbraak) wrote :

@bjb1959
So you don't mind if somebody messes with the personal email correspondence you have with your friends, colleagues and family?

You wouldn't mind if the post-office adds "Eat more hamburgers at McDonalds" under every postcard you send?

joopbraak (joopbraak) wrote :

@bjb1959
People care about Ubuntu, that's why they complain. Obviously you don't.

This is done. Please take further discussion elsewhere.

C de-Avillez (hggdh2) wrote :

Marking as Opinion -- fix is implemented already, and reverts bug 615300.

Changed in evolution (Ubuntu Maverick):
status: Fix Released → Opinion
Scott Kitterman (kitterman) wrote :

No. The bug is fixed and this is not a discussion forum.

Changed in evolution (Ubuntu Maverick):
status: Opinion → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers