[SRU] Evolution [Open Link In Browser] not working for new eBay email hyperlinks

Bug #611983 reported by Andy Mallett on 2010-07-31
58
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Evolution
Invalid
Medium
evolution (Ubuntu)
Low
Unassigned
Lucid
Undecided
Unassigned
Maverick
Undecided
Unassigned
Natty
Low
Unassigned

Bug Description

I am running the following - Ubuntu Lucid Lynx 10.04 + Firefox 3.6.8 + Evolution 2.28.3

On the 26th July 2010, eBay (in their wisdom !) changed the structure of their notification emails, unfortunately since this change I have been unable (in Evolution mail) to click on the hyperlinks back to the eBay website without the resulting eBay web page showing a variety of errors.

Before this issue arose, the eBay email hyperlinks had the structure such as -
    http://cgi.ebay.co.uk/ws/eBayISAPI.dll?ViewItem&item=290457755810&ssPageName=ADME:B:SS:GB:1123
and Evolution still opens these links correctly.

After the eBay change the links look like -

    http://rover.ebay.com/rover/0/e11021.m45.l1123/7?euid=5352848142992251064&loc=http%3A%2F%2Fcgi.ebay.co.uk%2Fws%2FeBayISAPI.dll%3FViewItem%26item%3D150472423977%26ssPageName%3DADME%3AB%3ASS%3AGB%3A1123

-now if within Evolution I hover over the hyperlink and select "[Copy Link Location]", then paste the result in Firefox, then I get the result I would expect.

HOWEVER if in the same link I try to either "[Open Link In Browser]", or simply double clicking the mouse to open the link into Firefox, then the URL that Firefox receives looks like -

    http://rover.ebay.com/rover/0/e11021.m45.l1123/7?euid=5352848142992251064&loc=http://cgi.ebay.co.uk/ws/eBayISAPI.dll?ViewItem&item=150472423977&ssPageName=ADME:B:SS:GB:1123

- which turns out to be invalid !

What can I do to get Evolution to send the correct form of the URL to Firefox ? - or is this an Evolution bug.

There has been a short discussion on the possible cause of this problem here -
https://answers.launchpad.net/ubuntu/+source/evolution/+question/119395

and the proposed solution from that link says -
"
I see your problem now. Seems that evolution is decoding the escape codes (%3A, %2F, etc) that are present in the original URL, but the application on eBay needs those escape codes intact.

Maybe it is an Evolution bug, as it should not alter the URL while sending it to Firefox.

I checked the evolution source code:

  http://archive.ubuntu.com/ubuntu/pool/main/e/evolution/evolution_2.28.3.orig.tar.gz

Inside e-util/e-util.c file, there is a function e_show_uri(). Before it passes the URL to Firefox, it removes the escape codes by calling camel_url_decode():

  http://library.gnome.org/devel/camel/stable/camel-camel-url.html#camel-url-decode

So I think you really should open an evolution bug and see if anyone can come with an explanation for this behavior.
"

Dane A. Alberty (drawr) wrote :

I can't even copy and paste links. The "copy" appears to work but then the paste is blank. I am on Karmic Koala but I do make updates when I have trouble playing movies and cd's. So I am an ex-windows user trying to make the best of Linux. TIA

Andy Mallett (ubuntu-ajmallett) wrote :

A very unhelpful update from eBay customer support -

"
I have noticed that you're currently using a Linux as your operating system.
As of now, the recommended operating system that can
support eBay functions are Microsoft Windows and Macintosh. This is the
reason why some hyperlinks can't be processed by your email client
because when using a different operating system like Linux, other eBay
functions may not be supported. I suggest that you use the supported
operating systems when using eBay to ensure proper functionality of the site.
"

For me, changing to Windows is NEVER going to happen, I just need Evolution fixed as it is obvious that eBay are not going to be any help !

Pedro Villavicencio (pedro) wrote :

It looks similar to bug https://bugzilla.gnome.org/show_bug.cgi?id=625413 ; may you please subscribe to it and add comments if needed? thanks.

Changed in evolution (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in evolution:
status: Unknown → New
Andy Mallett (ubuntu-ajmallett) wrote :

*** This is NOT a duplicate of bug #149964. ***

Bug #149964 is some issue with embedded "&" (ampersand) characters, I don't believe my issue has anything to do with that, in fact I have always found URL's with embedded "&" characters work as intended.

The bug I am reporting looks to be a problem with how the "%" (percent) character is handled.

André Carezia (carezia) wrote :

It's related to bug #149964. In both bug reports, the underlying problem is the same: the URL is decoded by calling function camel_url_decode(). I think the URL should be passed intact to the web browser.

Andy Mallett (ubuntu-ajmallett) wrote :

It may be the case that the problematic function happens to be the same - although with different symptoms.

Do you think that by making this new issue a duplicate of the old bug #149964, which currently has a status of "Fix Released" nearly three years ago and the majority of respondents saying the problem is solved, then surely my issue is not going to be resolved ?

Andy Mallett (ubuntu-ajmallett) wrote :

I think Bug #616889 is a duplicate of this one.

Andy Mallett (ubuntu-ajmallett) wrote :

I wonder if I am missing something obvious here ?.

Can anyone tell me WHY my two example hyperlinks behave differently, as they both look identical but just expressed differently.

So the hyperlink that works (expressed using ESCAPE codes) -
http://rover.ebay.com/rover/0/e11021.m45.l1123/7?euid=5352848142992251064&loc=http%3A%2F%2Fcgi.ebay.co.uk%2Fws%2FeBayISAPI.dll%3FViewItem%26item%3D150472423977%26ssPageName%3DADME%3AB%3ASS%3AGB%3A1123

And the hyperlink that fails (expressed using ASCII characters) -
http://rover.ebay.com/rover/0/e11021.m45.l1123/7?euid=5352848142992251064&loc=http://cgi.ebay.co.uk/ws/eBayISAPI.dll?ViewItem&item=150472423977&ssPageName=ADME:B:SS:GB:1123

But if you manually translate all the ESCAPE characters from the first example, then you end up with the second example !

André Carezia (carezia) wrote :

Sorry, I was wrong in my comment #5.

The bug #149964 is about generating hyperlinks for showing at the message window/panel. The function camel_url_decode() plays no role on that bug. This bug is about sending the wrong hyperlink to an external application (web browser). This bug is not a duplicate of bug #149964.

So, @Andy, you are right: making this bug a duplicate of bug #149964 will not solve it.

Thank you for confirming that this is not a duplicate bug, so how do we UNduplicate it ?

Pedro Villavicencio (pedro) wrote :

I've unduplicated the bug, it can be done by clicking at the yellow button next to the duplicated number.

Jason Connedy (connedy) wrote :

This bug doesn't appears only for ebay-links other their rover-server.
It affects many mails from other servers too, such as job-portals.

For example the german jobcenter ... when I click the link in my mail in evolution, firefox gets this url:
http://jobboerse.arbeitsagentur.de/vamJB/suchassistent.html?typ=6&encext=AB0M8FPb/XORENPrCV7i1Pk932s+ghR2z29EB3Hq24qrS+6zqesN9NerF/uPsNdG&encext=NK0A5xz5oCQRaGZgIQ0ovG0YNAfV8f2NcCBzRgKv2+sSqW1TR7P/6V2+WumA8KEN
and it results in:
http://jobboerse.arbeitsagentur.de/vamJB/suchassistentStatusAnzeigen.html?execution=e4s1

When I right-click on the link in evolution, then copy the link and paste this in firefox it looks like this:
http://jobboerse.arbeitsagentur.de:80/vamJB/suchassistent.html?typ=6&encext=AB0M8FPb%2FXORENPrCV7i1Pk932s%2BghR2z29EB3Hq24qrS%2B6zqesN9NerF%2FuPsNdG&encext=NK0A5xz5oCQRaGZgIQ0ovG0YNAfV8f2NcCBzRgKv2%2BsSqW1TR7P%2F6V2%2BWumA8KEN
and it works!
The same behaviour appears with ebay and amazon.

Changed in evolution:
importance: Unknown → Medium
David Kaplan (dmkaplan) wrote :

This bug applies to any link that includes special escape characters (for example, %40 = @). As this is commonplace in links nowadays, this problem is likely to be rather significant. I have noticed it with emails from a large number of websites.

From the discussion above, it is no longer clear to me where this bug is being followed. Is this the duplicate or are the others the duplicate?

jyanek (yanekjg) wrote :

I am also having the same issue with ebay notifications to evolution. Using ubuntu 10.10 with evolution 2.30.3. If I click on the hyperlink from within evolution, ebay gives me "This listing () has been removed, or this item is not available". However, if I COPY the hyperlink from evolution, paste in firefox, then the link works properly. Please help. This has been going on since 10.04.

Marc Deslauriers (mdeslaur) wrote :

This was caused by an incorrect patch to attempt to fix gnome bug #581032, which has since been reverted in evolution trunk and 2.32.

See:

http://git.gnome.org/browse/evolution/commit/?id=723528e407bca6f2aa26461e6f8bcc7de32b056d

Changed in evolution (Ubuntu Lucid):
status: New → Confirmed
Changed in evolution (Ubuntu Maverick):
status: New → Confirmed
bojo42 (bojo42) wrote :

tested the git commit on the lucid package and tested sucessfully with ebay links.

bojo42 (bojo42) wrote :

did not test it on maverick, but should be the same.

Changed in evolution (Ubuntu Maverick):
status: Confirmed → In Progress
Changed in evolution (Ubuntu Lucid):
status: Confirmed → In Progress
bojo42 (bojo42) wrote :

for current testing install the following .debs or use pinning on the PPA :

lucid: https://launchpad.net/~bojo42/+archive/testing/+sourcepub/1357951/+listing-archive-extra

maverick: https://launchpad.net/~bojo42/+archive/testing/+sourcepub/1357949/+listing-archive-extra

as said the maverick package is untested, but i am running the lucid one with success.

bojo42 (bojo42) wrote :

BTW i forget: the packages on my PPA will get superseded once we get official packages or unrelated updates.

jyanek (yanekjg) wrote :

I can test with Maverick, but not sure how many (or which of) the .debs to install? Also, if I put this in, when the next version of Evolution comes out, will I need to uninstall? Thanks!

bojo42 (bojo42) wrote :

@jyanek: you will probably just need the evolution, evolution-common, evolution-plugins & libevolution packages for your architecture. the next update will automatically remove my packages if the version number is at least 2.30.3-1ubuntu8.

Marc Deslauriers (mdeslaur) wrote :

SRU Request:

Impact: links in email do not decode properly, in particular the ones from eBay.

This has been addressed by backporting a minimal fix from trunk, see the debdiff in comment #16.

I have uploaded packages to lucid-proposed. I will upload packages to maverick-proposed once the current packages in -proposed get released.

summary: - Evolution [Open Link In Browser] not working for new eBay email
+ [SRU] Evolution [Open Link In Browser] not working for new eBay email
hyperlinks
Changed in evolution (Ubuntu Natty):
status: Triaged → Fix Released
Martin Pitt (pitti) wrote :

Note, the lucid upload in -proposed queue doesn't include version 2.28.3-0ubuntu10.1 which is currenlty in lucid-proposed for bug 229187, but didn't get any feedback yet. If verification of that fails, this upload is ok, but otherwise it might be preferable to include the previous patch.

Martin Pitt (pitti) wrote :

ah, seems that other bug is v-failed.

Changed in evolution (Ubuntu Lucid):
status: In Progress → Fix Committed
tags: added: verification-needed

Accepted evolution into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

TJ (tj) wrote :

Confirmed as fixed.

apt-cache policy evolution
evolution:
  Installed: 2.28.3-0ubuntu10.2
  Candidate: 2.28.3-0ubuntu10.2
  Version table:
 *** 2.28.3-0ubuntu10.2 0
        500 http://gb.archive.ubuntu.com/ubuntu/ lucid-proposed/main Packages
        100 /var/lib/dpkg/status
     2.28.3-0ubuntu10 0
        500 http://gb.archive.ubuntu.com/ubuntu/ lucid-updates/main Packages
     2.28.3-0ubuntu9 0
        500 http://gb.archive.ubuntu.com/ubuntu/ lucid/main Packages

tags: added: verification-done
removed: verification-needed
Ken Guenther (kguenther6) wrote :

Also confimed as fixed.

apt-cache policy evolution
evolution:
  Installed: 2.28.3-0ubuntu10.2
  Candidate: 2.28.3-0ubuntu10.2
  Version table:
 *** 2.28.3-0ubuntu10.2 0
        100 /var/lib/dpkg/status
     2.28.3-0ubuntu10 0
        500 http://us.archive.ubuntu.com/ubuntu/ lucid-updates/main Packages
     2.28.3-0ubuntu9 0
        500 http://us.archive.ubuntu.com/ubuntu/ lucid/main Packages

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evolution - 2.28.3-0ubuntu10.2

---------------
evolution (2.28.3-0ubuntu10.2) lucid-proposed; urgency=low

  * debian/patches/94_faulty_hyperlinks_to_external_applications.patch:
    - from git to fix wrong handling of some hyperlinks (LP: #611983)
 -- bojo42 <email address hidden> Sun, 07 Nov 2010 20:34:46 +0100

Changed in evolution (Ubuntu Lucid):
status: Fix Committed → Fix Released
bojo42 (bojo42) wrote :

great we finally closed it in lucid. next is maverick, so i rebased the diff against 2.30.3-1ubuntu7.2.

Marc Deslauriers (mdeslaur) wrote :

Packages with the debdiff in comment #29 have been pushed to maverick-proposed.

Martin Pitt (pitti) wrote :

Accepted evolution into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in evolution (Ubuntu Maverick):
status: In Progress → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
Forlong (forlong) wrote :

Confirming that Evolution in maverick-proposed fixed this for me.

Omer Akram (om26er) on 2011-01-30
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evolution - 2.30.3-1ubuntu7.3

---------------
evolution (2.30.3-1ubuntu7.3) maverick-proposed; urgency=low

  * debian/patches/93_faulty_hyperlinks_to_external_applications.patch:
    - from git to fix wrong handling of some hyperlinks (LP: #611983)
 -- bojo42 <email address hidden> Mon, 03 Jan 2011 10:59:53 +0100

Changed in evolution (Ubuntu Maverick):
status: Fix Committed → Fix Released
Changed in evolution:
status: New → Invalid

In evolution I can not send this message:
And finally do not forget to look at my website.
there You can find new photos from 2011
where my website is a hyperlink to
http://www.jerker.olofpark.com/Eindex.html

So I changed to Thunderbird from Evolution
And that solved the problem

Please fix this bug in evolution

bojo42 (bojo42) wrote :

@Olof: This bug is already fixed. Your problem seems to be completely unrelated.

I use ubuntu 10.04 and Evolution 2.28.3 and the bug is still there.
But change from Evolution to Thunderbird solved it

This bug is fixed.
When I have tested this morning everything is working.
I like Evolution. Many thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.