evolution crashed with SIGSEGV in pango_layout_line_get_extents()

Bug #607111 reported by Arthur Rilke on 2010-07-19
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
evolution (Ubuntu)
Medium
Unassigned
Nominated for Maverick by Matt Lavin

Bug Description

Binary package hint: evolution

First Evolution crashed when I selected all contacts and chose to have them deleted. Evolution then immediately restarted and recovered a draft message I was working on. I clicked on Calendar. Then Evolution crashed for a second time, which is the crash apport has now collected information on.

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: evolution 2.30.2-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.35-7.11-generic 2.6.35-rc4
Uname: Linux 2.6.35-7-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
CrashCounter: 1
Date: Mon Jul 19 10:31:52 2010
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/evolution
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
ProcCmdline: evolution
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_ZA.utf8
SegvAnalysis:
 Segfault happened at: 0x6eb08d <pango_layout_line_get_extents+29>: mov (%eax),%ecx
 PC (0x006eb08d) ok
 source "(%eax)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%ecx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: evolution
StacktraceTop:
 pango_layout_line_get_extents ()
 ?? () from /usr/lib/libpango-1.0.so.0
 ?? () from /usr/lib/libpango-1.0.so.0
 pango_layout_get_pixel_extents ()
 pango_layout_get_pixel_size ()
Title: evolution crashed with SIGSEGV in pango_layout_line_get_extents()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Arthur Rilke (arthurrilke) wrote :
Pedro Villavicencio (pedro) wrote :

Thank you taking the time to report this bug and helping to make Ubuntu better. However, processing the crash report to get detailed information for the developers failed as the retracer did not generate a useful symbolic stack trace.
Please try to obtain a backtrace manually following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in evolution (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in evolution (Ubuntu):
status: Incomplete → Invalid
Matt Lavin (matt-lavin) wrote :

I can regularly reproduce this crash by clicking on a specific date in my evolution calendar. I've attached the data described on the DebuggingProgramCrash wiki page.

Changed in evolution (Ubuntu):
status: Invalid → Confirmed
Matt Lavin (matt-lavin) wrote :

I can regularly reproduce this crash by clicking on a specific date in my evolution calendar. I've attached the data described on the DebuggingProgramCrash wiki page.

Jörg Frings-Fürst (jff-de) wrote :

10.10 is not longer supported
change status to invalid

Changed in evolution (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers