evolution crashed with SIGSEGV in gtk_widget_get_toplevel()

Bug #602828 reported by LSL on 2010-07-07
416
This bug affects 87 people
Affects Status Importance Assigned to Milestone
Evolution
Invalid
Critical
evolution (Ubuntu)
Medium
Didier Roche

Bug Description

Binary package hint: evolution

Segmentation fault after I told Evolution to quit

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: evolution 2.30.2-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.35-6.9-generic 2.6.35-rc3
Uname: Linux 2.6.35-6-generic x86_64
Architecture: amd64
Date: Wed Jul 7 10:32:58 2010
ExecutablePath: /usr/bin/evolution
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
ProcCmdline: evolution
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.utf8
SegvAnalysis:
 Segfault happened at: 0x7f6369cd6123 <gtk_widget_get_toplevel+83>: mov 0x58(%rbx),%rax
 PC (0x7f6369cd6123) ok
 source "0x58(%rbx)" (0xaaaaaaaaaaaaab02) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: evolution
StacktraceTop:
 gtk_widget_get_toplevel ()
 ?? () from /usr/lib/libgtk-x11-2.0.so.0
 gtk_widget_has_screen ()
 ?? () from /usr/lib/libgtk-x11-2.0.so.0
 ?? () from /usr/lib/libgdk-x11-2.0.so.0
Title: evolution crashed with SIGSEGV in gtk_widget_get_toplevel()
UserGroups: adm admin cdrom dialout lpadmin netdev plugdev sambashare

LSL (spesialstyrker) wrote :

StacktraceTop:
 IA__gtk_widget_get_toplevel (
 gtk_widget_get_screen_unchecked (widget=0x1bac3f0)
 IA__gtk_widget_has_screen (widget=0x1bac3f0)
 recompute_idle_func (data=<value optimized out>)
 gdk_threads_dispatch (data=0x1db8f40)

Changed in evolution (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Pedro Villavicencio (pedro) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at:
 https://bugzilla.gnome.org/show_bug.cgi?id=623832

visibility: private → public
Changed in evolution (Ubuntu):
status: New → Triaged
Changed in evolution:
status: Unknown → New
Paul White (paulw2u) wrote :

Inadvertently reported as a duplicate (#611719) I encountered this bug/crash when attempting to open Evolution and thinking it wasn't going to open, I opened it a second time. Evolution then opened momentarily before the crash notification appeared.

I've tried several times to reproduce this crash but failed.

Dennis Sheil (dennis-sheil) wrote :

I can reproduce this at will.

First I open evolution to a date on which I already have an appointment scheduled. Either via the Clock (calendar) applet on my toolbar, or the command that invokes, "evolution calendar:///?startdate=20100923T040000Z", or other appointment days I've opened where it eventually crashes as well.

Then I copy from within the appointment. I can select all and copy, or highlight one letter and copy, or whatever. It doesn't matter what field - summary, location, both will eventually crash it.

So then I close the appointment out, then close evolution out.

Boom! Segmentation fault.

When I do it in gdb, I get the same stacktrace as is attached here.

welcome to open source =)

On Wed, Sep 8, 2010 at 10:38 AM, Dennis Sheil <email address hidden>wrote:

> I can reproduce this at will.
>
> First I open evolution to a date on which I already have an appointment
> scheduled. Either via the Clock (calendar) applet on my toolbar, or the
> command that invokes, "evolution
> calendar:///?startdate=20100923T040000Z", or other appointment days I've
> opened where it eventually crashes as well.
>
> Then I copy from within the appointment. I can select all and copy, or
> highlight one letter and copy, or whatever. It doesn't matter what
> field - summary, location, both will eventually crash it.
>
> So then I close the appointment out, then close evolution out.
>
> Boom! Segmentation fault.
>
> When I do it in gdb, I get the same stacktrace as is attached here.
>
> --
> evolution crashed with SIGSEGV in gtk_widget_get_toplevel()
> https://bugs.launchpad.net/bugs/602828
> You received this bug notification because you are a direct subscriber
> of the bug.
>

I can reproduce this (or at least get the same error message) by:

- Open Evolution mail, leave it in the back ground.
- Accidentally select "contacts" from the upper menu (opens a new contacts window)
- Close the contacts and try to select the original mail window

Didier Roche (didrocks) on 2010-09-14
Changed in evolution (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
David Nelson (commerce) wrote :

I'd just configured a gmail account and it was about to suck down a lot of mail...

Changed in evolution:
importance: Unknown → Critical
bastianr (reich) wrote :

same bug for me. i did not do anything (the client just crashs while indexing 1000+ messages)...

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evolution - 2.30.3-1ubuntu2

---------------
evolution (2.30.3-1ubuntu2) maverick; urgency=low

  * add debian/patches/89_remove_component_id_registration.patch:
    - ignore -c component gconf registration on launching just "evolution"
      (LP: #642244)
  * add debian/patches/91_git_fix_e_shell_ref_counting.patch:
    - should fix a crasher (LP: #602828) when quitting evolution because a bad
      reference counting (backport from evo 2.31)
 -- Didier Roche <email address hidden> Sun, 19 Sep 2010 15:31:34 +0200

Changed in evolution (Ubuntu):
status: Triaged → Fix Released

LinkedIn
------------

Bug,

I'd like to add you to my professional network on LinkedIn.

- Patrick Lindsey

Patrick Lindsey
Student at University of South Florida
Tampa/St. Petersburg, Florida Area

Confirm that you know Patrick Lindsey
https://www.linkedin.com/e/n4dm4a-gfed3eqk-3n/isd/1790169581/qJPO94Qw/

--
(c) 2010, LinkedIn Corporation

Changed in evolution:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.