Please add a scroll bar on the right side of the preferences menu

Bug #560612 reported by linuxnoob18 on 2010-04-11
58
This bug affects 10 people
Affects Status Importance Assigned to Milestone
evolution (Ubuntu)
Low
Unassigned

Bug Description

there needs to be a scroll bar on the right side of the evolution preferences menu as users cannot see some preferences

see attached image for details

papukaija (papukaija) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in evolution.
(With many applications, you can report a future bug directly on the appropriate package by opening the application's "Help" menu and choosing "Report a Problem". https://wiki.ubuntu.com/ReportingBugs)

affects: ubuntu → evolution (Ubuntu)
tags: added: wishlist
summary: - evolution feature needed
+ Please add a scroll bar on the right side of the preferences menu
Changed in evolution (Ubuntu):
importance: Undecided → Low
Ricardo Graça (devius) wrote :

This bug is especially evident and serious on the netbook edition. The preferences window is just too big, and without a good reason for being so. Also the lack of scrollbars on some of the tabs make it impossible to fully use the preferences window to set the preferences. Pages affected that I am aware of:

- General preferences tab in the Email preferences page,
- General preferences tab on Composer preferences page,
- General and Presentation tabs on Calendar and tasks page.

Attached images of evolution on Ubuntu Netbook Edition 10.04 with default theme. Also note that the preferences window is too wide to fit on screen (1024x600) and it's not possible to resize it to shorter lengths, although it is possible to stretch it and note that there isn't a good reason for it to be so wide in the first place.

Ricardo Graça (devius) wrote :
papukaija (papukaija) on 2010-05-11
tags: added: ubuntu-unr
papukaija (papukaija) wrote :

This bug is affecting 2 people. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status.

Changed in evolution (Ubuntu):
status: New → Confirmed

There is ongoing work on making evolution easier to use on small screens in the "Evolution Express" branch. The dialogs for "add new account" have already been improved and are part of evolution in 10.10. The "express mode" should be switched on by default in the netbook edition and you can manually use it by starting evolution with the "--express" command line option.

express mode is default in UNE already

On Sat, Oct 9, 2010 at 2:54 PM, Marcel Stimberg
<email address hidden>wrote:

> There is ongoing work on making evolution easier to use on small screens
> in the "Evolution Express" branch. The dialogs for "add new account"
> have already been improved and are part of evolution in 10.10. The
> "express mode" should be switched on by default in the netbook edition
> and you can manually use it by starting evolution with the "--express"
> command line option.
>
> --
> Please add a scroll bar on the right side of the preferences menu
> https://bugs.launchpad.net/bugs/560612
> You received this bug notification because you are subscribed to
> evolution in ubuntu.
>
> Status in “evolution” package in Ubuntu: Confirmed
>
> Bug description:
> there needs to be a scroll bar on the right side of the evolution
> preferences menu as users cannot see some preferences
>
> see attached image for details
>
>
>

a8ksh4 (spam-dn) wrote :

The initial configuration window does not fit on netbook screen (1024x600). I just installed netbook 10.10 and this is an issue. The first window says "Welcome to evlolution... Click Forward to continue", but the forward button is hidden off of the bottom of the screen. It is accessible by holding alt to move the window around and finding the button, but new users probably won't know how to do this. The window should have a scroll bar or some other dynamic formatting...

Gary Perkins (garyp409) wrote :

This bug should have a higher importance. Even some of the switcher icons are off the screen. Unless you are an advanced user, Evolution is unusable on the netbook edition. As it is, even being an advanced user, it is too...clunky comes to mind. I very much enjoyed Evolution on the desktop, but until these issues are addressed, I will be using other products.

Ricardo Graça (devius) wrote :

The fact that Evolution Express is now the default doesn't solve this bug. Some users might prefer the regular Evolution and then they can't use it because the settings dialog is so poorly designed. There is no reason for it being so big because most of it is just blank space. I already reported which sections on this dialog are affected by this. I can't understand why it is so hard to just add a scroll bar to the interface if everything doesn't fit on the screen, as this already happens in some sections.

Christer (christerdamm) wrote :

I am using Ubuntu Netbook 10.10 on a Samsung Q1Ultra. Why is the Importance of this ticket so low?
I tried using the "Alt" trick to move the dialogs around, but I could still not get the "Evolution Preferences" main dialog to show any buttons at the bottom. Why does this window need to be so tall? Also, what is the reason for locking it so that it cannot be resized?

Rhys Thomas (e-rhys-thomas) wrote :

this bug is still in natty

Ricardo Graça (devius) wrote :

It was mentioned that evolution express was more "usable" in small screens, but evolution express is just plain old evolution with the added ability to resize things, instead of everything being artificially locked to a minimum (big) size, and without the contacts and calendar management, so it's not really a solution at all for this problem. Evolution is still unusable and very hard and clunky to configure on small screens. Luckily thunderbird will be the default email client on future ubuntu versions.

This is well and truly broken and not just on netbooks. Running an Acer laptop in 1280x768 still isn't enough to give access to the "close" button. Clicking on a blank area of the window jumps down to the invisible part BUT the click offsets are wrong and so clicking on the close button doesn't actually close it.

I like evolution but unless you are trying to code it into oblivion then this bug needs a higher priority.

Changed in evolution (Ubuntu):
status: Confirmed → Fix Released
a8ksh4 (spam-dn) wrote :

Hah, awesome! This thread's been going for ~2 years. It's good to see a
fix in place!

On Fri, Aug 10, 2012 at 3:33 PM, linuxnoob18 <email address hidden>wrote:

> ** Changed in: evolution (Ubuntu)
> Status: Confirmed => Fix Released
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/560612
>
> Title:
> Please add a scroll bar on the right side of the preferences menu
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/evolution/+bug/560612/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers