Evolution closes when saves an appointment

Bug #518227 reported by Mannex on 2010-02-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evolution
Fix Released
Critical
evolution (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: evolution

when I pressed Save to save the appointment, Evolution closed completely. Very annoying. Any ideas why this would happen? Is it because I am modifying an already-existing appointment?

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/evolution
Package: evolution 2.26.1-0ubuntu2
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: evolution
Uname: Linux 2.6.28-17-generic i686

Mannex (russ-mannex) wrote :

This bug is an upstream one and it would be quite helpful if somebody experiencing it could send the bug the to the people writing the software. You can learn more about how to do this for various upstreams at https://wiki.ubuntu.com/Bugs/Upstream/GNOME . Thanks in advance!

summary: - NOTABUG Should have better recurring dates
+ Should have better recurring dates
Changed in evolution (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Wishlist
status: New → Confirmed
Angel Abad (angelabad) on 2010-03-11
Changed in evolution:
importance: Undecided → Unknown
status: New → Unknown
Angel Abad (angelabad) on 2010-03-11
Changed in evolution (Ubuntu):
status: Confirmed → Fix Committed
Angel Abad (angelabad) wrote :

From gnome bugzilla:

We already support this -- see the screenshot. Just set your start date to the
second Sunday in May.

Changed in evolution (Ubuntu):
status: Fix Committed → Fix Released

Interesting. I've done it twice now, and both times, when I pressed Save
to save the appointment, Evolution closed completely. Very annoying. Any
ideas why this would happen? Is it because I am modifying an
already-existing appointment?
-
Russ Mannex
<email address hidden>
http://www.mannex.com
707-322-2321

On Fri, 2010-03-12 at 09:59 +0000, Angel Abad wrote:
> >From gnome bugzilla:
>
> We already support this -- see the screenshot. Just set your start date to the
> second Sunday in May.
>
> ** Attachment added: "Screenshot"
> http://launchpadlibrarian.net/40865540/screenshot.png
>
> ** Changed in: evolution (Ubuntu)
> Status: Fix Committed => Fix Released
>

Angel Abad (angelabad) on 2010-03-13
Changed in evolution (Ubuntu):
status: Fix Released → New
summary: - Should have better recurring dates
+ Evolution closes when saves an appointment
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a backtrace following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in evolution (Ubuntu):
importance: Wishlist → Low
status: New → Incomplete

I am assuming the debug package you want me to install would be:
   evolution-dbg 2.26.1-0ubuntu2
Does that sound right? I'm on Jaunty (9.04). Thanks.

-
Russ Mannex
<email address hidden>
http://www.mannex.com
707-322-2321

On Mon, 2010-03-15 at 11:40 +0000, Sebastien Bacher wrote:
> Thank you for taking the time to report this bug and helping to make
> Ubuntu better. Please try to obtain a backtrace following the
> instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload
> the backtrace (as an attachment) to the bug report. This will greatly
> help us in tracking down your problem.
>
> ** Changed in: evolution (Ubuntu)
> Importance: Wishlist => Low
>
> ** Changed in: evolution (Ubuntu)
> Status: New => Incomplete
>

Mannex (russ-mannex) wrote :

Attaching backtrace, etc. Hope this helps.

-Mannex

Mannex (russ-mannex) wrote :

I attached the backtrace to the bug. Hope this helps. To reproduce, I
simply create a calendar appointment and save it. Then, I open it back
up and attempt to make it a recurring appointment. As soon as I press
Save, it segs.

-
Russ Mannex
<email address hidden>
http://www.mannex.com
707-322-2321

On Mon, 2010-03-15 at 11:40 +0000, Sebastien Bacher wrote:
> Thank you for taking the time to report this bug and helping to make
> Ubuntu better. Please try to obtain a backtrace following the
> instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload
> the backtrace (as an attachment) to the bug report. This will greatly
> help us in tracking down your problem.
>
> ** Changed in: evolution (Ubuntu)
> Importance: Wishlist => Low
>
> ** Changed in: evolution (Ubuntu)
> Status: New => Incomplete
>

Angel Abad (angelabad) wrote :

Bug watcher updated, and sended backtrace to gnome bugzilla

Thanks!

description: updated
Angel Abad (angelabad) wrote :

This bug has been fixed in upstream

Thanks!

Changed in evolution (Ubuntu):
status: Incomplete → New
Pedro Villavicencio (pedro) wrote :

upstream report said it should be fixed with 2.26.3 , since karmic and lucid are using evolution 2.28, i'm marking this as fixed. thanks all.

Changed in evolution (Ubuntu):
status: New → Fix Released
Changed in evolution:
importance: Unknown → Critical
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.