Ubuntu

evolution-alarm-notify pops up repeatedly

Reported by bcrowell on 2009-12-30
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
evolution (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: evolution

I log in to a Gnome session, then log out and log in to a different WM (Fluxbox). Every 10 minutes or so, I get a popup dialog box that gives this message:

An error occurred while loading or saving configuration information for evolution-alarm-notify. Some of your configuration settings may not work properly.

When I click for details, I get this:

Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details - 1: Failed to get connection to session: Failed to connect to socket /tmp/dbus-hx4x1jloNZ: Connection refused)

A "ps x" shows that the offending process seems to be evolution-alarm-notify:

 $ ps x
  PID TTY STAT TIME COMMAND
 6889 ? Sl 0:00 /usr/lib/evolution/2.26/evolution-alarm-notify

I don't use Evolution.

This is on jaunty.

 $ uname -a
Linux rintintin 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:58:03 UTC 2009 x86_64 GNU/Linux
$ lsb_release -rd
Description: Ubuntu 9.04
Release: 9.04

What I expected to happen: I shouldn't get Gnome or Evolution dialogs if I'm not using Evolution. A dialog shouldn't keep popping up forever, with no way to make it stop happening.

Pedro Villavicencio (pedro) wrote :

Could you please try to test the same on karmic and comment back? Thanks in advance.

Changed in evolution (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete
bcrowell (launchpadcrowell07) wrote :

I upgraded to karmic, and can no longer reproduce the bug.

Pedro Villavicencio (pedro) wrote :

ok cool, closing the report then. thank you.

Changed in evolution (Ubuntu):
status: Incomplete → Invalid
bcrowell (launchpadcrowell07) wrote :

I spoke too soon when I said this was fixed in karmic. I just got it again today, after upgrading to karmic.

Changed in evolution (Ubuntu):
status: Invalid → Confirmed
Nick McConnell (nckmccnnll) wrote :

I'm getting the dialog in karmic 64-bit, running under VMware Fusion on an iMac. I am using gnome, but not evolution (in fact, I removed it, but that didn't stop the popup).

Matt (segaloco) wrote :

This started happening to me too. It had never happened until I installed KDE. Now it occurs on KDE and GNOME, pretty constantly.

Architecture: i386
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release Candidate i386 (20091020.3)
Package: evolution 2.28.1-0ubuntu2
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 LANG=fi_FI.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-17.54-generic
Uname: Linux 2.6.31-17-generic i686
UserGroups: adm admin audio cdrom dialout dip fax fuse lpadmin netdev plugdev sambashare tape video
XsessionErrors:
 (gnome-settings-daemon:2319): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (nautilus:2375): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (polkit-gnome-authentication-agent-1:2385): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (firefox:2570): GLib-WARNING **: g_set_prgname() called multiple times

tags: added: apport-collected
tags: added: i386
papukaija (papukaija) wrote :

Unfortunately the workaround didn't work for me. I disabled evolution-alarm-notify from startup list which should work.

summary: - evolution-alarm-notify pops up repeatedly; I don't use Gnome or
- Evolution
+ evolution-alarm-notify pops up repeatedly
Matt (segaloco) wrote :

I honestly don't know what I did, but the bug disappeared. I can get some logs eventually, I am just very busy with school, chores, etc...

Michael Vogt (mvo) wrote :

I ran into this during a hardy->lucid upgrade (with cdrom)

tags: added: iso-testing
papukaija (papukaija) wrote :

Is the iso-testing tag really necessary? This bug report was opened for Jaunty and confirmed for Karmic.

description: updated
papukaija (papukaija) on 2010-03-19
tags: added: karmic
tags: added: jaunty lucid
fedesog (fedesog) wrote :

Same problem on Karmic, solved using the workaround from message #9 and restarting.
I reckon saved_state got corrupted somehow during shutdown.

Pedro Villavicencio (pedro) wrote :

Thanks for the report, is this still an issue with latest Natty packages? Please test and comment back, thanks in advance.

Changed in evolution (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Confirmed → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in evolution (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers