Umlaut/Special caracters not imported - .pst-file import (calender, contacts) from outlook XP (German) to Evolution 2.26

Bug #491786 reported by tellapu on 2009-12-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
evolution (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: evolution

I was delighted to see the pst-import implemented in the newest evolution release (2.28.1 with Ubuntu 09.10 Karmic Koala.

1. Unfortunately the umlauts and special characters were not imported (addresses, notes, calender items), but replaced by a ?-character. Is there any solution for that?

ProblemType: Bug
Architecture: i386
Date: Thu Dec 3 16:38:48 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/evolution
Package: evolution 2.28.1-0ubuntu2
ProcEnviron:
 LANGUAGE=en_GB.UTF-8
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-15.50-generic
SourcePackage: evolution
Uname: Linux 2.6.31-15-generic i686

tellapu (tellapu) wrote :
tellapu (tellapu) wrote :

Mistake in the title: I meant Evolution 2.28.1 instead of Evolution 2.26.

Pedro Villavicencio (pedro) wrote :

Thanks for the report, could you attach an example to the report? thanks.

Changed in evolution (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete
tellapu (tellapu) wrote :

Thanks for looking into this. It would safe a lot of working!

tellapu (tellapu) wrote :
Pedro Villavicencio (pedro) wrote :

I'm not able to see the character nor with gedit or evolution for example. could you try to open the file with a text editor and see if you get the same? could be an encoding issue rather than a bug on the application. thanks.

tellapu (tellapu) wrote :

Hi Pedro,

Thanks for checking.
I attached a screenshot how it looks like if I open it in gedit. There is a square with a question mark. I can even copy and paste it to other files or programs. Here I paste it as well: � (I am wondering how it will look like after posting this).
Encoding problems would be easier to solve - I guess or hope.

tellapu (tellapu) wrote :

Attached is the same vcard transfered to a Windows XP computer and opened with Outlook XP.
I would really appreciate any help. If it would be an encoding problem, what can I do to fix this?
May somebody switch the importance to high as it probably affects a lot of people. THANKS.

Pedro Villavicencio (pedro) wrote :

well only option for now is to edit the file with gedit or other utf8 editor, save the file and import it, that's a problem with the file itself and not an evolution or other application encoding one, i'm closing the bug for now, thanks.

Changed in evolution (Ubuntu):
status: Incomplete → Invalid
tellapu (tellapu) wrote :

Dear Pedro,

Thanks for looking into this.
Which file would you open with gedit? I don't import the vcf-card I attached here. I import the addressbook/calender from a pst-file. I can't open the original pst-file or the evolution addressbook.db with gedit.
And even if I can open it, it would be a tremendous work to change hundreds or thousands of special character as all the characters are replaced by only one character � (find and replace won't work).

And again: Which file do you mean with "that's a problem with the file itself"? If I import the addresses in Windows XP with thunderbird I don't have a special character problem, but unfortunately other problems :-).

Any explanation is very welcome!

Changed in evolution (Ubuntu):
status: Invalid → Incomplete
tellapu (tellapu) wrote :

The problem is still there! Do you need any information? I would be really helpful and great if it can be fixed for the next LTS 10.04! Please change Importance to high!

tellapu (tellapu) wrote :

Time flies by, but no activity on this bug. Any tips? I would like to finally move from Windows to Ubuntu and the last piece would be the transfer of the addresses and the calendar, but it still doesn't work with the special character and Umlauts.
Interestingly the import of the outlook csv-file into Evolution (2.28.3) has not problems with the special characters and Umlaut, but there are other issues (e.g. not matching of a lot fields), so I prefer the import of the pst-file.

tellapu (tellapu) wrote :

Hi there! Any tips, anything needed? Please!

tellapu (tellapu) wrote :

Anybody working on this?

tellapu (tellapu) wrote :

PST-import works now again with Evolution 3.2.2 (Ubuntu 11.10,), but still no import of the Umlaut characters. Any help is much appreciated!

Jörg Frings-Fürst (jff-de) wrote :

bug from 2009. Version not more supported.
change status to invalid.

Changed in evolution (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers