Evolution doesn't close when IMAP quota is low

Bug #4438 reported by Ruben Vermeersch on 2005-11-14
6
Affects Status Importance Assigned to Milestone
Evolution
Fix Released
Undecided
Unassigned
evolution (Ubuntu)
Medium
Ubuntu GNOME

Bug Description

I'm checking my emails through IMAP4, from a Cyrus server. When my quota is low, evolution displays a warning (space usage is at 90%). Apart from being shown a thousand times (which is quite annoying), it has the side effect that evolution doesn't close anymore. It greys out, but never completely exits. Only solution: killall evolution, which I don't really like to do :-)

Sebastien Bacher (seb128) wrote :

Thanks for your bug. What version of evolution/ubuntu do you use? Could you get a backtrace of the hang when that happens? You can get it using gdb:
- gdb -p `pidof evolution`
(gdb) thread apply all bt

Are you sure than the hang is due to the quota?

Changed in evolution:
assignee: nobody → gnome
status: New → NeedInfo
assignee: nobody → gnome
status: New → NeedInfo
Ruben Vermeersch (ruben) wrote :

The hangs only appear when the quota warning appears. Technically, it's also not a hang, the app doesn't really freeze: the whole UI becomes insensitive & grey (the usual behavior of evolution when it quits), but it never quits, the window stays there, unusable. When launching a new evo instance, all works fine.

Ruben Vermeersch (ruben) wrote :

I will do a backtrace when I'm out of quota again :-)

Here's a backtrace of a frozen evolution, hopefully this will be of any use.

Lionel Dricot (ploum) wrote :

I confirm that this bug was happening for me too. But it appears to be solved, at least for me, in the current Dapper.

Can you try with the latest evo and e-d-s packages and confirm that you have still this bug ?

Ruben Vermeersch (ruben) wrote :

I changed my setup & filtering methods so I don't run into this anymore (my imap doesn't get filled anymore now), so I can't really test it.

Feel free to close it, if it's still there we can always reopen it.

Cheers,
     Ruben

Lionel Dricot (ploum) wrote :

As I don't have the issue anymore nor the initial reporter, I close this bug. If anybody can reproduce the bug, feel free to reopen.

Changed in evolution:
status: Needs Info → Fix Released
Changed in evolution:
assignee: gnome → nobody
status: Unconfirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments