Google calendar support broken; repeatedly asks for password

Bug #436731 reported by Martin-Éric Racine on 2009-09-25
82
This bug affects 17 people
Affects Status Importance Assigned to Milestone
evolution (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: evolution

Since Evolution 2.27 was replaced by 2.28 in Karmic, connecting to my Google calendars no longer works. Evo repeatedly asks for the password. Running it from command line shows the following 3 lines repeating themselves, every time Evo asks for the password and I enter it:

$ LC_ALL=C evolution
e-data-server-ui-Message: Unable to find password(s) in keyring (Keyring reports: No matching results)
e-data-server-ui-Message: Key file does not have key 'caldav:__m.e.racine%<email address hidden>com_calendar_dav_m.e.racine@gmail.com_events'
e-data-server-ui-Message: Unable to find password(s) in keyring (Keyring reports: No matching results)
e-data-server-ui-Message: Key file does not have key 'caldav:__m.e.racine%<email address hidden>com_calendar_dav_m.e.racine@gmail.com_events'
e-data-server-ui-Message: Unable to find password(s) in keyring (Keyring reports: No matching results)
e-data-server-ui-Message: Key file does not have key 'caldav:__m.e.racine%<email address hidden>com_calendar_dav_m.e.racine@gmail.com_events'
e-data-server-ui-Message: Unable to find password(s) in keyring (Keyring reports: No matching results)
e-data-server-ui-Message: Key file does not have key 'caldav:__m.e.racine%<email address hidden>com_calendar_dav_m.e.racine@gmail.com_events'

ProblemType: Bug
Architecture: i386
Date: Fri Sep 25 19:23:50 2009
DistroRelease: Ubuntu 9.10
Package: evolution 2.28.0-0ubuntu2
ProcEnviron:
 LANGUAGE=fi_FI.UTF-8
 PATH=(custom, user)
 LANG=fi_FI.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-10.35-generic
SourcePackage: evolution
Uname: Linux 2.6.31-10-generic i686

Martin-Éric Racine (q-funk) wrote :
Changed in evolution (Ubuntu):
importance: Undecided → Low
Ryan Steele (rgsteele) on 2009-10-23
Changed in evolution (Ubuntu):
status: New → Confirmed
Ryan Steele (rgsteele) wrote :

I can confirm. I tried deleting my Google calendars and re-adding them. When adding a calendar, Evolution prompts for a password to retrieve the list of calendars associated with the Google account. This part still works. However, once the calendar is selected, the repeated prompts for the password begin.

Workaround: Use CalDAV, as documented here: http://www.google.com/support/calendar/bin/answer.py?hl=en&answer=99358. Google doesn't have instructions specifically for Evolution but the instructions for Sunbird/iCal are fairly easily adapted for Evolution.

According to https://bugzilla.gnome.org/show_bug.cgi?id=583374 it is intended that CalDAV replace the Google Calendar import. In fact, https://bugzilla.gnome.org/show_bug.cgi?id=588856 indicates that code was committed in 2.27.5 to migrate Google Calendar accounts to CalDAV. So I guess the question is, why is this not working?

summary: - Googel calendar support broken; repeatedly asks for password
+ Google calendar support broken; repeatedly asks for password
Mathieu Gauthier (oustedaisse) wrote :

Same issue, regression since Jaunty :(

Marco Meyer (marco-meyer) wrote :

confirmed...

same story. . .even checking the ssl option doesn't work. besides, after closing the properties window and going back the https: part in the link changes to caldav: again. not sure if that makes a difference though

Mathieu Gauthier (oustedaisse) wrote :

And so... no fix ? :(

easybeat (beat-wuethrich) wrote :

I have the same problem...is there no fix for it?

Ryan Steele (rgsteele) wrote :

Eshwar, Mathieu and easybeat: Just manually remove your Google Calendar account and re-add it as a CalDAV account. The bug is that this should have happened automatically.

Alex Peters (alex-peters) wrote :

This issue persists in Oneiric.

Jake (jmiheve) wrote :

Confirming that this is still persisting in Oneiric. I had to reboot my computer to get it to stop.

Also, it won't let me delete all the Google Calendar accounts, and at one point, one calendar that I had deleted *reappeared* after the password prompt came up! WTF!?!?!?!?

old_toby (simon-hornweb) wrote :

Well that problem only STARTED with oneiric. With natty, I had no problems like that.

This makes ubuntu totally unusable, this ist TOTAL BULLSHIT! Sorry for my words, but these are the only ones that fit. Please make it HIGH priority and solve it ASAP.

PeMaGonGo (pemagongo) wrote :

As old_toby noticed this bug was not present on 11.04 and as he said I would set this as High priority. Although evolution was replaced by Thunderbird, it is still the better PIM software.

Simon (simschi) wrote :

I have the same problems here:
* can not delete a cal
* a cal reappeared
* it asks for the password every other secound

@PeMaGonGo: Oh, and I just wondererd where this birdy appeared from and shot it down. ;-)

Smeagol (gollum12345678) wrote :

This week it started happening to me on Ubuntu 12.04 with Evolution 3.2.3.

It was asking the password all the time, even when I can get the right list of calendars for my account.

Ryan Hansen (ketiko) wrote :

I'm having the same problem.

Ubuntu 13.04
Evolution 3.6.4
Gnome Shell 3.8.1

Jörg Frings-Fürst (jff-de) wrote :

change status to Fix released (see gnome-bugs)

Changed in evolution (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.