Evolution not restoring data from backup archive

Bug #408603 reported by Andrey Zhekov on 2009-08-03
38
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Evolution
Fix Released
High
evolution (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: evolution

Ubuntu 9.10 a3
Evolution 2.27.5-0ubuntu1

I tried to restore my email from Evolution 2.26 archive (from Ubuntu 9.04) - the process began and after few seconds it looks like it's over and OK but after a second the archive import wizard pops up again and I repeated the procedure - no luck.
Than I've created a null account and tried to restore my email through the File > Restore... - the same thing

Related branches

description: updated
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in evolution (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
Andrey Zhekov (x3ro.daemon) wrote :
Changed in evolution:
status: Unknown → Incomplete
Changed in evolution (Ubuntu):
status: New → Triaged
Andrea Caminiti (nrayever) wrote :

Hi guys:

i'm having the same issue. Is there any work around? So i can continue using my mail.

Regards Andrea

Andrey Zhekov (x3ro.daemon) wrote :
Changed in evolution:
status: Incomplete → Fix Committed
Andrey Zhekov (x3ro.daemon) wrote :

diff --git a/plugins/backup-restore/backup.c b/plugins/backup-restore/backup.c
index f285938..ca7ab29 100644
--- a/plugins/backup-restore/backup.c
+++ b/plugins/backup-restore/backup.c
@@ -324,7 +324,7 @@ check (const gchar *filename)

  g_message ("Third result %d", result);

- return result != 0;
+ return result == 0;
 }

 static gboolean

Flavelle (flavelle.ballem) wrote :

Sorry, relatively new to bug reporting process.

If I'm reading the notes above correctly, then supposedly the problem is fixed.

I just did an absolutely clean install of Karmic Alpha 4, with all updates applied prior to trying to set up Evolution from a backup file. It did not work.

This is important that this works, since this is one important function for those of us who do clean installations to update ubuntu to a new release.

evolution 2.27.90-0ubuntu2 is the version that is installed.

Thanks,

Andrey Zhekov (x3ro.daemon) wrote :

As it has been said in the Bugzilla "...Created commit 15c0690 in evo gnome-2-28 (2.27.92+)..."
So, wait for evolution 2.27.92+.The fix is not released,it's only committed. We'll have to wait

Changed in evolution (Ubuntu):
status: Triaged → Fix Committed
status: Fix Committed → Triaged
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evolution - 2.27.92-0ubuntu1

---------------
evolution (2.27.92-0ubuntu1) karmic; urgency=low

  * New upstream version
    Mail:
    - #494531 - Use quoted-printable encoding when necessary
    - #593872 - Forgets which signature is assigned to which account
    Calendar:
    - #592873 - Initialize Force Read only check state properly
    Miscellaneous:
    - #590687 - Evolution not restoring data from backup archive (lp: #408603)
    - #592335 - Submit bug-report doesn't work
    Other Fixes:
    Fix discrepancy wrt what's actually in the UI
    Fix return types to match the type of function
    Support for Anjal to have provider specific options in acc editor
    Translations
  * debian/control:
    - updated eds requirement
  * debian/patches/90_autoconf.patch:
    - new upstream version

 -- Sebastien Bacher <email address hidden> Mon, 07 Sep 2009 15:49:19 +0200

Changed in evolution (Ubuntu):
status: Fix Committed → Fix Released
Flavelle (flavelle.ballem) wrote :

I am confirming that the bug was fixed. I did a clean installation of karmic Alpha 5, then applied all updates - including Evolution.

When I started Evolution, I was able to restore from backup and all mail, calendar, settings, etc. were correctly restored.

Many thanks for your efforts on this!

tags: added: iso-testing
Dave Morley (davmor2) wrote :

Bug is still an issue here. I have found a work around for those who still have issues.

Extract the tar.gz file into a folder foo.
Hit ctrl+h to show hidden files/folders
Open the .evolution folder.
Copy the backup-restore-gconf.xml into foo.
highlight the 3 item now in the foo folder.
Right click and select compress.
Call it evolution-backup.tar.gz.
Now direct evolution to the foo folder and the new evolution-backup.tar.gz file.

Magically it now works.

Changed in evolution:
importance: Unknown → High
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Patches

Remote bug watches

Bug watches keep track of this bug in other bug trackers.