Ubuntu

Opening dialogs, really slow

Reported by Ian Cornwall on 2009-04-23
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
evolution (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: evolution

It takes 30 seconds or so to open any dialogs or windows. It isn't on all windows. Here are the ones I have seen so far. Preferences, Plugins, Composing a new email.

evolution:
  Installed: 2.26.1-0ubuntu1

Running Ubuntu 9.04

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/evolution
NonfreeKernelModules: nvidia
Package: evolution 2.26.1-0ubuntu1
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
SourcePackage: evolution
Uname: Linux 2.6.28-11-generic x86_64

Ian Cornwall (ian-ianinit) wrote :
Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a valgrind log following the instructions at https://wiki.ubuntu.com/Valgrind and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in evolution (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete
Ian Cornwall (ian-ianinit) wrote :

Here's the log

Sebastien Bacher (seb128) wrote :

is the issue specific to evolution only? do you have it using an another user account on the same box? that's somewhat an issue on your configuration since nobody else has that bug. do you run evolution locally or over ssh or vnc?

Ian Cornwall (ian-ianinit) wrote :

It is specific to evolution. Everything else is fine. I haven't tried another user account. I'll try that. I run it locally.

Greg (gregb1) wrote :

I'm experiencing similar symptoms, especially over ssh. For example, clicking on "Reply" takes about 20-25 seconds for the window to open over remote X. It's faster locally, but still noticeably slow (around 5 seconds).

Brian Atkins (briansrapier) wrote :

Same here. Just upgraded to 9.04 and Evolution (Exchange) hangs on start and hangs 45-60 seconds when trying to compose a new message. I have read another account whereby downgrading the kernel to 2.6.27-14, but haven't attempted that as of yet. Other apps do seem a bit slower (ghb - handbrake), but don't have any specifics.

Ran:
G_SLICE=always-malloc G_DEBUG=gc-friendly valgrind -v --tool=memcheck --leak-check=full --num-callers=40 --log-file=valgrind.log --track-origins=yes --leak-check=full --show-reachable=yes evolution

and obtained the attached log.

Brian Atkins (briansrapier) wrote :

Further checks seem to indicate errors with the window or file manager. I have tried launching various applications, each appears to be a bit slower than with Ibis (I know how subjective that sounds). Also, when attempting to do an action such as "file->open" which requires opening the file manager, things crawl.

I switched from Nautilus to Thunar and have the same results.

Brian Atkins (briansrapier) wrote :

Disabling IPV6 seems to fix the issue. It's built into the kernel instead of being a module in previous versions. Trying to disable it using sysctl.conf following the Ubuntu wiki won't work as the location of disable_ipv6 has moved.

Here is what I did:

Temp fix:
echo 1 > /proc/sys/net/ipv6/conf/all/disable_ipv6

More permanent workaround:
# vi /etc/sysctl.conf

add:

net.ipv6.conf.all.disable_ipv6 = 1

Workaround suggested by Brian Atkins doesn't work here. Hitting New mail or Reply still takes about 45 seconds. Hitting "open" on a standard gtk program is still slow (about 10 seconds).

Sebastien Bacher (seb128) wrote :

could somebody having the issue get a stacktrace using gdb while it's hanging?

Download full text (12.5 KiB)

hmm...never thought you could do that. Excellent. Pasted below (stuck in some dbus call). This is from clicking on the 'New' button (ie compose).

(gdb) bt
#0 0xb7fa9430 in __kernel_vsyscall ()
#1 0xb6973ae7 in poll () from /lib/tls/i686/cmov/libc.so.6
#2 0xb6b1fbeb in ?? () from /lib/libdbus-1.so.3
#3 0xb6b17cd7 in ?? () from /lib/libdbus-1.so.3
#4 0xb6b15ebf in ?? () from /lib/libdbus-1.so.3
#5 0xb6b0092e in ?? () from /lib/libdbus-1.so.3
#6 0xb6b02f83 in ?? () from /lib/libdbus-1.so.3
#7 0xb6b101f1 in dbus_pending_call_block () from /lib/libdbus-1.so.3
#8 0xb6b381cf in ?? () from /usr/lib/libdbus-glib-1.so.2
#9 0xb6b38c0e in dbus_g_proxy_call () from /usr/lib/libdbus-glib-1.so.2
#10 0xb3cd74ff in tracker_get_version () from /usr/lib/libtrackerclient.so.0
#11 0xb725e8f8 in _gtk_search_engine_tracker_new () at /build/buildd/gtk+2.0-2.16.1/gtk/gtksearchenginetracker.c:305
#12 0xb6fe5997 in _gtk_search_engine_new () at /build/buildd/gtk+2.0-2.16.1/gtk/gtksearchengine.c:119
#13 0xb706f785 in gtk_file_chooser_default_constructor (type=160791840, n_construct_properties=1, construct_params=0x9e8c3e8)
    at /build/buildd/gtk+2.0-2.16.1/gtk/gtkfilechooserdefault.c:234
#14 0xb6ac5c26 in IA__g_object_newv (object_type=160791840, n_parameters=0, parameters=0x0)
    at /build/buildd/glib2.0-2.20.1/gobject/gobject.c:1215
#15 0xb6ac67e7 in IA__g_object_new_valist (object_type=160791840, first_property_name=0x0, var_args=0xbf8c4fd8 "")
    at /build/buildd/glib2.0-2.20.1/gobject/gobject.c:1278
#16 0xb6ac695e in IA__g_object_new (object_type=160791840, first_property_name=0x0) at /build/buildd/glib2.0-2.20.1/gobject/gobject.c:1060
#17 0xb705db47 in _gtk_file_chooser_default_new () at /build/buildd/gtk+2.0-2.16.1/gtk/gtkfilechooserdefault.c:11310
#18 0xb70746a6 in gtk_file_chooser_widget_constructor (type=158602832, n_construct_properties=1, construct_params=0x9e8c3a8)
    at /build/buildd/gtk+2.0-2.16.1/gtk/gtkfilechooserwidget.c:103
#19 0xb6ac5c26 in IA__g_object_newv (object_type=158602832, n_parameters=0, parameters=0x0)
    at /build/buildd/glib2.0-2.20.1/gobject/gobject.c:1215
#20 0xb6ac67e7 in IA__g_object_new_valist (object_type=158602832, first_property_name=0x0,
    var_args=0xbf8c5218 "���\t�\037���\233\206\t\034��\tX�S\t�\037���\233\206\t\034��\thS\214�&\\���\213A\t\003")
    at /build/buildd/glib2.0-2.20.1/gobject/gobject.c:1278
#21 0xb6ac695e in IA__g_object_new (object_type=158602832, first_property_name=0x0) at /build/buildd/glib2.0-2.20.1/gobject/gobject.c:1060
#22 0xb706fdb5 in gtk_file_chooser_dialog_constructor (type=155290568, n_construct_properties=3, construct_params=0x9e8c090)
    at /build/buildd/gtk+2.0-2.16.1/gtk/gtkfilechooserdialog.c:272
#23 0xb6ac5c26 in IA__g_object_newv (object_type=155290568, n_parameters=2, parameters=0x9e8c610)
    at /build/buildd/glib2.0-2.20.1/gobject/gobject.c:1215
#24 0xb6ac6812 in IA__g_object_new_valist (object_type=155290568, first_property_name=0xb7265a74 "title", var_args=0xbf8c5444 "")
    at /build/buildd/glib2.0-2.20.1/gobject/gobject.c:1319
#25 0xb6ac695e in IA__g_object_new (object_type=155290568, first_property_name=0xb7265a74 "title")
    at /build/buildd/glib2.0-2.20.1/gob...

Sebastien Bacher (seb128) wrote :

the stacktrace indicates the issue is due to tracker, is that one installed and running?

Brian Atkins (briansrapier) wrote :

@Alejandro Dubrovsky

Yes. I found out this morning that it was back to it's previous slowness despite having set the net.ipv6.conf.all.disable_ipv6 flag to '1'. I did look a little deeper and discovered that there are multiple 'disable_ipv6' sysctl settings:

net.ipv6.conf.all.disable_ipv6
net.ipv6.conf.default.disable_ipv6
net.ipv6.conf.lo.disable_ipv6
net.ipv6.conf.eth0.disable_ipv6
net.ipv6.conf.wmaster0.disable_ipv6
net.ipv6.conf.wlan0.disable_ipv6

I have gone ahead and disabled them all (not sure if it will affect anything else) and rebooted. I now have:
# sysctl -a | grep -i disable_ipv6
...
net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1
net.ipv6.conf.eth0.disable_ipv6 = 1
net.ipv6.conf.wmaster0.disable_ipv6 = 1
net.ipv6.conf.wlan0.disable_ipv6 = 1

Following reboot, selecting 'compose', 'reply', or 'reply to all' results in a new window opening within 1-2 seconds.

I'll post changes in my situation.

Brian Atkins (briansrapier) wrote :

Just as an update: after 2+ hours with no apparent changes in the performance of evolution, I decided to see what would happen by turning them back off and then re-enabling the switches 1 at a time. This particular one seems to have the most effect:

net.ipv6.conf.lo.disable_ipv6

I'm wondering if this isn't an issue with applications being able to communicate with X/xorg due to issues with IPV6.

@Sebastian Bacher
Yes, tracker was installed and running. Even better, killing trackerd solves the problem. New, Reply, etc from evolution and standard open file from other programs back to being instantaneous.

@Brian Atkins
Restarting trackerd doesn't seem to bring back the problem, so I can't tell if the ipv6 solution also works here. Sorry.

Thank you both for looking into it.

Brian Atkins (briansrapier) wrote :

I would be interested to know if people experiencing issues with Evolution are also affected by the xserver-xorg-video-intel bug (https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/359392).

Brian Atkins (briansrapier) wrote :

Despite disabling IPV6 there were still some lingering issues with Evolution performance, especially for actions requiring the opening of a new window or menu item.

I have been following bug 359392 as it also affects me to an extent. By chance, yesterday, while researching the other issue, I found a post on the Ubuntu forums related to Intel X issues (http://ubuntuforums.org/showthread.php?t=1130582). After making the changes listed in the post, including a new kernel from the ubuntu-x-swat PPA, I haven't experienced a single issue with Evolution. It appears that a lot of the built-in X options in the previous kernel were unset for the new kernel. I'm trying to get a list of the actual changes from the admin of the packages.

Though it's still just an educated guess, I suspect that this bug is actually an upstream issue with xorg, kernel options, or possibly intel video drivers.

@Brian Atkins
Not running an intel card here, so no (to related ticket affecting me).

Sebastien Bacher (seb128) wrote :

could you try if that's still an issue in karmic?

I no longer have the laptop on which this issue originally presented
itself. I'll change my status regarding this bug later today.

Pedro Villavicencio (pedro) wrote :

Thanks for the report, it has been some time without any response or feedback in this bug report and we are wondering if this is still an issue for you with the latest release of Ubuntu the Natty Narwhal, May you please test with that version and comment back if you're still having or not the issue? Please have a look at http://www.ubuntu.com/download to know how to install that version.Thanks in advance.

I don't use evolution any more, but I just fired it up to check if the bug is still there, and it seems to have been fixed. So many things have changed with my setup though, that it is hard to tell if I'm testing the same thing.

natraj (pnatraj) wrote :

Same as Alejandro Dubrovsky, i have moved out of evolution.

Thanks
Natraj

Jörg Frings-Fürst (jff-de) wrote :

bug from 2009. Version not more supported.
change status to invalid.

Changed in evolution (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers