folders.db gets out of sync with mail server

Bug #346352 reported by Wowbagger on 2009-03-21
44
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Evolution
Fix Released
Critical
evolution (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: evolution

Evolution stores local information about IMAP server directories in ~/.evolution/mail/imap/<server name>/folders.db

This file will frequently get corrupted and out of sync with the real number of messages in the folders on the server. Doing a "Send/Receive" does NOT correct the problem, nor does actually viewing the contents of the folder - e.g. the folder count will show 2 unread messages, when opening the folder shows no messages at all, and even after opening the folder the count will show 2 unread messages.

Again: neither expunging the directory, closing and restarting Evolution, nor doing a send and receive will clear the erroneous counts.

Shutting down Evolution, deleting the folders.db file, and restarting Evolution will clear the problem.

NOTE: Unlike some of the other bug reports, no error messages are presented to the user in this case.

Steps to reproduce:
Given a working IMAP setup with Evolution, update all folders, then kill evolution (e.g. killall -KILL evolution).

Expected results:
Upon restart Evolution should rebuild the counts in all the folders.

Actual results
Evolution shows bogus counts on many (but not all) folders.

Reproducibility: High, if not every time.

Description: Ubuntu 8.10
Release: 8.10

Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
ii evolution 2.24.3-0ubuntu groupware suite with mail client and organiz
ii evolution-comm 2.24.3-0ubuntu architecture independent files for Evolution
ii evolution-data 2.24.3-0ubuntu evolution database backend server
ii evolution-data 2.24.3-0ubuntu architecture independent files for Evolution
un evolution-data <none> (no description available)
un evolution-data <none> (no description available)
ii evolution-dbg 2.24.3-0ubuntu debugging symbols for Evolution
pn evolution-exch <none> (no description available)
un evolution-exch <none> (no description available)
ii evolution-plug 2.24.3-0ubuntu standard plugins for Evolution
un evolution-plug <none> (no description available)
ii evolution-webc 2.24.0-0ubuntu webcal: URL handler for GNOME and Evolution

Sebastien Bacher (seb128) wrote :

thank you for your bug report, could you send the issue to bugzilla.gnome.org where the people writting evolution will read it too since you have a configuration triggering the bug?

Changed in evolution (Ubuntu):
assignee: nobody → desktop-bugs
importance: Undecided → Low
Changed in evolution (Ubuntu):
status: New → Triaged
Changed in evolution:
status: Unknown → New
Changed in evolution:
status: New → Invalid
Wowbagger (ha87psc02) wrote :

May I ask why this has been marked "Invalid" - the bug still exists, and is reproducible.

Sebastien Bacher (seb128) wrote :

you could click on the upstream bug and read the reason directly rather than ask there

Wowbagger (ha87psc02) wrote :

I did - and if YOU had looked at the upstream bug, you would have seen that
a) the first bug was incorrectly marked as a dup of a bug having to do with search folders rather than actual IMAP folders.
and
b) the second bug is still not resolved

Wowbagger, the bug is "invalid" because it was marked as a duplicate and launchpad there is no status named "upstream duplicate" in launchpad. The last comment on the upstream bug (stating that it's not a duplicate) was on 2009-07-16 so it will likely be marked as not being a duplicate when a developer reads that. Don't worry about your bug ;)

Omer Akram (om26er) wrote :

thanks for the bug report. can you please check if the issue is still there in Ubuntu 10.04 or preferably evolution 2.30

Changed in evolution (Ubuntu):
status: Triaged → Incomplete
John Rose (johnaaronrose) wrote :

Issue still in Lucid.

John Rose (johnaaronrose) wrote :

Created evo.log using CAMEL

PS Due to problem I'm having with Launchpad in that it doesn't show bugs that I have reported as part of My Bugs nor does it send me email about them, there may be duplicates of this.

Changed in evolution:
importance: Unknown → Medium
status: Invalid → Unknown
Jeff Fortin Tam (kiddo) wrote :

As per comment #8.

Changed in evolution (Ubuntu):
status: Incomplete → Confirmed
Jeff Fortin Tam (kiddo) wrote :

FWIW, also happens with 2.30.3.

Jeff Fortin Tam (kiddo) wrote :

https://bugzilla.gnome.org/show_bug.cgi?id=543389 is the upstream tracker bug for all disk-summary related bugs...

Changed in evolution:
importance: Medium → Unknown
Changed in evolution:
importance: Unknown → Critical
status: Unknown → Confirmed
Randy Barlow (rbarlow) wrote :

I also observe this behavior with the evolution-mapi plugin. It is not just a problem with IMAP.

Sarastro (sa3p83) wrote :

I have the IMAP snyc problem on both a 10.4 and a 10.10 machine using the same IMAP server. Killing Evolution and deleting the folder.db file restores and updates the Evolution folders but is this the only solution to this bug?

Stefano Bagnatica (thepisu) wrote :

I had the same issue with Evolution 3.2.1, and solved deleting the file folders.db inside ~/.local/share/evolution/mail/1295611670.31535.6@cvs28.

So now the folders.db is no more in evolution/mail/imap, but in evolution/mail/GUID.

Stefano Bagnatica (thepisu) wrote :

Update: the problem is not solved, also deleting folders.db file... I continue to receive the error message...

Jörg Frings-Fürst (jff-de) wrote :

change status to Fix released (see gnome-bugs)

Changed in evolution (Ubuntu):
status: Confirmed → Fix Released
Changed in evolution:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.