crash when configuring evolution mapi (exchange 2007) account

Bug #333855 reported by Igor on 2009-02-24
62
This bug affects 2 people
Affects Status Importance Assigned to Milestone
evolution mapi
Fix Released
Unknown
evolution (Ubuntu)
Medium
Unassigned
openchange (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: evolution

Evolution crashed in first time wizard when I configured evolution to work with mapi (exchange 2007) account.
I can configured imap (another server) but then evolution crash (another crash) when I access Edit->Preferences. Both crashes reproducible.

ProblemType: Crash
Architecture: i386
CrashCounter: 1
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/evolution
Package: evolution 2.25.91-0ubuntu2
ProcCmdline: evolution --component=mail
ProcCwd: /home/igor
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 4
SourcePackage: evolution
StacktraceTop:
 ?? ()
 ?? () from /usr/lib/libdcerpc.so.0
 ?? () from /usr/lib/libdcerpc.so.0
 ?? () from /usr/lib/libdcerpc.so.0
 ?? () from /usr/lib/libdcerpc.so.0
Title: evolution crashed with SIGILL
Uname: Linux 2.6.28-8-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Igor (xrevolver) wrote :

StacktraceTop:?? ()
free_mccache (ccc=0x8c74430)
_talloc_free (ptr=0x8c74430) at ../lib/talloc/talloc.c:515
_talloc_free (ptr=0x90b1830) at ../lib/talloc/talloc.c:546
_talloc_free (ptr=0x903cf38) at ../lib/talloc/talloc.c:546

Sebastien Bacher (seb128) wrote :

that's not an evolution issue but an evolution-mapi one

Changed in evolution:
importance: Undecided → Medium
status: New → Invalid
Igor (xrevolver) wrote :

Same bug reported on gnome bugzilla:

http://bugzilla.gnome.org/show_bug.cgi?id=571579

Igor (xrevolver) on 2009-02-25
Changed in evolution-mapi:
importance: Undecided → Unknown
status: New → Unknown
Changed in evolution-mapi:
status: Unknown → Confirmed
Pedro Villavicencio (pedro) wrote :

Thanks for sent it there.

Changed in evolution-mapi:
importance: Undecided → Medium
status: New → Triaged
Sebastian Martinez (tychocity) wrote :

i confirm the same error in exchange 2003 account.

Joshua Duan (joshua-duan) wrote :

I can confirm the same error, it happened during creation of exchange 2007 account.

=========================================================================
Logging into the server... (no debugging symbols found)
succeeded
libexchangemapi-Message: exchange-mapi-connection.c:146: exchange_mapi_connection_close: lock(connect_lock)

Program received signal SIGSEGV, Segmentation fault.
=========================================================================

My build:
Distro: Jaunty alpah 5 with all latest updates.

Evolution versidpkg -l | grep evolution
ii evolution 2.26.0-0ubuntu2 groupware suite with mail client and organiz
ii evolution-common 2.26.0-0ubuntu2 architecture independent files for Evolution
ii evolution-data-server 2.26.0-0ubuntu1 evolution database backend server
ii evolution-data-server-common 2.26.0-0ubuntu1 architecture independent files for Evolution
ii evolution-documentation-en 2.26.0-0ubuntu2 documentation for Evolution
ii evolution-exchange 2.26.0-0ubuntu2 Exchange plugin for the Evolution groupware
ii evolution-indicator 0.1.10-0ubuntu1 GNOME panel indicator applet for Evolution
ii evolution-mapi 0.25.92-0ubuntu1 Evolution extension for MS Exchange 2007 ser
ii evolution-plugins 2.26.0-0ubuntu2 standard plugins for Evolution
ii evolution-plugins-experimental 2.26.0-0ubuntu2 experimental plugins for Evolution
ii evolution-webcal 2.26.0-0ubuntu1 webcal: URL handler for GNOME and Evolution
ons:

Cheers
Joshua

James Ward (jamesward) wrote :

Same problem here. I just updated to evolution-mapi-0.26.0.1-0ubuntu1 and it's still crashing evolution when I try to setup my Exchange account.

Sebastian Martinez (tychocity) wrote :

Same problem, exchange 2003.

AinSon (ainson) wrote :

i can confirm this problem
platform is amd64

Rob Adams (readams) wrote :

Upstream bug reports that this is fixed in libmapi 0.8.2

I tried this just now. Ubuntu 9.04, Evolution 2.26.1, libmapi0 1:0.8.2ubuntu1. I get the segmentation fault when authenticating to my Exchange 2003 server.

Changed in evolution-mapi:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.