Not all birthdays are shown

Bug #324043 reported by Kim Alvefur on 2009-02-01
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Evolution
Fix Released
High
evolution (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: evolution

Not all birthdays for contacts are shown in the calendar view, or the clock-applet.
I tried going through all my contacts and setting the birth date +1 day and back again so I could save. This appears to temporarily fix the issue for that contact, until I had gone through all contacts and found that it had forgotten about some of them again.

I got this in terminal after doing "evolution --force-shutdown; evolution" and then unchecking and checking the checkbox for Birthdays and Anniversaries:
(evolution:17603): calendar-gui-WARNING **: gnome-cal.c:910: Could not create the query: Backend is busy

And after doing "evolution --force-shutdown; evolution" again that disappeared and I got this instead:

calendar-gui-Message: Check if default client matches (1193913009.6096.11@rutilus 1193913009.6096.11@rutilus)

Changed in evolution:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Triaged
Changed in evolution:
status: Unknown → Confirmed
Changed in evolution:
status: Confirmed → Invalid
Changed in evolution:
status: Invalid → New
Changed in evolution:
status: New → Confirmed
iMac (imac-netstatz) wrote :

I have at least one contact where their birthdate is missing. In my case, two contacts share October 21st, one 1981-10-21, the other 1977-10-21. Both are in the same group. the 1981 date was missing on the calendar, so I changed back to 9-21 and forwards again and it appeared to resolve the issue temporarily

LorenM (elspamocollector) wrote :

I have someone in my contacts with a birthday of 4-25 and I do not know what year they were born so I entered 2010. I have another contact with a birthday of 4-5 and I also do not know what year they were born so I also put 2010 for the year. For the contact with the birthday of 4-5, I see the reminder in the calendar. For the contact with the birthday of 4-25, I only see a reminder in the calendar when I change the year during the current session of Linux running; if I restart the computer, I no longer see the 4-25 birthday reminder in the calendar. I tried changing the years for the 4-25 birthday to 2009 then 2008 and I only see the reminder in the calendar during the current session of Linux running.

I do not know how to generate a bug report and post it to the correct place. If you need more information, please contact me with instructions.

Changed in evolution:
status: Confirmed → Incomplete
Pedro Villavicencio (pedro) wrote :

Could somebody test the same on Maverick? Upstream is asking for testing on 2.30 which is there right now, thanks in advance.

iMac (imac-netstatz) wrote :

I'll give it a whirl.. using this PPA.. add-apt-repository ppa:jacob/evo230

iMac (imac-netstatz) wrote :

It looks like it is working better.. I have never seen so many birthdays in list view :) I have at lease one failure still. Two contacts with birthdays on May 21st .. only one of them (earlier year by date?) shows up. I know if I refresh it will appear.. but I'll wait to leave this for a future test case since I had trouble finding any others.

Changed in evolution:
status: Incomplete → Fix Released
LorenM (elspamocollector) wrote :

I received the message that there is a fix, not showing all birthdays in the calendar. I installed an Evolution update last week, but I have at least two birthdays that are not showing in the calendar at this time. One on April 2, (04/02/1951) and one on July 14 (07/14/1955). I notice that if I change something about the 7-14 contact it immediately shows up in the calendar, but if I close Evolution and reopen it the birthday no longer shows in the calendar.

On 2010-05-04, I mentioned that a 4-25 birthday did not show in the calendar, but before the update, it reappeared in the calendar. I suspect there is an impact of the system date changing if a specific contact date appears in the calendar. I left the 4-25 birthday with a year of 2008 since I reported the bug. I believe the 4-25 birthday contact reappeared in the calendar on the correct date about a month after their birthday, sometime late in May, and I believe the 4-25 birthday continued to show in the calendar after it reappeared before the update to Evolution. The 4-25 birthday is still showing in the calendar after the update.

LorenM (elspamocollector) wrote :

I just found another birthday that does not show on the calendar, 09/10/1960. The previous birthday that shows on my calendar is 08/30/1945 and the next birthday that shows is 09/18/1961.

LorenM (elspamocollector) wrote :

And yet another missing birthday, 11/04/1937. The previous birthdays that shows on my calendar is 11/03/1946 and 11/03/1951, one of these has an anniversary in June. The next birthday that shows is after the birthday on 11/04/1937 is 11/11/1937. I did not check to see if there are any other birthdays missing between the 4th and the 11th.

Changed in evolution:
importance: Unknown → High
LorenM (elspamocollector) wrote :

I have more birthday anomalies. The person with the birthday on 09/18/1961 shows up in the calendar, but birthdays on 09/18/1929 and 09/19/1951 do not.

Sekt fault (the-pulse) wrote :

I have the same problem with natty. It's a WebDAV addressbook. As soon as I open a contact and save it, the birthday is dispayed in the calendar. The addressbook is marked to be downloaded for offline work, so evolution should be aware of the birthdays and anniversaries.

Jörg Frings-Fürst (jff-de) wrote :

change status to Fix released (see gnome-bugs)

Changed in evolution (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.