evolution: Cannot get folder 'foo': folder does not exist.

Bug #320198 reported by Chris Cheney on 2009-01-22
0
Affects Status Importance Assigned to Milestone
evolution (Ubuntu)
High
Ubuntu Desktop Bugs

Bug Description

Binary package hint: evolution

I tried updating a filter to move emails into a different folder since a mailing list changed names. That would seem simple enough, right? Not so, evolution has now completely broken my filtering and everything is landing in the inbox instead. I even tried deleting the filter entirely and remaking it to see if it did not like the filter for some reason but had the same results. It seems that if you select a folder on imap(?) that it will not actually move emails to the folder on filtering and if you go back to look at the folder selection it says the folder it should but clicking on it it does not show the folder highlighted. On filtering it gives an error of "Cannot get folder 'whatever/path/to/folder': folder does not exist".

This is a HUGE usability issue for me. If I can't find a workaround very soon I will have to ditch evolution.

 I have attached a video showing the problem.

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/bin/evolution
Package: evolution 2.24.2-0ubuntu1
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: evolution
Uname: Linux 2.6.28-4-generic x86_64

Chris Cheney (ccheney) wrote :
Chris Cheney (ccheney) wrote :

This bug might be in Jaunty as well but I had other issues when trying to upgrade to Jaunty so was unable to check.

Changed in evolution:
assignee: nobody → desktop-bugs
importance: Undecided → High
status: New → Confirmed
milestone: none → intrepid-updates
Sebastien Bacher (seb128) wrote :

could you try if 2.24.3 also has this issue?

Chris Cheney (ccheney) wrote :

Hmm, yes this solves the problem.

I could have sworn I had 2.24.3 installed before reinstalling my system yesterday when the problem showed up originally. I had intended to go to Jaunty at that time but ran into several other issues so rolled back to Intrepid without intrepid-proposed when I filed this bug report.

When is it expected that the evolution in intrepid-proposed will go into intrepid-updates?

Thanks,

Chris Cheney

Sebastien Bacher (seb128) wrote :

closing since the update fixes the issue, the new version should be ready to be moved to intrepid updates

Changed in evolution:
milestone: intrepid-updates → none
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers