Evolution: "Unknown Mailbox" and "UID not allowed now" when using IMAP

Bug #317353 reported by Tristan Schmelcher on 2009-01-15
2
Affects Status Importance Assigned to Milestone
evolution (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: evolution

I'm running Ubuntu Intrepid 32-bit, but I've had this bug for a long time. Every now and then, after downloading some new message headers from my Gmail account (using IMAP), Evolution gets into a state where it can't download anything new after that. If I then attempt to open one of the new messages that I got headers for, I get the error:

Unable to retrieve message
IMAP command failed: Unknown Mailbox: INBOX (Failure)

If I try again (by going to an old, cached message and then going back), I get a different error:

Unable to retrieve message
IMAP command failed: UID not allowed now.

Images of the errors are attached. Retrying again continues to give the second error from then on. The problem clears once I exit Evolution and restart it.

$ lsb_release -rd
Description: Ubuntu 8.10
Release: 8.10
$ apt-cache policy evolution
evolution:
  Installed: 2.24.2-0ubuntu1
  Candidate: 2.24.2-0ubuntu1
  Version table:
 *** 2.24.2-0ubuntu1 0
        500 http://archive.ubuntu.com intrepid-updates/main Packages
        100 /var/lib/dpkg/status
     2.24.1-0ubuntu2 0
        500 http://archive.ubuntu.com intrepid/main Packages
$

Pedro Villavicencio (pedro) wrote :

Thanks for the report, Could you please get an evolution debug log with: CAMEL_DEBUG=all evolution &> evolution-debug.txt perform the operation to reproduce the bug and attach the resulting file to the report? thanks.

Changed in evolution:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in evolution:
status: Incomplete → Invalid

I finally got the info you asked for. (I kept forgetting to run with the debug settings after reboots so I kept missing the bug.) The file is a massive 1.1 GB though so I only uploaded the last 6000 lines. I'll keep the whole thing around though so let me know if you need to see more of it.

Changed in evolution:
status: Invalid → New
Sebastien Bacher (seb128) wrote :

could you try if that's still an issue in jaunty?

Changed in evolution (Ubuntu):
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in evolution (Ubuntu):
status: Incomplete → Invalid
Jens Bremmekamp (nem75) wrote :

This frequently happens for me on Ubuntu Maverick. It only occurs in connection with my work email account though (Gmail for Business via IMAP) though, not with my private account (regular Gmail via IMAP).

Changed in evolution (Ubuntu):
status: Invalid → Confirmed
Jörg Frings-Fürst (jff-de) wrote :

bug from 2009. Version not more supported.
change status to invalid.

Changed in evolution (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers