bogofilter error messages in evolution

Bug #282734 reported by Eric Donkersloot
78
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Evolution
Fix Released
Medium
evolution (Ubuntu)
Fix Released
Low
Ubuntu Desktop Bugs
Declined for Intrepid by Sebastien Bacher

Bug Description

Binary package hint: evolution

When receiving mail and checking for junk using bogofilter, evolution throws an error in the bottom status bar:

"Check Junk Failed" - Pipe to Bogofilter failed, error code: 3

This is what is displayed in the debug log:

Can't open file 'wordlist.db' in directory '/home/username/.bogofilter'.
error #2 - No such file or directory.

wordlist.db is located in /var/cache/dictionaries-common/

Revision history for this message
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

 * Is this reproducible?
 * If so, what specific steps should we take to recreate this bug?
 * What ubuntu version do you use?

 This will help us to find and resolve the problem.

Changed in evolution:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Revision history for this message
Eric Donkersloot (ericd) wrote :

* Yes, this bug is reproducible.
* To reproduce this bug, Evolution should be enabled to check incoming mail for junk using Bogofilter (which was enabled by default on my machine) and junk filtering should be enabled for one or more e-mail account(s).
* Ubuntu version:
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.10
DISTRIB_CODENAME=intrepid
DISTRIB_DESCRIPTION="Ubuntu intrepid (development branch)"

Revision history for this message
GuitarRocker2562 (guitarrocker2562) wrote :

I have this exact problem as well.

Changed in evolution:
status: Incomplete → Confirmed
Revision history for this message
Stephen Williams (swilliams8) wrote :

I had the same problem with Intrepid. As the original post says, bogofilter is looking for a wordlist.db file in /home/username/.bogofilter but this file does not exist upon installation. This file is custom to each user, based upon the messages they have marked as "Junk".

Bogofilter will automatically create this file when a message is marked as "Junk". So, as a simple fix, simply mark a message as "Junk" inside of Evolution. You can then go to the Junk folder and mark the message "Mark as Not Junk" if desired. The wordlist.db file will remain in place.

Revision history for this message
Sebastien Bacher (seb128) wrote :
Changed in evolution:
status: Confirmed → Triaged
Revision history for this message
cabbie (cabbiebatman) wrote :

I had this problem also on 8.10. I copied wordlist.db from /var/cache/dictionaries-common/ to /home/username/.bogofilter based on the error but it still failed. I removed the file and then marked a message as spam and then not spam and the wordlist.db was created and I have not seen the error again.

Revision history for this message
Charles Profitt (cprofitt) wrote :

The temporary fix worked for me as well.

Revision history for this message
kingtiger01 (mnovick1988) wrote :

same here. need to be a bug fix, or a meta-package added temporarily to the repo's. that auto-creates a empty file in the users home dir.

~king

Revision history for this message
Joe Kearns (jkearns) wrote :

I also encountered the problem. The temp fix worked (thanks), but it was quite scary the first time evolution checked my mail. All the errors piled up and I was anticipating a crash. A permanent fix would be nice to see.

Ubuntu 8.10

--Joe

Revision history for this message
sultan (sultanqasim) wrote :

Same bug on my iMac and the temporary fix works. Still, a proper fix should be made so newbies aren't turned off. These little things give people the impression that Ubuntu (and Linux in general) is buggy and unreliable (which is really not the case).

Revision history for this message
8200 (8200) wrote :

I can also confirm this bug @ Ubuntu 8.10 i386.

Marking an email as "junk" and then marking the same as "not junk" solved it.

Revision history for this message
Zied ALAYA (zied.alaya) wrote :

the same as 8200.
I tried before to disable the SpamAssassin Junk plug-in but it didn't solve the problem.

Revision history for this message
Jake Franklin (jfranklin) wrote :

Same bug for me on 8.10. Marking a message as Junk clears the issue.

Revision history for this message
dzappaterra (dzappaterra) wrote : Re: [Bug 282734] Re: bogofilter error messages in evolution

it works.
thanks
davide

2008/11/2 8200 <email address hidden>

> I can also confirm this bug @ Ubuntu 8.10 i386.
>
> Marking an email as "junk" and then marking the same as "not junk"
> solved it.
>
> --
> bogofilter error messages in evolution
> https://bugs.launchpad.net/bugs/282734
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in The Evolution Mail & Calendaring Tool: Unknown
> Status in "evolution" source package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: evolution
>
> When receiving mail and checking for junk using bogofilter, evolution
> throws an error in the bottom status bar:
>
> "Check Junk Failed" - Pipe to Bogofilter failed, error code: 3
>
> This is what is displayed in the debug log:
>
> Can't open file 'wordlist.db' in directory '/home/username/.bogofilter'.
> error #2 - No such file or directory.
>
> wordlist.db is located in /var/cache/dictionaries-common/
>

Revision history for this message
chiques (bajaguilin) wrote :

The work around worked for me too!
Thanks!

Revision history for this message
Gláuber Gonçalves (glaubergoncalves) wrote :

Marking messages as junk to create the folder has worked just fine for me too. The problem now is that Bogofilter does not seem to be filtering spam messages, I get all of them directly in my Inbox. The same has occurred in 8.04, which was solved through system updates at that time.

Revision history for this message
Martin Korsgaard (martin-korsgaard) wrote :

This bug is a little more serious than it may seem. The first time I did a synch, there was so many bogo-filter error messages that gdm crashed.

Revision history for this message
Anurag (anurag1008) wrote :

I got the same error after I did fresh install of 8.10 and restored the data for Evolution. After starting Evolution I got the same error. I copied the files '/home/username/.bogofilter' to the new home and it works fine and seems to filter fine.

As I understand it, while copying Evolution files, we need to copy spamfilter (bogofilter) files too. Evolution works fine after that.

Changed in evolution:
status: Unknown → Confirmed
Revision history for this message
Nicolò Dalla Valentina (nicodrummervr) wrote :

hello thanks I have resolved the problem ..... but every time that
rienstallo ubuntu 8,10 is thanks thousands

Revision history for this message
primefalcon (primefalcon) wrote :

Just had the same problem since I just upgraded from 8.04 to 8.10 and the fix seems to have worked as well...

been having the problem for about a week and just kinda ignored it, thinking oh well it'll be fixed and well sicne it's been a week I came to look for this :-)

Revision history for this message
Chris (christian-kropfberger) wrote :

Since one or two weeks ago this error has occurred on my machine as well (8.10). I have not undertaken any special actions but regularly applying patches as they have been made available.

Has there a final fix been released?

Thx!

Revision history for this message
O. Emmerson (oemmerson) wrote :

I moved one of my accounts across to evolution from Thunderbird today. I clicked send and recieve and got loads of Evolution error mesages. They say:
Check Junk Failed

Pipe to Bogofilter failed, error code: 3.'

The trick of marking one message as junk worked for me.

I'm using 8.10.

Revision history for this message
Gerard (gteich04) wrote :

This happened to me yesterday-In addition my pop account with my provider-verizon- is affected. I no longer receive the error message after applying this fix. I have lost the place in the new message folder on the server. Unless some can tell me how to prevent all of my messages on the server from being downloaded, it looks like I will have to manually delete those messages on the server--1500 of them. Yikes!

Revision history for this message
Nicolò Dalla Valentina (nicodrummervr) wrote :

I do not know dispiace grazi hello hello

Revision history for this message
Martin Mai (mrkanister-deactivatedaccount-deactivatedaccount) wrote :

Comment from upstream:
>>>
Should be fixed within this commit
http://svn.gnome.org/viewvc/evolution?view=revision&revision=36883
<<<
Therefore closing this bug. Please reopen if this is still an isseu with the latest developmetn version Uubntu 9.10

Changed in evolution (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Xiang (hsiang-liu) wrote :

ubuntu 10.04, please reopen this issue.

Xiang (hsiang-liu)
Changed in evolution (Ubuntu):
status: Fix Released → Confirmed
Revision history for this message
Xiang (hsiang-liu) wrote :

I am sorry, Maybe someone can help me to delete the re-open request above.
I did not realize that the default junk plugin has been changed to spamassin though I always use bogofilter.

Revision history for this message
Sebastien Bacher (seb128) wrote :

don't reopen closed bugs, if you have a similar issue open a new bug

Changed in evolution (Ubuntu):
status: Confirmed → Fix Released
Changed in evolution:
importance: Unknown → Medium
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.