preferences dialog shows wrong look in evolution

Bug #279282 reported by Javier García Díaz on 2008-10-06
76
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Evolution
Unknown
Medium
New Wave
Critical
Dilomo
evolution (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: evolution

I use different colors for panel menus and application menus. Evolutions uses the colors in gnome panel in the mail options dialog.

Please, see attached screenshot to see the difference and excuse my English.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/bin/evolution
NonfreeKernelModules: nvidia
Package: evolution 2.24.0-0ubuntu1
ProcEnviron:
 LANGUAGE=es_ES:es:en_GB:en
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
SourcePackage: evolution
Uname: Linux 2.6.27-5-generic i686

Javier García Díaz (jgd) wrote :
Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Also, please answer these questions:
* Is this reproducible?
* If so, what specific steps should we take to recreate this bug?

This will greatly aid us in tracking down your problem and resolving this bug.

Changed in evolution:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Javier García Díaz (jgd) wrote :

Steps:

1- Use gnome-color-chooser or edit your .gtkrc-2.0 to change your panel color. For instance, put the following lines in a file named .gtkrc-2.0 in your home directory:

style "gnome-color-chooser-panel"
{
  bg[NORMAL] = "#999999"
  fg[NORMAL] = "#ff0000"
}
class "*Panel*" style "gnome-color-chooser-panel"
widget "*PanelWidget*" style "gnome-color-chooser-panel"
widget "*PanelApplet*" style "gnome-color-chooser-panel"
class "*Tray*" style "gnome-color-chooser-panel"
widget "*Tray*" style "gnome-color-chooser-panel"

2- Logout and login to see the changes (depending on what theme you are using, your panel might not change)

3- Open evolution and go to the preferences dialog. Select the third option. It will be gray with red letters (as your panel). The rest of the dialog is OK.

Javier García Díaz (jgd) wrote :

By the way, some other things use wrong colors. For instance, nm-applet menus in the notification area are OK, but rhythmbox right-click menu in that area has panel colors instead of menu colors. The dialog to create a new personalized launcher has panel colors too. I know this is not tha same bug, but see the attachment.

Sebastien Bacher (seb128) wrote :

There is a bug upstream about that on http://bugzilla.gnome.org/show_bug.cgi?id=549213

Changed in evolution:
status: Incomplete → Triaged
Changed in evolution:
status: Unknown → New
Changed in evolution:
status: New → Confirmed
Jeff Sereno (jsereno) wrote :

This cosmetic bug is still present under Ubuntu 9.04.

The Mail Preferences option in the preferences is the only part of the whole preferences dialog to use completely different colours for the text.

Attached is how I see it using the New Wave colour theme. Choose any other area of the preferences and the text is black.

...and is still present under Ubuntu 9.10.

Firefly (luciole) wrote :

still present in Karmic, found with New Wave default theme !!

Firefly (luciole) wrote :

PS : This bug is only seen in the "mail preferences" (3rd) tab, other tabs are ok.

Chris Plewright (plewright) wrote :

This bug is even worse in the version of evolution that came with Karmic.

In addition to the "Mail Preferences" tab using the wrong font colour, I also noticed since upgrading to karmic, I can't read the "Save As" button (when an email message has an attachment) because it now also uses the wrong font colour!

Dilomo (ankere) wrote :

I can confirm this too. Why the developers are doing this thing wrong?? I can't get it.

Oded Arbel (oded-geek) wrote :

As indicated in GNOME bug 549213, commenting out line 4989 in New Wave's gtkrc (the one about a widget_class *Mail*) solved this problem for me.

I believe this is a bug in gnome-themes-ubuntu (which I couldn't locate on launchpad).

Dilomo (ankere) wrote :

I used the match "*Panel*Mail*" and it works indeed. Thanks for the help!

I'll release this in the next version of the theme.

Changed in anton:
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → Dilomo (ankere)
status: Confirmed → In Progress
milestone: none → newwave-0.8.2
Dilomo (ankere) on 2009-12-14
Changed in anton:
status: In Progress → Fix Released

I can still reproduce the bug with fully updated system (karmic in use).

the 'save as' wrong look

no problems here but...

look at these options...

Dilomo (ankere) wrote :

Can you tell me which version of the theme you are using? I suggest it is 0.8.1. Can you try downloading 0.8.2 and tell me if there is still a problem?

Here's a link:
http://gnome-look.org/content/show.php/New+Wave?content=87134

May you tell me please, which one of these
                (New Wave Pack)
  (New Wave GDM)
  (New Wave GDM List)
  (Lock-Dialog Theme)
  (Alternative Metacity)
  (Alternative "Key" Metacity)
  (New Wave XFWM Theme)
  (Alternative XFWM theme (by Steve Dodier))
  (Perfect Wave Emerald theme (by Zuil Nossile))
  (Opera Theme (by Kyle Baker))
  (Google Chrome Theme (by Lasse Valentini)

I should install?

Dilomo (ankere) wrote :

You should download the first one (New Wave Pack). Install the gtp files by double clicking.

The pack also includes a program called New Wave Configurator (it is .deb file) . With it you can check the version of your installed themes.

Dilomo (ankere) wrote :

Btw: Можеш да ми пишеш и на български ако ти е по лесно :)

Разбира се, че ми е по-лесно, благодаря ти. Сега ще видя, какво мога да направя по-въпроса, но сигурно си прав, че ползвам по-старата версия (защото ползвам само "оригиналните" пакети, които си идват с Убунту-то).

Абсолютно прав! Проблемът е разрешен идеално, благодаря ти отново.
Един последен въпрос свързан със Скайп... когато използвам "Dark Sand", доста от менютата са напълно черни, но текстът също е черен и не може нищичко да се прочете.
Мислиш ли, че трябва да отворя нов доклад за бъг в "Dark Sand" темичката или това че скайп е close-source, докладът ще бъде отхлърлен? (:

Dilomo (ankere) wrote :

Аз мисля, че проблемът с Dark Sand трябва да бъде споменат (докладван) на хората, които го поддържат. Все пак ако проблема не е техен те ще те уведомят, но ако е при тях (както може би е) те трябва да се постараят и да го оправят.

Благодаря ти, че се постара да помогнеш при решаването на проблема с Evolution! Ако има нещо друго което забележиш докладвай пък аз ще видя дали мога да го оправя ;)

И така за нашата неразбираща публика: So the problem is solved.

Changed in evolution:
status: Confirmed → Invalid

It is not 'invalid' but 'fixed' in the latest version of the New Wave theme.

Omer Akram (om26er) wrote :

not a bug in evolution though its fixed by the theme :)

Changed in evolution (Ubuntu):
status: Triaged → Invalid
Changed in evolution:
importance: Unknown → Medium
status: Invalid → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.