evolution bug, "Summary and folder mismatch, even after a sync"

Bug #27014 reported by Alexander van Loon on 2005-12-13
224
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Evolution
Fix Released
Critical
evolution (Ubuntu)
High
Ubuntu Desktop Bugs

Bug Description

I just opened Evolution, and Evolution autodownloaded my e-mail. Immediatly a
window pops up called "Evolution Error". It gives this error message:

"Error while Storing folder 'Inbox'.

Summary and folder mismatch, even after a sync"

Then I click OK. Then the same window with the same error message pops up again.
I click OK again. Then I notice that my received e-mail message (1 in the Inbox
folder) is copied by Evolution, so that it appears in my Inbox twice (I'm sure
that it is not the sender sending the e-mail twice). I also notice that there is
new mail in a subfolder of my Inbox called "Ubuntu Bugzilla" (which is used for
all bugzilla mail, which gets filtered and is placed in that folder). I open the
"Ubuntu Bugzilla" folder, when I open it I got the error message again. I didn't
see an e-mail appearing twice in this folder however. When I click the Inbox
folder, and then the "Ubuntu Bugzilla" folder again, the error message appears
again after I've clicked on the "Ubuntu Bugzilla" folder. This bug isn't
harmful, but it is annoying.

This bug occured today, but today isn't the first time, I've seen it happen a
lot when using Evolution on my box, since the preview releases of Ubuntu 5.10.
I'm using Ubuntu Breezy Badger 5.10 with Evolution 2.4.1. I assumed this bug was
high on the priority list to be fixed because it's so obvious, but there hasn't
been an update which fixed it, and when I searched for Evolution bugs in
Ubuntu's bugzilla I didn't find any other reports. Hard to believe my case is
unique.

Daniel Holbach (dholbach) wrote :

Thanks for your bug report. What type of mail account do you use?

Alexander van Loon (avanloon) wrote :

I use a POP3 account, is that what you mean?

Alexander van Loon (avanloon) wrote :

I'm using Dapper Drake now with Evolution 2.5.4. I thought the bug was gone because it didn't occur for some days, but today it did. So I can still confirm it.

Alexander van Loon (avanloon) wrote :

One more off-topic question, I reported this bug, but why isn't this bug displayed then when I go to my "Bugs Reported" in Launchpad? Did the migration from Bugzilla to Launchpad not go 100% correctly, or does Launchpad have some problems?

Sebastien Bacher (seb128) wrote :

I've forwarded your issue upstream http://bugzilla.gnome.org/show_bug.cgi?id=327982 and will let you know if they comment on it

It's possible that you have 2 accounts after the migration, as described by the announce mail:

"If no Launchpad account exists for an email address then a new account
will be created. Note that the Bugzilla password is not migrated for
generated accounts, due to differences in how passwords are stored.

If you have used a different email address in Bugzilla to what you
used in Launchpad, you can make the transition go more smoothly by
registering your Bugzilla email address in Launchpad at:

  https://launchpad.net/people/$USER/+editemails

If an extra Launchpad account does get created for you though, you can
request an account merge at:

  https://launchpad.net/people/+requestmerge"

Did you use 2 differents emails for bugzilla/launchpad? In which case you may want to try what is described by that mail

Changed in evolution:
assignee: seb128 → desktop-bugs
status: Needs Info → Confirmed
Sebastien Bacher (seb128) wrote :

Upstream comment:

"Hmm, ok... First of all, a quick workaround/solution. Please see the first few
comments of bug 213072 and especially bug 213072 comment 30, since the location
of the mail folders changed since the original report.

Deleteing the file ~/.evolution/mail/local/Inbox.ev-summary should solve this
"mismatch". At least for the Inbox. All files named like your Evo mail folders
with an extension of .ev-summary are indexing files only. You can safely remove
them (with Evo closed first), and they will be recreated next time you start
Evo. May take a while for large folders.

Note: In the example above, the "Inbox" named file holds your mails. Do not
touch this file.

Since you get the same message for your "Ubuntu Bugzilla" folder: Based on your
description above, the relevant indexing file should be inside the "Inbox.sbd"
dir. Feel free to contact me directly, if you are unsure how to work around
this by the discussions above. Sebastien should know where to find me. ;)"

Alexander van Loon (avanloon) wrote :

Thanks for the explanation.

Concerning Launchpad, I used the same e-mail adress for Bugzilla and Launchpad. However, I do see this bug now when I go to "Bugs Reported" in Launchpad, (I'm sure it wasn't there when I checked for the first time though) so nevermind.

The bug occurs very sporadic for me, it hasn't affected me for the last week, so I didn't bother with the workaround. I can't reproduce it either, so I don't think I can be of much help. But I'm glad to see it has a high priority for the Evo devolopers to fix.

Bubbels (bubbels) wrote :

Maybe i'm barking up the wrong tree, but maybe this info will help:

When I installed de Beagle-Evolution connector, Evo gave the problems. Uninstallation of the software restored the normal way of working.

I have not further tested it, but I thout it may be something to look at.

Daniel Holbach (dholbach) wrote :

Thanks for the comment, I added it to http://bugzilla.gnome.org/show_bug.cgi?id=213072

Bubbels (bubbels) wrote :

I was wrong,

After about a week the same error was back, even when the Evolution-Beagle connector wasn't installed.

So much for further testing. . .

Alexander van Loon (avanloon) wrote :

This bug is unfortunately still in Evolution 2.6.0, and it has plagued me at least two times this day again. Last time I said it was sporadic, but since I'm using Evo 2.6.0 on Dapper it happens nearly every day.

In the upstream bug report I read that this bug is retargeted to Evolution 2.7.0. That would mean waiting another half year and coping with this evil bug before 2.7.0 is released. This is such a severe bug, would it be possible for the Ubuntu dev's to backport a fix for this bug once this bug has been fixed in Evolution's CVS? Or if the Evolution team will do a bug fix release, 2.6.1 or something, will that new version be available for Dapper?

Daniel Holbach (dholbach) wrote :

It's a bit hard to say that now, there is no fix yet, so we don't know when there will be a fix and how big it is, depending on those two factors, it's inclusion will be considered.

Stu Hood (stuhood) wrote :

I can confirm this as well with a POP3 account. Restarting evolution fixes the problem... temporarily.

This problem is annoying, however, interesting part is that I could not reproduce it on my home computer. However, it is serious showstopper when it accours and makes Evolution usage useless, which is sad.

Additional comment to workaround with deleting Inbox.ev-summary file in ~/.evolution/mail/local. First, you should turn off your accounts so no new mail would come in or any checking for new mail would not accour. Then, remove Inbox.ev-summary and quit Evolution. Then launch Evolution again and let it create new Inbox.ev-summary. It takes few minutes for at least thousand mails so take your time. Let it sync several times, pressing "Send/Recieve" (might be not necessary) and then turn on your account(s) one after one.

My problem was that deleting this file and letting checking Evo mail once in two minutes didn't let create Evo this summary file, so previous workaround didn't work fully.

Sebastien Bacher (seb128) wrote :

Could people having that comment on the upstream bug rather? We are not likely to do distro specific work on it so upstream has better chance to get it worked

Paul van Genderen (paulvg) wrote :

I had this problem a few weeks ago, removed the ev-summary file and thought it was done with, but it just came back. Removing only the inbox ev-summary file didn't help either. I had to remove all ev-summary files. Yes, I disabled the email accounts and I put it in offline mode.

I have 2 accounts. One local account that's set up to check in /var/spool/mail/ubuntu and sends with sendmail (actually postfix ofcourse), and the other account only sends email, through the GMail SMTP. I recieve mail locally with fetchmail. Biff is enabled, but last time it wasn't.

Paul van Genderen (paulvg) wrote :

It seems persistant now. After opening Evolution for the second time, it came back again, as soon as I switched it to online mode. The difference is that I had new email (the above comment). I've also noticed emails are duplicated each time the error appears (like the inital reporter). When I had this a few weeks ago, I had a couple of thousand new emails, because automatic background checking was enabled and I just shrugged and dismissed the error, left it alone for a while, not realising how quickly new emails piled up. After clicking away error after error I googled for a solution. Fortunately, this time there are only about 350 new emails.

But I'm now a bit afraid of using Evolution, even though it has grown on me and I kinda depend on it now.

Changed in evolution:
status: Unconfirmed → Confirmed
Lee Revell (rlrevell) wrote :

What's the status of this severe bug? I get bit every few days. Is it really so hard to prevent Evo from constantly corrupting my mail folders?

Workaround is no solution for me - Evo hangs or crashes. I have to manually move the corrupt mbox file out of the way and re-import it.

Sebastien Bacher (seb128) wrote :

You can read the details on http://bugzilla.gnome.org/show_bug.cgi?id=213072. That bug doesn't happen for a lot of people and the people who code on evolution doesn't get the issue which makes it not easy for them to debug. Figuring what actions lead to the issue might be useful for them

Changed in evolution:
importance: Medium → High
Lee Revell (rlrevell) wrote :

Well it really sounds like the problem is some kind of race or inadequate serialization between mail reading/deleting and new mail coming in. It seems that 5 years of bug reports should be enough even if the developers cannot reproduce the problem.

All I do to reproduce the bug is have a POP3 account (leave mail on server disabled) subscribed to 20-30 mailing lists including very high volume ones like linux-kernel and just leave Evo open all the time and use it normally, and the bug hits every week or so.

What additional information can I provide to help debug it?

Kevin Kubasik (kkubasik) wrote :

I just wanted to say that this has happened to me also. It appears to be a product of when evolution is 'Storing Mail' (according to the bottom left status bar) and is unexpectedly shut down. I am more than willing to work with anyone to help debug.

Sebastien Bacher (seb128) wrote :

Could you comment upstream? Then know the code better and can give be advices than we would do since we only update the packages and do small patching and have no real knowledge on the code for it

Robert Persson (ireneshusband) wrote :

This bug has just afflicted me for the first time (although I have had problems with duplicate mails already). It actually happened while I was starting and stopping evolution in order to compile an unrelated bug report, #62192. To be more precise, I first noticed it immediately after the double evolution freeze and the total system freeze described there.

Tim Prosser (tim-prosser) wrote :

Not sure this is entirely relevant, but I saw this error when attempting to Expunge deleted emails.

The cause of the summary file corruption was that I had less disk space free than the size of the Inbox.

It appears that Evolution makes a temporary copy of the whole folder when doing various housekeeping duties, including Expunge. With insufficient disk space, it fails to complete the expected update to the Inbox but nevertheless updates the Inbox summary.

I fixed the problem by freeing up disk space, stopping Evolution, deleting all the .index, .data and .summary files, and restarting.

I think the generally the problem is that Evolution doesn't deal with failure to update a folder gracefully - and it should definitely check for available disk space.

Wisu Suntoyo (wisu) wrote :

Bug happened to me after clean install of edgy and moving evolution mailbox and settings across to the new installation

After reading the comments above I ran

find ~.evolution/ -name "*.ev-summary" -print0 | xargs -0 rm -rf

to delete .ev-summary files... and it did the trick

Geoff J (geoff-jankowski) wrote :

I know this is not the solution but it is a work around that works!

Please make sure you back up the relevan data file for the problem folder first, just in case.

Often when the mismatch message occurs evolution cannot generate a .ev-summary file, especially with large (500+ Meg) files.

To overcome the problem for folder FOO

Make a new folder FOO1

go to FOO and select all emails

Move all mails from FOO to FOO1

select FOO1 (the mismatch error will come up again as you leave FOO)

Check all the mails are there.

Quit and restart evolution to check the data is there, select FOO1. Then select another folder to make sure the error does not occur on this new file.

Delete FOO (you need to expunge it first)

Rename FOO1 to FOO

Everything should now work.

Finally, for good housekeeping check the ~/.evolution/mail/local/Inbox.sbd/....... directory to see that the new files are all listed as FOO.

This does not always happen (some will retain the FOO1 element) and it will not cause a problem but will be confusing if you regularly check the evolution directory and file structure so;

Instead of renaming FOO1 to FOO

Stop then restart evolution

Make a new folder FOO

Move the files from FOO1 to FOO

Stop start and check once more

Delete FOO1

Hope this of use to beleaguered evo users

scarolan (scarolan) wrote :

This really is a deal-breaker. I can't have my mail client locking up like this several times a day. Given the age of the bug I'm surprised no one has been able to fix it. Can you just borrow some working code from the Mozilla Thunderbird team? (I kid, I kid . . . )

I'm running Ubuntu Feisty 7.04 on an IBM Thinkpad T41:

1. Download mail into local mbox spool, /var/spool/mail/username
2. Attempt to open mail with Evolution
3. Get several duplicate messages and error box
4. Restart evolution and cross fingers hoping it will resolve itself
5. Lather, rinse, repeat

If someone can tell me what error/debug/log files you need to troubleshoot I will be happy to post them for you.

scarolan (scarolan) wrote :

For others experiencing the same bug, I found that opening the mail spool with mutt seems to clean up whatever problems were introduced by Evolution. After opening and closing with mutt, I am again able to read my messages in Evolution.

Jamie Strandboge (jdstrand) wrote :

The attached patch is not an actual fix for the bug, and it has been submitted upstream. It is a viable workaround until a proper fix can be made. I have been using this patch for months, and have rolled it out to all my users and this problem is virtually eliminated. I went from having this error every day to having it happen only twice in months.

The patch simply stops evolution from automatically downloading email on startup. This gives evolution a chance to finish setting up all of its indexes before email is downloaded. This was also the default behavior of evolution 1.4.

Simply drop the patch into debian/patches and rebuild.

Jamie Strandboge (jdstrand) wrote :

The attached script provides a convenient way to clean out summary files after this bug hits. It has proven quite useful (before implementing the above patch), and is very non-tech user-friendly.

Here is the order of operations:
1. asks the user to close evolution
2. forces evolution to close
3. sets evolution to be in offline mode via gconftool-2
4. removes the summary files in $HOME/.evolution/mail/local and below
5. tells user how to start evolution again

I developed it so that non-technical users could have a way to navigate through this bug, and it has proven very handy.

Thanks, Jamie, but I've stopped using Evolution for the time being. I will
keep your note for future reference.

On 6/23/07, Jamie Strandboge <email address hidden> wrote:
>
> The attached script provides a convenient way to clean out summary files
> after this bug hits. It has proven quite useful (before implementing
> the above patch), and is very non-tech user-friendly.
>
> Here is the order of operations:
> 1. asks the user to close evolution
> 2. forces evolution to close
> 3. sets evolution to be in offline mode via gconftool-2
> 4. removes the summary files in $HOME/.evolution/mail/local and below
> 5. tells user how to start evolution again
>
> I developed it so that non-technical users could have a way to navigate
> through this bug, and it has proven very handy.
>
> ** Attachment added: "script to"
> http://launchpadlibrarian.net/8172690/evolution_clean_summary
>
> --
> evolution bug, "Summary and folder mismatch, even after a sync"
> https://bugs.launchpad.net/bugs/27014
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Glen (glentupling) wrote :

I have had this issue for some time now and it has been consistent, every time evolution opens I get the summary folder mismatch. Today I deleted one email account (I had two email accounts setup in evoltuion.) Problem goes away immediately! Is evolution not cabable of handling multiple email accounts? I am using Ubuntu Dapper and evolution 2.6.1

Changed in evolution:
status: Confirmed → Triaged
mustali (mustali-dalal) wrote :

I started seeing this issue today and I tried the fixes listed here. However, none of the following resolved the issue:
- removing the second email account
- reinstalling evolution
- 'rm *.cmeta *.ev-summary* *.ibex.index*' followed by a restart.

I use Evolution at work and this will be a big issue for me. My mail folders are large:
-rw------- 1 mustali mustali 18585 2007-08-11 16:36 Drafts
-rw------- 1 mustali mustali 473186989 2007-08-12 12:06 Inbox
drwxr-xr-x 2 mustali mustali 4096 2007-08-12 13:23 Inbox.sbd
-rw------- 1 mustali mustali 0 2007-08-11 16:10 Outbox
-rw------- 1 mustali mustali 134372122 2007-08-11 16:10 Sent

I hope this is fixed soon. I am now considering a move to Thunderbird in the interim.

on Ubuntu Fiesty

mustali (mustali-dalal) wrote :

Ok, this worked:

- Backup the ~/.evolution folder.
- Export all the messages (after deleting duplicates) to a mbox format and import them.
   - For each folder, open folder, highlight all the messages and choose Save As.. to a file. This will create a mbox formatted file.
   - After exporting all the folders, delete the ~/.evolution folder.
   - Restart Evolution and import each of the files created before.

Thunderbird will have to wait :)

Mustali

David B (d-bannon) wrote :

Kubuntu 7.04, Evolution 2.10.1, POP account

I too have this problem, repeatedly, I can usually get going again by doing the "remove summery files, restart offline" trick but do sometimes need to do it again and again.

I am also logging an error "/bin/sh: /usr/bin/esd: not found", reportedly fixable by installing esound or pulseaudio, neither of which appear available. I have no reason to think the esd problem is related to the "even after a sync" problem but just in case it might be...

Surprising how long this bug has been around. I have used RedHat and Fedora for some time, did not see the problem there.

David

mazzystr (mazzystr) wrote :

Is anyone using Kerberos, Winbind or Samba along with their Evolution?

I disabled my winbind and now my evolution seems to be running better. My Windows admin said my host was pounding the domain controller with authentication requests.

/Chris

dmontalvao (dmontalvao) wrote :

This might seem odd.... But, while reading this, I just closed Evolution. Then, on terminal I typed:

apt-get install evolution

This is what I got:

root@DMS-Ubuntu:/# apt-get install evolution
Reading package lists... Done
Building dependency tree
Reading state information... Done
evolution is already the newest version.
The following packages were automatically installed and are no longer required:
  libxfcegui4-4 libxfce4mcs-client3 libgtk-canvas1 xfce4-panel libtagc0
  libpcre3 libart2 gdk-imlib1 libxfce4util4 libgtkmm1.2-0c2a libexo-0.3-0
  libsigc++0c2 libraptor1 liblrdf0 libxfce4mcs-manager3 libthunar-vfs-1-2
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Afterwards, I started evolution and... Voilá? No more bug? But... I don't get it!

Lucky Strike? lol

dmontalvao (dmontalvao) wrote :

Oh, I didn't remove evolution nor have I backed up anything.

Jamie Strandboge (jdstrand) wrote :

I have been running Gutsy's evolution for about 3 weeks, and have not seen this problem anymore. It used to happen at least daily on dapper. This is the same machine and email that had the problems before. Upgraded to from dapper, to edgy, to feisty to gutsy. Now it works fine. I'll report back if the problem crops up again.

Changed in evolution:
status: Confirmed → In Progress
Changed in evolution:
status: Triaged → Fix Committed
Changed in evolution:
status: Fix Committed → Fix Released
Changed in evolution:
status: In Progress → Fix Released
32 comments hidden view all 112 comments
lenticular (geostrophic) wrote :

Any idea whether this will be backported to Gutsy? I'm not ready to make the jump to Hardy until it goes live, but this problem makes using Evolution pretty annoying.

Also, I followed the link above to Sankar's patch, which looks to be C code in an svn repository. Unless I'm missing something, that means I would need to compile evolution on my system, right?

Thanks,
  John

Johnathon (kirrus) wrote :

We would need to create a debdiff, containing only the patch to fix this particular problem (against apt-get source evolution).

Once we've got a minimal debdiff we can request an SRU to put the patch into Ubuntu.

That, or we need to request a backport of the latest version of Evolution into Gutsy, which would go into the backports repository.

gerard67 (mathieu-petit) wrote :

Four years of evolution, four years of this insane mismatch bug that comes and goes ... any news of an eventual Gutsy backport ?

Johnathon (kirrus) wrote :

Reading up on it, this would require an SRU, not a backport. (The backport team won't backport for a bug fix).

Personally, I don't think that it is worth putting an SRU through, although you can request one if you wish, we would need (as mentioned before) a minimal .debdiff

(Need to fill this "when": Bugs which do not fit under above categories, but (1) have an obviously safe patch and (2) affect an application rather than critical infrastructure packages (like X.org or the kernel). We fit (2), but need a minimal patch to fit (1).)

Here is more info on the SRU process:
https://wiki.ubuntu.com/StableReleaseUpdates

josef.sabl (josef-sabl-gmail) wrote :

This is not funny... I last all of my inbox thanks to this little, cosmetic, non-destructive bug :-(

Ubuntu, shame on you for having such crappy application as a default choice. (This is not the only bug in Evolution I have troubles with)

josef.sabl (josef-sabl-gmail) wrote :

Oh, sorry, there should be "lost" not "last".

Chris (christian-kropfberger) wrote :

I have just observed the bug with evolution 2.12.1 on Ubuntu 7.10.

Maybe related, since the workaround is the same: Since upgrading to evolution 2.22.1 (with 8.04 LTS), there is a different error message, like "Error storing Inbox folder: Corrupted MBOX file or invalid "From" line detected." (I use the German version, so this may not be the entirely correct English message). Deleting the index files & restarting evolution removes the problem temporarily. Main difference: I encountered the "summary and folder mismatch" error only once every few months, whereas this one comes up each time I start Evolution for the first time after booting the system.

This new error message points me at the fact that many spam mails do not have a valid "From:" line (well, it is blank) but use the "X-Sender" instead. Evolution displays those mails in the preview window as if the "From:" line were there, you can only tell the difference when looking at the mail code. So, to clarify my previous statement: This error occurs each time I start Evolution for the first time after booting the system AND if there are spam mails in the Inbox (which is usually the case). Haven't observed this error yet when no spam was there...

TIA,
-wolfgang

Changed in evolution:
status: Fix Released → Confirmed
dryudh (yudhvir0039) wrote :

at the time of opening of any folder istead it internet browser open itself first than foler. what should i do ?

Changed in evolution:
status: Confirmed → Fix Released
Joachim (joachimrs) wrote :

Am on Intrepid Ibex with Evolution 2.23.91 and had the "Summary and folder mismatch even after a sync" error when trying to empty the (Evolution-) Trash for one of my POP3 accounts (at Yahoo).

After the upgrade to Intrepid Evolution migrated to a new sqlite and crashed right after that. However, it worked ok since then. Now I have two E-Mails in my Trash that I can't remove, ok, no big deal, just a minor annoyance. But can it become bigger?

jott (ottjochen) wrote :

Bug not fixed as gnome states.

Changed in evolution:
importance: Unknown → Undecided
status: Fix Released → New
status: Fix Released → New
jott (ottjochen) wrote :

Gnome bug tracker states the bug as fixed in 2.23.91. I'm using this version (on Intrepid). Ironically, the very version it should be fixed is the first time for me the bug appeared at all. I've not read *all* the comments, so I describe what I observe:
- only one folder is affected.
- "Summary and folder mismatch, even after a sync"-message if moving to that folder (or after other actions on that folder)
- Some messages are duplicate in that folder
- If marking all messages in that folder, the displayed "selected" and "total" numbers totally mismatch, sometimes by a factor of three or more (no, this is not because I forgot to "compress folder"). Messages do not seem to be duplicate in the corresponding file holding the mails, thoug
- stopping evolution, deleting the *-ev*-(indexing)-files for that folder does not help at all.

jott (ottjochen) wrote :

It gets even better: every time I mark/unmark the folder(!), the "total" counter increments by about the total count of the messages(!). I get the same error message if I "expunge folder" (this is what I meant by "compressing folder" in my previous comment).

Pedro Villavicencio (pedro) wrote :

May you please guys stop commenting other issues in this report, this is about the summary and folder mismatch nothing else, if you have other issues do please submit another bug about those for better tracking , thanks in advance.

Changed in evolution:
importance: Undecided → Unknown
status: New → Unknown
status: New → Triaged
Sebastian Kapfer (caci) wrote :

In my experience, the issue with the duplicated emails is strongly correlated with the mismatch issue that this bug is about. (In fact I think the duplicated mails go away when you shut down evo cleanly and delete its indices and thus force it to re-build them.) In any case, it seems the multithreading bug is back. :-(

Changed in evolution:
status: Unknown → Fix Released
Michael Flaig (mflaig) wrote :

Just a few words that this problem is currently very annoying :-(

Yesterday I removed all summary files and evo could store correctly.
Today morning Evo hang and I had to quit it by evolution --force-shutdown. "Summary and folder mismatch, even after a sync" is back, so status changes (reply status, mark as read, etc) don't get saved als long as this error occures. also mail duplicates happen again.

I see this problem only with the POP3 account for now.
My IMAP accounts are good, no problems with summary there, yet.

--- version ---
evolution 2.24.0-0ubuntu1
evolution-data-server 2.24.0-0ubuntu1

Sebastien Bacher (seb128) wrote :

the issue should be fixed in intrepid now

Changed in evolution:
status: Triaged → Fix Released
Michael Flaig (mflaig) wrote :

Hi,

for me it's not fixed, Sorry.
I rebooted the system, removed all cmeta and ibex files and then started evolution
  find ./ -name '*.ibex*' -print0 | xargs -0 rm
  find ./ -name '*.cmeta*' -print0 | xargs -0 rm

Seeing even more summary corruption than before. If I go to inbox and delete an email the mail that was below the deleted one gets shown 3 times, after expunge the mailbox is corrupt again

--- snip ---
Error while Storing folder 'Inbox'.
Summary and folder mismatch, even after a sync
--- snap ---

Only one of the shown entries in summary actually shows a messige if double clicked.

I also see duplicate mails when I just enter a folder, but not for every email.
The Messages in Terminal on folder change:
--- snip ---
(evolution:11523): camel-WARNING **: Could not find key entry for word '0x00000000': No such file or directory
(evolution:11523): camel-WARNING **: Could not find key entry for word '0x00000000': No such file or directory
(evolution:11523): camel-WARNING **: Could not find key entry for word '0x00000000': No such file or directory
(evolution:11523): camel-WARNING **: Could not find key entry for word '0x0000000000000000': No such file or directory
(evolution:11523): camel-WARNING **: Could not find key entry for word '0x0000000000000000': No such file or directory
(evolution:11523): camel-WARNING **: Could not find key entry for word '0x0000000000000000': No such file or directory
(evolution:11523): camel-WARNING **: Could not find key entry for word '0x00000000': No such file or directory
(evolution:11523): camel-WARNING **: Could not find key entry for word '0x00000000': No such file or directory
Saving 1655/3310 dirty records of Inbox/OSS Mailinglisten/ekiga-devel
Triggering summary_reloaded on Inbox/OSS Mailinglisten/ekiga-devel 0x8d7b4e8
(evolution:11523): camel-local-provider-WARNING **: Expected a From line here, didn't get it
(evolution:11523): camel-local-provider-WARNING **: failed a quick-sync, trying a full sync
(evolution:11523): camel-local-provider-WARNING **: Expected a From line here, didn't get it 64263344
camel-Message: 2vajbjBG1 - already there
--- snap ---

Oh, and I am seeing the duplicate emails with IMAP Mailboxes now, too. :-( I can not see any pattern however, seems random.

--- versions ---
ii evolution 2.24.0-0ubuntu2
ii evolution-common 2.24.0-0ubuntu2
ii evolution-data-server 2.24.0-0ubuntu1

Michael Flaig (mflaig) wrote :

Bug seems not fixed

Changed in evolution:
status: Fix Released → Confirmed
Sebastien Bacher (seb128) wrote :

what you describe seems to be rather a new bug in the intrepid version, open a new bug rather than reopening this one

Changed in evolution:
status: Confirmed → Fix Released
Mario Vukelic (mario-vukelic) wrote :

I _still_ have the "folder mismatch even after a sync" in up-to-date Intrepid ...
Seems to me like the old issue, so I figure I reopen the bug.

Changed in evolution:
status: Fix Released → Confirmed
Sebastien Bacher (seb128) wrote :

the code changed a lot in intrepid the bug is likely different one, open a new one rather than reopening this one

Changed in evolution:
status: Confirmed → Fix Released

There are two suggestions:
1. *anyone* who gets this bug on Intrepid- please report new bug, reproducible steps would be a obligatory, and put link/bug number in comments here so developers can check it out;
2. Please don't link such bugs on Intrepid as duplicates to this bug, put maybe into comments for further evaluation;

Ian Corne (icorne) wrote :

Well, i just got it but I have no idea how to reproduce...

followed some guidelines in
https://bugs.launchpad.net/evolution/+bug/28403

and it fixed it for now

Tremaine Lea (tremaine) wrote :
sebastian-s (sebastian-s) wrote :

As requested above here a link to a new bugreport regarding same/similar bug in intrepid https://bugs.launchpad.net/ubuntu/+source/evolution/+bug/360667

Ardhard (ardhard) wrote :

Remaine Lea: I got the same.

Try make free space on home FS for the bigest mail folder. Check: du -ks ~/.evolution/mail/local/* | sort -n .

Next check free space on home FS: df ~

If that not help try make more free space as much as : du -ks ~/.evolution/mail/local/.

Work for me.

Tremaine Lea (tremaine) wrote :

@Ardhard - heh, no luck there. I've got over 150G free. I've actually dropped Evolution in favour of Thunderbird for the time being as it doesn't appear this is going to be resolved any time soon. That said, I'll switch when they do - gpg signing in TB is a PITA.

I had the same problem - the bug 27014: "Summary and folder mismatch, even after a sync".
In the same time I had problem with the bug 183136: "Error while Storing folder Sent".
It was very annoying.
I have solved both problems in a very simple way.

Just delete file "folders.db" from ~/.evolution/mail/local and start "evolution". In the first time the evolution needs more time to rebuild folders.db. After that, everything works fine.

Ryan Daly (daly-ctcnet) wrote :

I just experienced the same bug with version 2.28.1.

I ended up having to remove .cmeta, .ibex.index, and .ibex.index.data files from directories under $HOME/.evolution.

Jacob Popov (j-a-popov) on 2010-05-31
Changed in evolution (Ubuntu):
status: Fix Released → Confirmed
Jacob Popov (j-a-popov) wrote :

I confirm this bug on 2.28.3-0ubuntu9 (Lucid). Actually this is getting really annoying. This bug seems to last for 5 (!) years now and nothing seems to gloss it over.

In Intrepid I had to remove files manually, in Lucid I still have to do it, only file names changed.
Arghh, sometimes I feel I'm flying off the handle. Will it EVER be fixed? Or maybe we should introduce a button called 'Work around the pesky error'? Why can't Evolution re-index its bases automatically time after time?

Jacob Popov (j-a-popov) wrote :

To sum it all up. I wrote a script to work over this damn bug:

#!/bin/bash
rm ~/.evolution/mail/local/folders.db
rm /home/jacob/.evolution/mail/local/*/*/*/*.ibex*
rm /home/jacob/.evolution/mail/local/*/*/*.ibex*
rm /home/jacob/.evolution/mail/local/*/*.ibex*
rm /home/jacob/.evolution/mail/local/*.ibex*
rm /home/jacob/.evolution/mail/local/*/*/*/*.cmeta
rm /home/jacob/.evolution/mail/local/*/*/*.cmeta
rm /home/jacob/.evolution/mail/local/*/*.cmeta
rm /home/jacob/.evolution/mail/local/*.cmeta

Still I'm looking for a better solution rather than asking the Dark side of the Force for help.

Pedro Villavicencio (pedro) wrote :

Please open a new bug report, this was closed two years ago.

Changed in evolution (Ubuntu):
status: Confirmed → Fix Released

Please point me to the new bug. I have the same problem with a local mbox directory feed by fetchmail.

New bug opened. See bug #594351

Changed in evolution:
importance: Unknown → Critical

The problem still persists, with the evolution that come with Ubuntu 10.04.

If you want to trigger it, it's quite easy. Create a "mail account" which is a local mbox folder, which point to a local directory with a couple of mbox files. Then, open one of the files. Exit evolution, and after evolution has exited feed the mboxes via fetchmail/procmail. Restart evolution. You have around 15% probability to see the bug (it happens to me once every 5-7 restarts).

Issuing evolution --force-shutdown, and removing the folders.db file from the directory will solve the problem and at the next restart is all ok. It seems that no mail is lost.

Diane Stiles (dinenpat11) wrote :

My trash doesn't empty and I get nearly the same error message "Summary and Folder Mismatch even after a sync."

Really I do not know why it's marked "fixed". Still happening, with the evolution that goes with Ubuntu 12.10. Happened today to me, and no way to workaround (I tried everything)

Just see the new bug 594351
Happened to me, solved making space in the home directory, and then deleted the files of the bug
594351
, so evolution reindex itself.
Sorry for my english

>----Original Message----
>De: <email address hidden>
>Fecha: 20/10/2012 20:31
>Para: <email address hidden>
>Asunto: [Bug 27014] Re: evolution bug, &quot;Summary and folder mismatch, even after a sync&quot;
>
>Really I do not know why it's marked "fixed". Still happening, with the
>evolution that goes with Ubuntu 12.10. Happened today to me, and no way
>to workaround (I tried everything)
>
>--
>You received this bug notification because you are subscribed to a
>duplicate bug report (276447).
>https://bugs.launchpad.net/bugs/27014
>
>Title:
> evolution bug, "Summary and folder mismatch, even after a sync"
>
>To manage notifications about this bug go to:
>https://bugs.launchpad.net/evolution/+bug/27014/+subscriptions
>

I eventually got rid of Evolution and also got rid of something like
Desk Gnome as well to completely clean out Evolution software. I am
using Thunderbird Email and it is fine so far but not great. I will
eventually put back Evolution when Thunderbird goes down. I am not
having the problems with Evol. of course because I am not using it anymore.

Diane

On 10/20/2012 04:31 PM, Romano Giannetti wrote:
> Really I do not know why it's marked "fixed". Still happening, with the
> evolution that goes with Ubuntu 12.10. Happened today to me, and no way
> to workaround (I tried everything)
>

Displaying first 40 and last 40 comments. View all 112 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.