Upgrade dapper -> hardy fails (because of evolution-plugins?!)

Bug #261990 reported by Thomas on 2008-08-27
2
Affects Status Importance Assigned to Milestone
evolution (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: update-manager

Source: latest dapper
/etc/lsb-release:
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=6.06
DISTRIB_CODENAME=dapper
DISTRIB_DESCRIPTION="Ubuntu 6.06.2 LTS"

Target: latest hardy
tk@t41u:~$ lsb_release -rd
Description: Ubuntu 8.04.1
Release: 8.04

tk@t41u:~$ apt-cache policy update-manager
update-manager:
  Installed: 1:0.87.30
  Candidate: 1:0.87.30
  Version table:
 *** 1:0.87.30 0
        500 http://de.archive.ubuntu.com hardy-updates/main Packages
        100 /var/lib/dpkg/status
     1:0.87.24 0
        500 http://de.archive.ubuntu.com hardy/main Packages

tk@t41u:~$ apt-cache policy evolution-plugins
evolution-plugins:
  Installed: 2.6.1-0ubuntu7.4
  Candidate: 2.22.3.1-0ubuntu1
  Version table:
     2.22.3.1-0ubuntu1 0
        500 http://de.archive.ubuntu.com hardy-updates/main Packages
     2.22.2-0ubuntu1.2 0
        500 http://security.ubuntu.com hardy-security/main Packages
     2.22.1-0ubuntu3 0
        500 http://de.archive.ubuntu.com hardy/main Packages
 *** 2.6.1-0ubuntu7.4 0
        100 /var/lib/dpkg/status

Errors by upgrade:

1.
Could not install '/var/cache/apt/archives/evolution-plugins_2.22.3.1-0ubuntu1_i386.deb'
[...]
there is no script in the new version of the package - giving up

2.
Errors were encountered while processing:
 evolution-plugins
Traceback (most recent call last):
  File "/usr/lib/python2.4/logging/__init__.py", line 740, in emit
    self.flush()
  File "/usr/lib/python2.4/logging/__init__.py", line 718, in flush
    self.stream.flush()
IOError: [Errno 9] Bad file descriptor
Traceback (most recent call last):
  File "/usr/lib/python2.4/logging/__init__.py", line 740, in emit
    self.flush()
  File "/usr/lib/python2.4/logging/__init__.py", line 718, in flush
    self.stream.flush()
IOError: [Errno 9] Bad file descriptor
Traceback (most recent call last):
  File "/usr/lib/python2.4/logging/__init__.py", line 740, in emit
    self.flush()
  File "/usr/lib/python2.4/logging/__init__.py", line 718, in flush
    self.stream.flush()
IOError: [Errno 9] Bad file descriptor
/tmp/tmpaYAUN-/backports/usr/lib/python2.4/site-packages/apt/__init__.py:2: RuntimeWarning: Python C API version mismatch for module apt_pkg: This Python has API version 1013, module apt_pkg has version 1012.
  import apt_pkg
/tmp/tmpaYAUN-/backports/usr/lib/python2.4/site-packages/apt/__init__.py:2: RuntimeWarning: Python C API version mismatch for module apt_pkg: This Python has API version 1013, module apt_pkg has version 1012.
  import apt_pkg

ProblemType: Package
Architecture: i386
Date: Wed Aug 27 21:39:35 2008
DistroRelease: Ubuntu 8.04
ErrorMessage: ErrorMessage: SystemError in cache.commit(): E:Sub-process /tmp/tmpaYAUN-/backports/usr/bin/dpkg returned an error code (1), E:Sub-process /tmp/tmpaYAUN-/backports/usr/bin/dpkg returned an error code (1), E:Sub-process /tmp/tmpaYAUN-/backports/usr/bin/dpkg returned an error code (1)

NonfreeKernelModules: ath_hal
Package: update-manager 1:0.87.30
PackageArchitecture: all
SourcePackage: update-manager
Title: package update-manager 1:0.87.30 failed to install/upgrade: ErrorMessage: SystemError in cache.commit(): E:Sub-process /tmp/tmpaYAUN-/backports/usr/bin/dpkg returned an error code (1), E:Sub-process /tmp/tmpaYAUN-/backports/usr/bin/dpkg returned an error code (1), E:Sub-process /tmp/tmpaYAUN-/backports/usr/bin/dpkg returned an error code (1)
Uname: Linux 2.6.15-52-686 i686

Thomas (th-kaufhold) wrote :
Michael Vogt (mvo) wrote :

Here is what is causing the error:

Preparing to replace evolution-plugins 2.6.1-0ubuntu7.4 (using .../evolution-plugins_2.22.3.1-0ubuntu1_i386.deb) ...
rm: cannot remove `/usr/share/doc/evolution-plugins': Is a directory
Unpacking replacement evolution-plugins ...
dpkg: error processing /var/cache/apt/archives/evolution-plugins_2.22.3.1-0ubuntu1_i386.deb (--unpack):
 there is no script in the new version of the package - giving up
dpkg (subprocess): unable to execute post-installation script: Exec format errordpkg: error while cleaning up:
 subprocess post-installation script returned error exit status 2

Michael Vogt (mvo) wrote :

The error with evolution-plugins might be local corruption of the filesystem, could you please attach the file /var/lib/dpkg/info/evolution-plugins.postinst

Changed in evolution:
assignee: nobody → mvo
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and don't hesitate to submit bug reports in the future.

Changed in evolution:
assignee: mvo → desktop-bugs
importance: Undecided → Low
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers