evolution does not recognize a meeting

Bug #231091 reported by Gaston Lodieu on 2008-05-16
44
Affects Status Importance Assigned to Milestone
Evolution
Fix Released
High
evolution (Ubuntu)
Medium
Sebastien Bacher
Hardy
Undecided
Unassigned
Intrepid
Medium
Sebastien Bacher

Bug Description

Binary package hint: evolution

I receive a meeting and I do not have the options like import to calendar, decline, tentative, accept, etc.
Just, I see it like a common email.
Let me know if you need any kind of info.
Thanks!
Gaston

TESTCASE:

* download http://bugzilla.gnome.org/attachment.cgi?id=111548&action=view which is the testcase attached to the gnome bugzilla bug
* dnd it from nautilus to an evolution box
* view the message

using the buggy version you have only some text displayed, using the new revision you have the meeting invitation displayed correctly

Gaston Lodieu (glodieu) wrote :

I'm using ubuntu 8.04 and evolution 2.22.1.1

Gaston Lodieu (glodieu) wrote :

Also, I'm using a exchange protocol.

Tobias Richter (tsr-ubuntu) wrote :

confirmed as a regression in one of the latest hardy-proposed changes

Changed in evolution:
status: New → Confirmed
Tobias Richter (tsr-ubuntu) wrote :

Temporary fix:
$ sudo apt-get install evolution=2.22.1-0ubuntu3 evolution-common=2.22.1-0ubuntu3 evolution-plugins=2.22.1-0ubuntu3

Sebastien Bacher (seb128) wrote :

thank you for your bug report, do you use the plain-text plugin? does disabling it workaround the issue? that seems similar to http://bugzilla.gnome.org/show_bug.cgi?id=532384

Changed in evolution:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: Confirmed → Incomplete
Changed in evolution:
status: Unknown → New
Tobias Richter (tsr-ubuntu) wrote :

Disabling the plain-text plugin helped here too, that seems to be the culprit.
Thanks!

Changed in evolution:
status: Incomplete → Triaged
Gaston Lodieu (glodieu) wrote :

Disabling the plain-text plugin resolves the problem.
Thanks!

Sebastien Bacher (seb128) wrote :
description: updated
Martin Pitt (pitti) wrote :

Accepted into hardy-proposed. This only affected the previous hardy-proposed version, thus this can be closed now.

Changed in evolution:
status: Triaged → Fix Released
Changed in evolution:
status: New → Fix Released
Daniel Sargeant (dsargeant) wrote :

Version 2.22.2-0ubuntu1 of evolution was installed on my machine as a Hardy recommended update without the fix for this issue. I had to manually disable the plain-text plugin.

Sebastien Bacher (seb128) wrote :

the change has been dropped by mistake and is not in the new version uploaded, it should still be applied, this upload should fix the issue

Changed in evolution:
status: Fix Released → Triaged
Steve Langasek (vorlon) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Johan Mulder (johan-launchpad) wrote :

The proposed update appears to have broken a dependency for the evolution package itsself:
The following packages have unmet dependencies:
  evolution: Depends: libgtkhtml3.14-19 (>= 3.18.2) but 3.18.1-0ubuntu1 is to be installed

Sebastien Bacher (seb128) wrote :

do you have an hardy-updates source enable?

Johan Mulder (johan-launchpad) wrote :

No. Ignore me :(
(it works indeed)

Pedro Villavicencio (pedro) wrote :

I've tested the package and after enable the plain-text plugin with the older evolution and import the testcase attached on the Gnome Bugzilla bug only text is show there. With the package from proposed (still the plain-text plugin enabled), I've removed and imported again the testcase, the meeting invitation is displayed, the bug is fixed, thanks.

Changed in evolution:
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in evolution:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Please apply the patch to Intrepid ASAP. Thanks!

Changed in evolution:
assignee: desktop-bugs → seb128
milestone: none → intrepid-alpha-2
Sebastien Bacher (seb128) wrote :

there is already a newer version in intrepid fixing the issue

Changed in evolution:
status: Triaged → Fix Released
Peter McKenna (peter-mckenna) wrote :

What about Hardy?? This is the long term support version and I received a meeting request 2 days ago that showed up as plain text.
Turning off the prefer plain-text plugin fixed it immediately, but why is the patch still not available in update manager? Is 4 months not enough time?

Sebastien Bacher (seb128) wrote :

did you read the bug log before commenting? the bug has been fixed in an hardy update too

That says Completed: 2008-06-25, yet my system (Hardy) is completely up
to date and this problem still occurs...

On Mon, 2008-10-27 at 09:34 +0000, Sebastien Bacher wrote:
> did you read the bug log before commenting? the bug has been fixed in an
> hardy update too
>

Sebastien Bacher (seb128) wrote :

what version are you using exactly? the hardy-updates one? in which case you have a different issue and should open a new bug describing it clearling and adding an example rather than commenting on a closed one

Peter McKenna (peter-mckenna) wrote :

Hardy Heron 8.04 LTS
Regards,
Peter McKenna

On Tue, 2008-10-28 at 09:06 +0000, Sebastien Bacher wrote:
> what version are you using exactly? the hardy-updates one? in which case
> you have a different issue and should open a new bug describing it
> clearling and adding an example rather than commenting on a closed one
>

Tobias Richter (tsr-ubuntu) wrote :

<email address hidden> wrote:
> Hardy Heron 8.04 LTS

That's not the version of your evolution packages. Please send the
output of 'dpkg -l evolution\*'

Tobias

Peter McKenna (peter-mckenna) wrote :

Here you are,
||/ Name Version Description
+++-===================-===================-======================================================
ii evolution 2.22.3.1-0ubuntu1 groupware suite with mail
client and organizer
ii evolution-common 2.22.3.1-0ubuntu1 architecture independent
files for Evolution
ii evolution-data-serv 2.22.3-0ubuntu2 evolution database backend
server
ii evolution-data-serv 2.22.3-0ubuntu2 architecture independent
files for Evolution Data Serv
un evolution-data-serv <none> (no description available)
un evolution-data-serv <none> (no description available)
un evolution-dbg <none> (no description available)
ii evolution-exchange 2.22.3-0ubuntu2 Exchange plugin for the
Evolution groupware suite
un evolution-jescs <none> (no description available)
ii evolution-plugins 2.22.3.1-0ubuntu1 standard plugins for
Evolution
pn evolution-plugins-e <none> (no description available)
un evolution-scalix <none> (no description available)
ii evolution-webcal 2.21.92-0ubuntu1 webcal: URL handler for
GNOME and Evolution

Sorry if I have submitted my comments in the wrong place, but the page I
found the original bug report on was titled 'Bugs in Ubuntu'.
Regards,
Peter McKenna

On Tue, 2008-10-28 at 13:07 +0000, Tobias Richter wrote:
> <email address hidden> wrote:
> > Hardy Heron 8.04 LTS
>
> That's not the version of your evolution packages. Please send the
> output of 'dpkg -l evolution\*'
>
> Tobias
>

Gavin Graham (gavingraham) wrote :

I have been running Ibex since it was released even with everything up-to-date, I am experiencing this. I too can confirm that disabling the plain text plugin fixes the error.

Changed in evolution:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.