Ubuntu

evolution leaves deleted messages strike through

Reported by Soren Larsen on 2008-05-16
78
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evolution
Fix Released
Medium
evolution (Ubuntu)
Low
Ubuntu Desktop Bugs
Hardy
Medium
Ubuntu Desktop Bugs
Intrepid
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: evolution

Ubuntu v. 8.04
Evolution v. 2.22.1.1
When deleting multiple emails in the evolution GUI, sometimes (as in every second time frequency) the last email is left visible in strike-through. Window refresh (F9) does not solve the problem, however selecting another folder and returning to the inbox makes the deleted entry go away. This bug is cosmetic.

ProblemType: Bug
Architecture: i386
Date: Fri May 16 09:45:34 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/evolution
NonfreeKernelModules: fglrx ath_hal
Package: evolution 2.22.1.1-0ubuntu2
PackageArchitecture: i386
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games
 LANG=en_DK.UTF-8
 SHELL=/bin/bash
SourcePackage: evolution
Uname: Linux 2.6.24-17-generic i686

Soren Larsen (ar2dee2) wrote :
Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it, because your description didn't include enough information. You may find it helpful to read "How to report bugs effectively" http://www.chiark.greenend.org.uk/~sgtatham/bugs.html. We'd be grateful if you would then provide a more complete description of the problem.
 We have instructions on debugging some types of problems. http://wiki.ubuntu.com/DebuggingProcedures
At a minimum, we need:
1. the specific steps or actions you took that caused you to encounter the problem,
2. the behavior you expected, and
3. the behavior you actually encountered (in as much detail as possible).
Thanks!

Changed in evolution:
assignee: nobody → desktop-bugs
status: New → Incomplete
Nico (nico-rdo) wrote :

I second the bug.

In a folder's messages list, delete 1 or more messages, the last one is shown as marked deleted (strikethrough) but does not disappear from the view.

Going to another folder and coming back makes the view proper.

I'm using a Dovecot IMAP server over SSL.

Hardy with security, updates and backports, up-to-date.

This behaviour started with the latest package coming from -updates.

Nico (nico-rdo) wrote :

Not only do I experience the same bug, but I find that the initial report gave the proper facts. Triaging went a bit quick on this one!

Changed in evolution:
status: Incomplete → Confirmed
Sebastien Bacher (seb128) wrote :

confirmed, the title is misleading though, the issue seems to be limited to the case where only one message is in the list, can you confirm that?

Sebastien Bacher (seb128) wrote :

the bug has been sent upstream on http://bugzilla.gnome.org/show_bug.cgi?id=535749

Changed in evolution:
importance: Undecided → Low
status: Confirmed → Triaged
Changed in evolution:
status: Unknown → New
Nico (nico-rdo) wrote :

ah, I have to correct a comment that will arrive here later (sent by email).

It happens to the last message message deleted, yes, but only when it was the last message present in the directory,

Sorry about that, I went too quickly...

Sebastien, merci :o)

Changed in evolution:
status: New → In Progress
Changed in evolution:
status: In Progress → Fix Released
Pedro Villavicencio (pedro) wrote :

fixed upstream, thanks for reporting.

Changed in evolution:
status: Triaged → Fix Committed
Sebastien Bacher (seb128) wrote :
Changed in evolution:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Confirmed
Steve Langasek (vorlon) wrote :

Accepted into -proposed, please test and give feedback here

Changed in evolution:
status: Confirmed → Fix Committed
Nico (nico-rdo) wrote :

cherry-picked the evolution* packages from proposed updates.

Looks like its doing the trick for me.

Many many thanks !

Pedro Villavicencio (pedro) wrote :

I was able to reproduce the issue with evolution 2.22.2-0ubuntu1.2, it indeed leave a message as strike through when you delete them. After installed the proposed version (2.22.2-0ubuntu1.3) i don't have the issue anymore, deleting/moving works as expected (no strike through anymore), bug is fixed, thanks.

Nico (nico-rdo) wrote :

After a day of heavy use of the -proposed packages:

- problem fixed
- no side effect to report

After a whole 15 minutes of light testing of the -proposed package :
- original problem is fixed
- no side effects (except a happy coworker, but that's a good thing!)

Many thanks for the fix!

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in evolution:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Needs fixing in Intrepid ASAP.

Changed in evolution:
milestone: none → intrepid-alpha-2
Sebastien Bacher (seb128) wrote :

new versions have been uploaded to intrepid

Changed in evolution:
status: Fix Committed → Fix Released
peter.senna (peter-senna) wrote :

I'm using Ubuntu 8.04 connected over IMAP on Exchange 2008 server and got same problem. I'm using 2.22.3.1-0ubuntu1.

Lupine (thelupine) wrote :

Using Ubuntu 8.10/Evolution 2.24.1, with a connection to my personal IMAPS server and my works GroupWise server and this is till happening. I've also seen this Gnome bugzilla reporting this issue here: http://bugzilla.gnome.org/show_bug.cgi?id=554530

showgun (showgun) wrote :

Same problem deleted email get a strike through and do not refresh until I close evolution and open open it again changing folders does not work

I am using Karmic 9.10 evolution 2.28.1

Changed in evolution:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.