crashes when copying a task description

Bug #219495 reported by Michael Jastram on 2008-04-19
8
Affects Status Importance Assigned to Milestone
Evolution
Fix Released
Critical
evolution (Ubuntu)
Medium
Ubuntu Desktop Bugs
Hardy
Medium
Ubuntu Desktop Bugs
Intrepid
Medium
Ubuntu Desktop Bugs

Bug Description

TESTCASE

1. Create a new task with some text in the body.
2. Save and close the task editor.
3. View the task in the preview and select some text
4. Copy the text, either using Edit > Copy or Ctrl+c
5. Notice how evolution just closes.

Related branches

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, your crash report is either missing or challenging to deal with as a ".crash" file. Please follow these instructions to have apport report a new bug about your crash that can be dealt with by the automatic retracer.

If you are using Ubuntu with the Gnome desktop environment - launch nautilus and navigate to your /var/crash directory and double click on the crash report you wish to submit.
If you are using Kubuntu or Xubuntu you can file the crash using /usr/share/apport/apport-qt --crash-file=/var/crash/_my_crash_report.crash in a terminal - where _my_crash_report.crash is the crash you would like to report.

I'm closing this bug report since the process outlined above will automatically open a new bug report which can then dealt with more efficiently. Thanks in advance for your cooperation and understanding.

Changed in evolution:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Invalid

This has been confirmed, and fixed upstream.

Steps to reproduce:
1. Create a new task with some text in the body.
2. Save and close the task editor.
3. View the task in the preview and select some text
4. Copy the text, either using Edit > Copy or Ctrl+c
5. Notice how evolution just closes.

Bugzilla bug: http://bugzilla.gnome.org/show_bug.cgi?id=524121

Please add this to a stable release update for Hardy.

Changed in evolution:
status: Invalid → Triaged
status: Triaged → Fix Committed
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Triaged
Sebastien Bacher (seb128) wrote :
description: updated
Sebastien Bacher (seb128) wrote :

The change has been uploaded as an hardy sru now

Changed in evolution:
status: Unknown → Fix Released
Martin Pitt (pitti) wrote :

Accepted into hardy-proposed, please test.

Changed in evolution:
status: Triaged → Fix Committed
Pedro Villavicencio (pedro) wrote :

Verification done:

- With default evolution package available on hardy, after followed the test case, copy text on the task preview, evolution crashed.
- With the proposed package (2.22.1-0ubuntu3.1), after followed the test case, evolution doesn't crash, the bug is fixed.

thanks,

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in evolution:
status: Fix Committed → Fix Released
Martin Pitt (pitti) on 2008-06-16
Changed in evolution:
milestone: none → intrepid-alpha-2
Sebastien Bacher (seb128) wrote :

new versions have been uploaded to intrepid now

Changed in evolution:
status: Fix Committed → Fix Released
Changed in evolution:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.