Evolution and Google calendar

Bug #198111 reported by Mehdi on 2008-03-03
102
Affects Status Importance Assigned to Milestone
Evolution
Fix Released
Medium
evolution (Ubuntu)
Low
Ubuntu Desktop Bugs
Nominated for Hardy by SprocketGizmo

Bug Description

Binary package hint: evolution

System: intel 64
Evolution: 2.21.92

If I make an account for google in Evolution, I can't see any evens from the google calendar. With right click and choosing properties there is no username! If the username is typed it can't be stored and the field of username stays blank.

ProblemType: Bug
Architecture: amd64
Date: Mon Mar 3 20:15:22 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/evolution
Package: evolution 2.21.92-0ubuntu1
PackageArchitecture: amd64
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: evolution
Uname: Linux 2.6.24-11-generic x86_64

Mehdi (mehdi-n1) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. Could you describe how you add the calendar?

Changed in evolution:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Mehdi (mehdi-n1) wrote :

new > calendar > Type : Google > Name: Google calendar > User name: google user name (without gmail.com) > Use ssl: yes > OK

Matthew Gregg (mcg) wrote :

Username field stays blank for me as well. I can see my google calendar events, but cannot add anything however.

Michael R. Head (burner) wrote :

I've tried just about every way of creating a google calendar source. No luck.

I think this is known upstream as either http://bugzilla.gnome.org/show_bug.cgi?id=502900 or http://bugzilla.gnome.org/show_bug.cgi?id=512629

RonSmits (ron-smits) wrote :

I have almost the same problem:
- create a google calendar
- events 2 weeks in the past and 2 weeks in the future are seen
- removing an event does not work
- adding an event does not work
- changing an event does not work
- selecting a date farther away shows an empty calendar
- adding an event in google itself only shows up after stopping and starting evolution

Luis Carlos Cobo (luiscarlos) wrote :

Same problem here.

Matthew Tighe (tighem) wrote :

I'm confirming this exact behavior under Hardy Beta. I can see events but I cannot make changes. Error messages:

(evolution:32022): calendar-gui-CRITICAL **: e_week_view_add_event: assertion `end > add_event_data->week_view->day_starts[0]' failed
BBDB spinning up...
e-data-server-ui-Message: Key file does not have key 'http:__www.google.com_calendar_ical_matthew.e.tighe%40gmail.com_private-097d745c8089ab30cb6daf43602bc6d6_basic.ics'

Changed in evolution:
status: Incomplete → Confirmed
Matthew Tighe (tighem) wrote :

The key error message was related to me trying to "publish" a calendar to google. The real issue I believe is the assertion error.

Matthew Tighe (tighem) wrote :

Sorry, I missed the initial error messages:

(evolution:1518): libecal-WARNING **: e-cal.c:318: Unexpected response

(evolution:1518): calendar-gui-WARNING **: Unable to load the calendar Permission denied

William King (quentusrex) wrote :

Same here... Username disappears....

Nick Russell (thatnick) wrote :

The username disappears for me sometimes (this can be checked by right clicking on the calendar and clicking properties). Other times I will just be prompted for my password every time I tick to show the Google calendar.

2 problems which I suspect are related to the above:

1) I've found that with my vanilla Google calendar though I do get both these problems I can usually, eventually get it to download my events. However, if i make any changes these are not uploaded to Google. If I close and reopen Evolution the events I added are gone. Is it simply that I'm not waiting long enough for the events to be auto uploaded before closing Evolution? Is there a way to force them to upload straight away?

2) With my Google Apps Calendar it doesn't work at all. Events don't download or upload.

I'm finding the same issues that RonSmits reported under Hardy Heron Beta. I can't tell if this is a result of the username not saving or something entirely different. I did look at gconf-editor and noticed that my username had been stored at apps:evolution:calendar:sources.

Jorge Castro (jorge) wrote :

I have filed this bug in the upstream bugzilla.

Changed in evolution:
status: Confirmed → Triaged

Have the same problem...username is always blank in that field and calendar is downloaded OK but changes from Evolution are not propagated.

mxyzptlk (mxyzptlk) wrote :

Same problem, once again. I believe the Google Provider plugin for Lightning/Thunderbird had a similar problem at one point. Strangely, it did seem to accurately offer an alarm I set in Google Calendar, but I'm testing that to make sure.

gutocarvalho (gutocarvalho) wrote :

Here i create an account but i cant see events.

Username dissapear

Evolution crash when trying to connect with google.

Please look the backtrace.

gutocarvalho (gutocarvalho) wrote :

Valgrind log of evolution calendar crash

deuce (azinas) wrote :

Nothing yet? I have the same problem... At least give us an explanation, or that you are working on it, or that we need to find some other mail/calendar application or smth...

Michael R. Head (burner) wrote :

Well, Ubuntu doesn't develop Evolution, probably it's better to ask on the gnome bugzilla.

The best option I've found so far is to get the private ical feed from each google calendar you want to access locally and add it as a calendar "On the Web". That way, the events show up in evolution and in the clock/calendar widget.

This calendar will be read only as far as Evolution is concerned, but you can sign in to the google calendar web site to make changes and they'll be reflected locally.

Raghvendra Sharma (raghav) wrote :

I faced something similar. Since its really my first time, I filed a new bug report (216123) which has aptly been marked as duplicate of this one.

However, in my situation, it does remember the username. And its not able to show any events at all. Basically the application just crashes.

Checking gconf-editor its visible that it has tried to store the same info mentioned earlier.

@Michael : The workaround you suggest was working in previous version as well, I have to say, I personally was looking forward to have the ability to publish from evolution to google as a key thing (like the calendar plugin for thunderbird provides). Thats been one big reason for me to wait for the new version of Evolution.

Could one of you post the corresponding bug number or so that has been filed with evolution team (gnome bugzilla) ? I'm rather new so I dont really know how it works.

Milan Krivda (milan-krivda) wrote :

Same problem on Ubuntu 8.04 RC with Evlution 2.22.1. Only one time i successfully used google calendar in evolution, not all events was readed and readed has bad start and end time.

mb (mattb108) wrote :

Same problem, seems to work if I disable SSL. However, I still get errors about invalid start dates, seems to be a problem with all day events created in Gcal.

Changed in evolution:
status: Unknown → New
reneyo (reneyo) wrote :

Same exact problem here in that events are not pushed to the google server. Also, username field is blank after the calendar is created.

BTW - How do I view the logs evolution outputs?

Alden (jason-alden-benoit) wrote :

Until Ubuntu Hardy pushed out the updates today, I was unable to get Evolution to ask for my Google account password. I can read events but I am still unable to edit them in Evolution.

isaac (isaac-abraham) wrote :

Slight variation to this bug... using Hardy, I can successfully view my own Google Calendar, but when I view the private .ics file of a friend by http://, Evolution only shows me initially the first few weeks of that calendar, even though there are entries for several months. After maybe 15 minutes it has downloaded some more, for ex. up until June, although there are entries in the calendar all year round. If I download the .ics file locally and use it as a local calendar, Evolution correctly shows me all the entries instantaneously.

Michael R. Head (burner) wrote :

@isaac

You can view the console output of evolution by running evo from a Terminal:

Applications/Accessories/Terminal
Then:
  evolution --force-shutdown
  evolution
(console output will follow)

markus haider (markus.haider) wrote :

I have the same problem, I can't view my google calender. And when rightclicking on the calender and going to the properties username is gone and ssl is activated, (also if I deactivated it before)

Console Output of evolution (sorry that its in german, I'll translate the relevant parts)
(evolution:8092): calendar-gui-WARNING **: Unable to load the calendar Legitimation gescheitert
[translation: legitimation failed]

e-data-server-ui-Message: Die Schlüsselwertedatei hat keinen Schlüssel »Google:__http:__www.google.com_calendar_feeds_myemail@host.at_private_full« in der Gruppe »Passwords-google«
[translation: the key file doesn't contain a key, ... in group passwords google]
e-data-server-ui-Message: Die Schlüsselwertedatei enthält nicht den Schlüssel »Google:__http:__www.google.com_calendar_feeds_myemail@host.at_private_full«
[translation: the key file doesn't contain the key, ... ]

But I'm sitting behind a quite strictly governed network, so could it be due to some ports blocked?

Joseph Smidt (jsmidt) wrote :

I have the same above problems: can't view Google calender and it loses my user name too.

Jeffrey Thompson (jthompsonic) wrote :

I have the same problem. Username goes blank. The calendar doesn't seem to sync. When I move other calendar items over to the Google calendar, they seem to move, but then they disappear.

Alden (jason-alden-benoit) wrote :

I had this issue resolved with recent updates in the last week or two. Are your systems fully up to date? Mehdi, are you still experiencing this? The only issues I have now are occasional crashing which according to bug reports/Ubuntu forums seems to be related to Evolution Google plugin, and that I can't 2 way sync, just sync from Google Calendar to Evolution. I haven't tested for the 2way sync recently and it could, but I doubt be working.

 On a side note, the password is now accessed from the keyring. (I remember seeing this update.) I get a pop-up asking do I want to allow retrieval once or from now on. This could be related to this issue, as that is how I suppose it was intended to work.

Michael R. Head (burner) wrote :

Yeah, I think this is fixed in evo's hardy-proposed packages, though I don't think the updated packages are in hardy-updates yet.

Rob Petti (rob-petti) wrote :

I've got 2.22.2 from hardy-proposed running right now, and the problem still exists. Username disappears after entering it, and it only syncs from google to evolution instead of both ways.

Matthew Gregg (mcg) wrote :

Ditto'ing Rob Petti. Google Calendar syncs one way. I cannot create new events. Username disappears.

Busby (mobusby) wrote :

Using Hardy, and all of the updates from proposed, I continue to get similar odd behavior. I can't add events to google calendar. Some back events, a very small fraction, are displayed, though (from a month or more in the past). Also, I get the following output when I run evolution from a terminal.

It is interesting to note that Lightning in Mozilla Thunderbird with the provider for Google Calendar extension supports read/write/updating of my google calendar flawlessly.

Same problem here. Once again Evolution is disappointing me.

j_esarey (jesarey) wrote :

I have the same bug above: evolution forgets my google calendar username, and I can't add events from within evolution. I can /see/ events that are already in the calendar or are added via the Google Calendar web interface. I'm hoping for a resolution of this problem, as otherwise Evolution has been great.

Gavin Graham (gavingraham) wrote :

I get the following messages (and plenty of them) when I run EVO from a shell:

(evolution:14569): calendar-gui-CRITICAL **: e_day_view_add_event: assertion `end > add_event_data->day_view->lower' failed

(evolution:14569): calendar-gui-CRITICAL **: e_week_view_add_event: assertion `end > add_event_data->week_view->day_starts[0]' failed

libecal-Message: e_cal_recur_generate_instances_of_rule(): bogus component, does not have DTSTART. Skipping...

Fabus (fabian-gebert-hh) wrote :

Same problem here. I don't quite understand why the feature is not just removed. There is no sense in non-working features.

Changed in evolution:
status: New → In Progress
Chris Roddy (cmr) wrote :

this is still reproducible on 2.22.3.1. i get nothing, no password prompt, no error, no events, just the erased username and empty calendar.

amitm02 (amit-man) wrote :

confirming in hardy, evolution 2.22.3.1.

Changed in evolution:
status: In Progress → Fix Released
Pedro Villavicencio (pedro) wrote :

this was fixed upstream, thanks for reporting.

Changed in evolution:
status: Triaged → Fix Committed

Thanks for fixing it :)

On Aug 20, 2008, at 2:16 PM, Pedro Villavicencio wrote:

> this was fixed upstream, thanks for reporting.
>
> ** Changed in: evolution (Ubuntu)
> Status: Triaged => Fix Committed
>
> --
> Evolution and Google calendar
> https://bugs.launchpad.net/bugs/198111
> You received this bug notification because you are a direct subscriber
> of the bug.

raeanne (raeanne-young) wrote :

so when will this be fixed in hardy backports?

Charles Tryon (charles-tryon) wrote :

I am using Fedora 9 and have the latest evolution update (evolution-2.22.3.1-1), and I can see calendar events from Google, but changes made in Evolution are not synced back to Google.

I'm not sure yet, but I also think that I am not seeing any private events getting synced from Google to Evolution, but there's no way to specify that you want private events.

Charles Tryon (charles-tryon) wrote :

I'm also finding that if I *change* the time or date of an event in Google, the updates don't seem to make it back to Evolution

Sebastien Bacher (seb128) wrote :

the new version is in intrepid

Changed in evolution:
status: Fix Committed → Fix Released

With Evolution 2.24.3 in intripid (on an intel 64bit machine) I can easily add the google calendars (I have my own and some shared, which I have write access to). The event in the calendars show up nicely. But the following things I have been unable to achieve:

1) Update/Create an event in evolution which would then be synced to google calendar.
2) Update/Create an event in google calendar which would then be synced to evolution.

Using wireshark to look at the traffic I notices that the google-calendar integration suffers from the same issues as the CalDAV integration:

https://bugs.launchpad.net/ubuntu/+source/evolution-caldav/+bug/138746

Basically Evolution wants to ask for the "OPTIONS" and google says "HTTP/1.1 501 Not Implemented".

Changed in evolution:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.