Evolution checks junk only at start

Bug #193377 reported by emilio
6
Affects Status Importance Assigned to Milestone
Evolution
Expired
Medium
evolution (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: evolution

I am running Ubuntu Gutsy and Evolution 2.12.1-0ubuntu1. After some pain I have managed to have the spam filter working in evolution (both Bogofilter and Spamassasin work in my case).

However evolution runs automaticly a spam check on new messages only on the first receive when evolution starts. On the subsequent automatic or manual run send/receive operations no spam checking is performed.

Note that if I manually selecting the new mail and I manually runing "message->check for junk" also works in my case.

Revision history for this message
Alex Ruddick (alexrudd0) wrote :

Reported upsteam at bugzilla.gnome.org

http://bugzilla.gnome.org/show_bug.cgi?id=517516

Revision history for this message
Pedro Villavicencio (pedro) wrote :

May you tell us if you're running IMAP or POP, upstream wants to know, thanks.

Changed in evolution:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Revision history for this message
emilio (emiliomaggio) wrote :

I am running both but I am sure of the bug for the IMAP one. I will try to test also on POP

Revision history for this message
Alex Ruddick (alexrudd0) wrote :

It would save time and effort if you can register at bugzilla.gnome.org and comment on the bug I linked to there.

That way, you can talk directly to the developers and hopefully get this triaged faster.

Changed in evolution:
status: Unknown → New
Revision history for this message
Milan Bouchet-Valat (nalimilan) wrote :

Could you confirm the bug is still occurring in Hardy? Sorry if upstream did not answer to your informations, but we cannot exclude it was 'magically' solved. By the way, you may want to use the bogofilter plugin to filter junk, this one is installed by default since Hardy, and should work.

Changed in evolution:
status: Incomplete → Confirmed
Revision history for this message
emilio (emiliomaggio) wrote :

As you said the bug is magically solved in Hardy

Revision history for this message
Milan Bouchet-Valat (nalimilan) wrote :

Thanks!

Changed in evolution:
status: Confirmed → Fix Released
Changed in evolution:
status: New → Invalid
Changed in evolution:
importance: Unknown → Medium
status: Invalid → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.