Ubuntu

Calendar preview reports the wrong date for meetings

Reported by Lee Maguire on 2008-01-29
2
Affects Status Importance Assigned to Milestone
Evolution
Fix Released
Medium
evolution (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: evolution

I receive an ics calendar attachment in email, the inline preview claims it is for a meeting tomorrow (Wednesday), but when I add it to my calendar it is for Friday.

The DTSTART and DEND fields in the ics are for Friday, so there appears to be a bug in the inline email preview.

Attached is an ics file for an event scheduled for 2008-02-01, and how it appears in my email on 2008-01-29 - suggesting the event is on 2008-01-30.

Running 2.21.5-0ubuntu1 under hardy (preview).

ProblemType: Bug
Architecture: i386
Date: Tue Jan 29 12:58:24 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/evolution
Package: evolution 2.21.5-0ubuntu1
PackageArchitecture: i386
ProcCmdline: evolution --component=mail
ProcCwd: /home/lee
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: evolution
Uname: Linux zoidberg 2.6.24-5-generic #1 SMP Thu Jan 24 19:45:21 UTC 2008 i686 GNU/Linux

Lee Maguire (leemaguire) wrote :
Lee Maguire (leemaguire) wrote :
Lee Maguire (leemaguire) wrote :
Lee Maguire (leemaguire) wrote :

If I load up the mail today, it shows the correct event date as "Friday, February 1". It appears the problem is/was with whatever function interprets the date into "Tomorrow" etc.

Lee Maguire (leemaguire) wrote :

On Thursday, the date was given as "Friday" rather than "Tomorrow". The event today is given as "Today".

Sebastien Bacher (seb128) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=514989

Changed in evolution:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Triaged
Changed in evolution:
status: Unknown → New
Changed in evolution:
status: New → In Progress
Changed in evolution:
importance: Unknown → Medium
Changed in evolution:
status: In Progress → Fix Released
Jörg Frings-Fürst (jff-de) wrote :

change status to fix released (see gnome bug)

Changed in evolution (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.