Ubuntu Gnome Bug -evolution translation

Bug #1572661 reported by NoOne on 2016-04-20
78
This bug affects 16 people
Affects Status Importance Assigned to Milestone
evolution (Ubuntu)
High
Unassigned
Xenial
High
Unassigned

Bug Description

* Impact
evolution is not translated

* Test case
start evolution under a non english locale, it should be translated

* Regression potential
none, that's a small packaging change to add translations to the deb

-----------------

Ubuntu Gnome 16.04 RC

Evolution is not translated in another language. It is in english only.

Affects at least french (canadian), Norwegian (Bokmål) and german (seen on a Google Plus post :

https://plus.google.com/+UbuntuGNOMEorg/posts/bsFL3SLf6ot

NoOne (1noname) on 2016-04-20
affects: imagemagick (Ubuntu) → evolution (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in evolution (Ubuntu):
status: New → Confirmed

Same here with Norwegian.
Some things are translated something is not.

description: updated
ockels (ockels) wrote :

No dutch translation.

/usr/share/locale-langpack/nl/LC_MESSAGES/evolution-data-server-3.18.mo is present

nomentero (toni7) wrote :

Same here Spanish traslation.

Bratmaxe (marcel-456) wrote :

Workaround from here:

https://askubuntu.com/questions/763412/how-can-i-get-german-language-in-evolution-for-ubuntu-16-04

1.
Download Evolution evolution_3.18.5.2.orig.tar.xz from here:

https://launchpad.net/ubuntu/xenial/+source/evolution

2.
Extract translation "{LANG}.po" for your language from "po" dir in archive

3.
Convert .po file to .mo:

msgfmt -cv -o /path/to/evolution-3.18.mo /path/to/{LANG}.po

4.
Copy evolution-3.18.mo to /usr/share/locale-langpack/{LANG}/LC_MESSAGES/evolution-3.18.mo

5.
Restart Evolution, enjoy.

The same happen with Catalan

Changed in evolution (Ubuntu):
importance: Undecided → High
status: Confirmed → In Progress
description: updated
Changed in evolution (Ubuntu):
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

This does/should not apply to yakkety, we'll fix the langpacks properly there. This is just an intermediate SRU for xenial indeed.

Changed in evolution (Ubuntu):
status: Fix Committed → Invalid
Changed in evolution (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed

Hello Claude, or anyone else affected,

Accepted evolution into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/evolution/3.18.5.2-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Tomáš Klos (tkl) wrote :

Hello, I can confirm that the translation in 3.18.5.2-0ubuntu2 version works correctly for Czech language. Thanks!

Kristian Rink (kawazu) wrote :

Works for me (de_DE) with the packages in -proposed. Thanks. :)

olavl (olavl) wrote :

Dutch translation works with evolution_3.18.5.2-0ubuntu3 from Proposed.

tags: added: verification-done
removed: verification-needed
NoOne (1noname) wrote :

I can also confirmed that the Evolution in Xenial-Proposed works.

It's now in french.

Thanks a lot !

NoOne (1noname) wrote :

But...

I can also say that this xenial-proposed version crashes easily.

I wanted to hide the information/header of one email, the buton with the sign " - " and Evolution closed immediatley.

Sebastien Bacher (seb128) wrote :

the code didn't change so the segfault was probably there before, worth reporting a new bug about that though

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evolution - 3.18.5.2-0ubuntu3

---------------
evolution (3.18.5.2-0ubuntu3) xenial; urgency=medium

  * debian/control:
    - remove the X-Ubuntu-Use-Langpack line rather than commenting it
      due pkgstriptranslations not understanding the # (being fixed,
      but meanwhile let's get that SRU working)

evolution (3.18.5.2-0ubuntu2) xenial; urgency=medium

  * debian/control:
    - don't define X-Ubuntu-Use-Langpack, due to a langpack-o-matic bug the
      evolution translations are missing from xenial. The tools are fixed
      but langpack updates are too much work to do one for that specific issue
      so we are going back to include translations until the next export.
      (lp: #1572661)

 -- Sebastien Bacher <email address hidden> Wed, 25 May 2016 08:19:06 +0200

Changed in evolution (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for evolution has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in evolution (Ubuntu Xenial):
importance: Undecided → High
status: Fix Released → Triaged
Sebastien Bacher (seb128) wrote :

I've reuploaded an update that re-enable languagepack use since next export are coming

Gunnar Hjalmarsson (gunnarhj) wrote :

evolution-3.18.mo is included in the language-pack-gnome-*-base packages, which are currently in xenial-proposed for verification and will be moved to -updates around July 14th.

Gianvito Cavasoli (janvitus) wrote :

Evolution 3.22 in Yakkety, same problem, missing some strings of the italian translation, upstream is complete: https://l10n.gnome.org/vertimus/evolution/gnome-3-22/po/it

Gunnar Hjalmarsson (gunnarhj) wrote :

Yeah, there are quite a few untranslated strings in Launchpad:

https://translations.launchpad.net/ubuntu/yakkety/+source/evolution/+pots/evolution/it/+translate?show=untranslated

@Gianvito: I don't think this is quite the same issue. Can you please file a new bug about yakkety.

Changed in evolution (Ubuntu Xenial):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers