evolution: hang on startup after upgrade

Bug #15447 reported by Debian Bug Importer on 2005-04-13
8
Affects Status Importance Assigned to Milestone
evolution (Debian)
Fix Released
Unknown
evolution (Ubuntu)
High
Sebastien Bacher

Bug Description

Automatically imported from Debian bug report #304437 http://bugs.debian.org/304437

# Automatically generated email from bts, devscripts version 2.8.10
tags 304437 sid

Debian Bug Importer (debzilla) wrote :

Automatically imported from Debian bug report #304437 http://bugs.debian.org/304437

Debian Bug Importer (debzilla) wrote :
Download full text (8.6 KiB)

Message-Id: <20050413051404.AF7483B668C@krebs>
Date: Tue, 12 Apr 2005 23:14:04 -0600
From: dann frazier <email address hidden>
To: Debian Bug Tracking System <email address hidden>
Subject: evolution: hang on startup after upgrade

Package: evolution
Version: 2.2.1.1-1
Severity: grave
Justification: renders package unusable

After upgrading to 2.2.1.1-1, evolution hangs on startup.
The main window renders, but immediately freezes. This also happens if
passed --offline.

$ LD_LIBRARY_PATH=/usr/lib/debug gdb /usr/bin/evolution
GNU gdb 6.3-debian
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB. Type "show warranty" for details.
This GDB was configured as "ia64-linux"...(no debugging symbols found)
Using host libthread_db library "/usr/lib/debug/libthread_db.so.1".

(gdb) run
Starting program: /usr/bin/evolution
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
---Type <return> to continue, or q <return> to quit---
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 16384 (LWP 18684)]

es menu class init
adding hook target 'source'
[New Thread 32769 (LWP 18691)]
[New Thread 16386 (LWP 18692)]
[New Thread 32771 (LWP 18693)]
[New Thread 49156 (LWP 18694)]
[New Thread 65541 (LWP 18695)]
[Thread 32771 (LWP 18693) exited]
[New Thread 81926 (LWP 18696)]
[New Thread 98307 (LWP 18697)]
[Thread 81926 (LWP 18696) exited]
[New Thread 114694 (LWP 18698)]
[Thread 114694 (LWP 18698) exited]

(evolution:18684): evolution-mail-WARNING **: Error occured while existing dialogue active:
Could not connect to localhost: SSL unavailable

Program received signal SIGINT, Interrupt.
[Switching to Thread 98307 (LWP 18697)]
__pthread_sigsuspend (set=0x20000000049dbe00)
    at ../linuxthreads/sysdeps/unix/sysv/linux/ia64/pt-sigsuspend.c:32
32 ../linuxthreads/sysdeps/unix/sysv/linux/ia64/pt-sigsuspend.c: No such file or directory.
        in ../linuxthreads/sysdeps/unix/sysv/linux/ia64/pt-sigsuspend.c
(gdb) bt
#0 __pthread_sigsuspend (set=0x20000000049dbe00)
    at ../linuxthreads/sysdeps/unix/sysv/linux/ia64/pt-sigsuspend.c:32
#1 0x200000000237f2f0 in __pthread_wait_for_re...

Read more...

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Tue, 12 Apr 2005 22:42:12 -0700
From: Steve Langasek <email address hidden>
To: <email address hidden>
Subject: tagging 304437

# Automatically generated email from bts, devscripts version 2.8.10
tags 304437 sid

Download full text (5.9 KiB)

Package: evolution
Version: 2.2.2-1
Followup-For: Bug #304437

The evolution upgrade to 2.2.1 worked for me. Evolution started up without any problems. Evolution prints a lot of messages about charset converters but I do
not remember if this was there before 2.2.1. The following lines are a sample of the warning messages but not all of them...

(evolution:15309): e-data-server-WARNING **: Could not open converter for 'iso-8216-6' to 'UTF-8' charset

(evolution:15309): e-data-server-WARNING **: Could not open converter for 'iso-9447-0' to 'UTF-8' charset

(evolution:15309): e-data-server-WARNING **: Could not open converter for 'iso-1272-9' to 'UTF-8' charset

(evolution:15309): e-data-server-WARNING **: Could not open converter for 'iso-839-3' to 'UTF-8' charset

(evolution:15309): e-data-server-WARNING **: Could not open converter for 'iso-8131-2' to 'UTF-8' charset

(evolution:15309): e-data-server-WARNING **: Could not open converter for 'iso-5162-8' to 'UTF-8' charset

(evolution:15309): e-data-server-WARNING **: Could not open converter for 'EUC' to 'UTF-8' charset

(evolution:15309): e-data-server-WARNING **: Could not open converter for 'iso-2690-4' to 'UTF-8' charset

(evolution:15309): camel-WARNING **: Block 8192 invalid scanning keys

(evolution:15309): e-data-server-WARNING **: Could not open converter for 'unknown-8bit' to 'UTF-8' charset

-- System Information:
Debian Release: 3.1
  APT prefers unstable
  APT policy: (990, 'unstable')
Architecture: i386 (i686)
Kernel: Linux 2.6.12-rc1
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)

Versions of packages evolution depends on:
ii evolution-data-serve 1.2.2-1 evolution database backend server
ii gconf2 2.8.1-5 GNOME configuration database syste
ii gnome-icon-theme 2.8.0-4 GNOME Desktop icon theme
ii gtkhtml3.6 3.6.2-1 HTML rendering/editing library - b
ii libart-2.0-2 2.3.17-1 Library of functions for 2D graphi
ii libatk1.0-0 1.8.0-4 The ATK accessibility toolkit
ii libaudiofile0 0.2.6-6 Open-source version of SGI's audio
ii libbonobo2-0 2.8.1-2 Bonobo CORBA interfaces library
ii libbonoboui2-0 2.8.1-2 The Bonobo UI library
ii libc6 2.3.2.ds1-20 GNU C Library: Shared libraries an
ii libcamel1.2-0 1.2.2-1 The Evolution MIME message handlin
ii libcompfaceg1 1989.11.11-24 Compress/decompress images for mai
ii libebook1.2-3 1.2.2-1 Client library for evolution addre
ii libecal1.2-2 1.2.2-1 Client library for evolution calen
ii libedataserver1.2-4 1.2.2-1 Utily library for evolution data s
ii libedataserverui1.2- 1.2.2-1 GUI utily library for evolution da
ii libesd0 0.2.35-2 Enlightened Sound Daemon - Shared
ii libfontconfig1 2.3.1-2 generic font configuration library
ii libfreetype6 2.1.7-2.3 FreeType 2 font engine, shared lib
ii libgail-common 1.8.2-1 GNOME Accessibility Implementation
ii li...

Read more...

severity 304437 important
tag 304437 unreproducible
stop

2005-04-12 (火) の 23:14 -0600 に dann frazier さんは書きました:
> Package: evolution
> Version: 2.2.1.1-1
> Severity: grave
> Justification: renders package unusable
>
> After upgrading to 2.2.1.1-1, evolution hangs on startup.
> The main window renders, but immediately freezes. This also happens if

No such problems for me. could you please try again with 2.2.2-1?
--
Takuo KITAME

On Thu, 2005-04-14 at 12:31 +0900, Takuo KITAME wrote:
> severity 304437 important
> tag 304437 unreproducible
> stop
>
> 2005-04-12 (火) の 23:14 -0600 に dann frazier さんは書きました:
> > Package: evolution
> > Version: 2.2.1.1-1
> > Severity: grave
> > Justification: renders package unusable
> >
> > After upgrading to 2.2.1.1-1, evolution hangs on startup.
> > The main window renders, but immediately freezes. This also happens if
>
> No such problems for me. could you please try again with 2.2.2-1?

Thanks for your quick reply. Did you happen to try on a 64-bit system?
Most problems I hit with evolution are 64-bitisms.

Anyway, this problem is actually gone in 2.2.2-1, so I'm closing this
bug. I've hit another issue, but have filed it separately.

Debian Bug Importer (debzilla) wrote :
Download full text (6.1 KiB)

Message-Id: <E1DLsZd-0003zv-8N@liberate>
Date: Wed, 13 Apr 2005 20:51:12 -0400
From: "Douglas F. Calvert" <email address hidden>
To: Debian Bug Tracking System <email address hidden>
Subject: evolution: Upgrade worked for me

Package: evolution
Version: 2.2.2-1
Followup-For: Bug #304437

The evolution upgrade to 2.2.1 worked for me. Evolution started up without any problems. Evolution prints a lot of messages about charset converters but I do
not remember if this was there before 2.2.1. The following lines are a sample of the warning messages but not all of them...

(evolution:15309): e-data-server-WARNING **: Could not open converter for 'iso-8216-6' to 'UTF-8' charset

(evolution:15309): e-data-server-WARNING **: Could not open converter for 'iso-9447-0' to 'UTF-8' charset

(evolution:15309): e-data-server-WARNING **: Could not open converter for 'iso-1272-9' to 'UTF-8' charset

(evolution:15309): e-data-server-WARNING **: Could not open converter for 'iso-839-3' to 'UTF-8' charset

(evolution:15309): e-data-server-WARNING **: Could not open converter for 'iso-8131-2' to 'UTF-8' charset

(evolution:15309): e-data-server-WARNING **: Could not open converter for 'iso-5162-8' to 'UTF-8' charset

(evolution:15309): e-data-server-WARNING **: Could not open converter for 'EUC' to 'UTF-8' charset

(evolution:15309): e-data-server-WARNING **: Could not open converter for 'iso-2690-4' to 'UTF-8' charset

(evolution:15309): camel-WARNING **: Block 8192 invalid scanning keys

(evolution:15309): e-data-server-WARNING **: Could not open converter for 'unknown-8bit' to 'UTF-8' charset

-- System Information:
Debian Release: 3.1
  APT prefers unstable
  APT policy: (990, 'unstable')
Architecture: i386 (i686)
Kernel: Linux 2.6.12-rc1
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)

Versions of packages evolution depends on:
ii evolution-data-serve 1.2.2-1 evolution database backend server
ii gconf2 2.8.1-5 GNOME configuration database syste
ii gnome-icon-theme 2.8.0-4 GNOME Desktop icon theme
ii gtkhtml3.6 3.6.2-1 HTML rendering/editing library - b
ii libart-2.0-2 2.3.17-1 Library of functions for 2D graphi
ii libatk1.0-0 1.8.0-4 The ATK accessibility toolkit
ii libaudiofile0 0.2.6-6 Open-source version of SGI's audio
ii libbonobo2-0 2.8.1-2 Bonobo CORBA interfaces library
ii libbonoboui2-0 2.8.1-2 The Bonobo UI library
ii libc6 2.3.2.ds1-20 GNU C Library: Shared libraries an
ii libcamel1.2-0 1.2.2-1 The Evolution MIME message handlin
ii libcompfaceg1 1989.11.11-24 Compress/decompress images for mai
ii libebook1.2-3 1.2.2-1 Client library for evolution addre
ii libecal1.2-2 1.2.2-1 Client library for evolution calen
ii libedataserver1.2-4 1.2.2-1 Utily library for evolution data s
ii libedataserverui1.2- 1.2.2-1 GUI utily library for evolution da
ii libesd0 0.2.35-2 Enlightened Sound Daemon - Shared
ii libfontconfig1 ...

Read more...

Debian Bug Importer (debzilla) wrote :

Message-Id: <1113449473.26658.4.camel@localhost>
Date: Thu, 14 Apr 2005 12:31:13 +0900
From: Takuo KITAME <email address hidden>
To: <email address hidden>, dann frazier <email address hidden>
Cc: bts-control <email address hidden>
Subject: Re: Bug#304437: evolution: hang on startup after upgrade

severity 304437 important
tag 304437 unreproducible
stop

2005-04-12 ($B2P(B) $B$N(B 23:14 -0600 $B$K(B dann frazier $B$5$s$O=q$-$^$7$?(B:
> Package: evolution
> Version: 2.2.1.1-1
> Severity: grave
> Justification: renders package unusable
>
> After upgrading to 2.2.1.1-1, evolution hangs on startup.
> The main window renders, but immediately freezes. This also happens if

No such problems for me. could you please try again with 2.2.2-1?
--
Takuo KITAME

Debian Bug Importer (debzilla) wrote :

Message-Id: <1113513427.24513.1.camel@localhost>
Date: Thu, 14 Apr 2005 15:17:07 -0600
From: dann frazier <email address hidden>
To: Takuo KITAME <email address hidden>
Cc: <email address hidden>, <email address hidden>
Subject: Re: Bug#304437: evolution: hang on startup after upgrade

On Thu, 2005-04-14 at 12:31 +0900, Takuo KITAME wrote:
> severity 304437 important
> tag 304437 unreproducible
> stop
>=20
> 2005-04-12 (=E7=81=AB) =E3=81=AE 23:14 -0600 =E3=81=AB dann frazier =E3=
=81=95=E3=82=93=E3=81=AF=E6=9B=B8=E3=81=8D=E3=81=BE=E3=81=97=E3=81=9F:
> > Package: evolution
> > Version: 2.2.1.1-1
> > Severity: grave
> > Justification: renders package unusable
> >=20
> > After upgrading to 2.2.1.1-1, evolution hangs on startup.
> > The main window renders, but immediately freezes. This also happens =
if
>=20
> No such problems for me. could you please try again with 2.2.2-1?

Thanks for your quick reply. Did you happen to try on a 64-bit system?
Most problems I hit with evolution are 64-bitisms.

Anyway, this problem is actually gone in 2.2.2-1, so I'm closing this
bug. I've hit another issue, but have filed it separately.

Sebastien Bacher (seb128) wrote :

fixed according to the debian comment

Changed in evolution:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.