Error when trying to connect to Google online account.

Bug #1519098 reported by Barry Drake on 2015-11-23
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evolution
Invalid
Medium
evolution (Ubuntu)
High
Unassigned

Bug Description

On trying to connect to my Google online account, I received the following error message:

Failed to connect address book 'Google : Barry'
The requested resource was not found: https://developers.google.com/accounts/docs/AuthForInstalledApps

On checking the above URL, I found this: "Important: ClientLogin has been officially deprecated since April 20, 2012 and is now no longer available. Requests to ClientLogin will fail with a HTTP 404 response. We encourage you to migrate to OAuth 2.0 as soon as possible".

OAuth 2.0 is described at: https://developers.google.com/identity/protocols/OAuth2

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: evolution 3.18.2-0ubuntu1
ProcVersionSignature: Ubuntu 4.2.0-19.23-generic 4.2.6
Uname: Linux 4.2.0-19-generic x86_64
ApportVersion: 2.19.2-0ubuntu6
Architecture: amd64
CurrentDesktop: Unity
Date: Mon Nov 23 20:48:04 2015
InstallationDate: Installed on 2015-11-12 (11 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20151111)
SourcePackage: evolution
UpgradeStatus: No upgrade log present (probably fresh install)

Barry Drake (b-drake) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in evolution (Ubuntu):
importance: Undecided → High
Barry Drake (b-drake) wrote :

I have reported the bug upstream as Gnome bug #758581
See: https://bugzilla.gnome.org/show_bug.cgi?id=758581

Sebastien Bacher (seb128) wrote :

The bug you are pointed at is supposed to be fixed in 3.18 no? Where did they write that it's an Ubuntu issue?

Barry Drake (b-drake) wrote :

It isn't fixed in the current version of Ubuntu. This is 3.18.2. The upstream Gnome Bug report says that it is fixed, but not for the 'Contacts' code. 'Contacts is all I use Evolution for. It is not an Ubuntu issue, you're right is saying that. The bug I reported was found to be a duplicate of Gnome bug #751979. The following comment exists at the bottom of that bug: "Calendars are fine, for now, it's only the Contacts part. I was thinking of disabling it, but didn't get to it yet. Well, until now".

Changed in evolution:
importance: Unknown → Medium
status: Unknown → Invalid
Sebastien Bacher (seb128) wrote :

Right, he wrote "until now" then commited https://git.gnome.org/browse/evolution/commit/?id=6adcf74 and seems they fixed the issue correctly in 3.19

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in evolution (Ubuntu):
status: New → Confirmed
Axel Pospischil (apos) wrote :

I just tried to give evolution 3.19 a try.

So I enabled (temporally) the gnome3-staging ppa, installed the evolutin 3.19 packages, but I still receive an error, when connecting to google address book:

GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._e_2dclient_2derror_2dquark.Code5:

I also cannot add connect to google calendar:

HTTP: auth error

---------------------------------------------------------------------
Here is what I did on freshly updated ubuntu 16.04:

[1] gnome3-staging ppa
apt-add-repository ppa:gnome3-team/gnome3-staging
apt-get update

[2] install aptitude (better in this case for updating)
apt install aptitude

[3] update evolution
aptitude install evolution evolution-data-server-online-accounts evolution-plugins
Die folgenden NEUEN Pakete werden zusätzlich installiert:
  libcamel-1.2-57{a}
Die folgenden Pakete werden ENTFERNT:
  libcryptui0a{u} seahorse-daemon{u}
Die folgenden Pakete werden aktualisiert:
  evolution evolution-common evolution-data-server evolution-data-server-common evolution-data-server-online-accounts evolution-plugins libedataserver-1.2-21 libevolution
8 Pakete aktualisiert, 1 zusätzlich installiert, 2 werden entfernt und 158 nicht aktualisiert.
0 B/13,2 MB an Archiven müssen heruntergeladen werden. Nach dem Entpacken werden 38,2 MB zusätzlich belegt sein.
Möchten Sie fortsetzen? [Y/n/?]

dpkg -l *evolution* | grep ii
ii evolution 3.19.90-0ubuntu1~xenial2 amd64 groupware suite with mail client and organizer
ii evolution-common 3.19.90-0ubuntu1~xenial2 all architecture independent files for Evolution
ii evolution-data-server 3.19.90-0ubuntu1~xenial1 amd64 evolution database backend server
ii evolution-data-server-common 3.19.90-0ubuntu1~xenial1 all architecture independent files for Evolution Data Server
ii evolution-data-server-online-accounts 3.19.90-0ubuntu1~xenial1 amd64 evolution data server integration with Ubuntu Online Accounts
ii evolution-plugins 3.19.90-0ubuntu1~xenial2 amd64 standard plugins for Evolution

Axel Pospischil (apos) wrote :

Addendum:

[4] DISABLE THE GNOME3-STAGING ppa so that your freshly installed 16.04 would not be messed up:

... by uncommenting the sources.list entry in
/etc/apt/sources.list.d/
gnome3-team-ubuntu-gnome3-staging-xenial.list

And do an:
> apt-get update

[5] after test you could purge the ppa with

ppa-purge ppa:gnome3-team/gnome3-staging

Paul White (paulw2u) wrote :

Upstream report is a duplicate of #749974
which is showing "RESOLVED FIXED" on 2015-09-21
Tested ok in Ubuntu 18.04
So fixed in recent Ubuntu versions

Changed in evolution (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.