evolution crashes after trying to send email when composer preferences 'format messages in HTML' is checked

Bug #1506124 reported by gonzo22412 on 2015-10-14
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
evolution (Ubuntu)
Medium
Unassigned

Bug Description

1.) Description: Ubuntu Wily Werewolf (development branch)
Release: 15.10

2.) Evolution:
  Installed: 3.16.5-1ubuntu

3.) I expected to be able to send an HTML formated email.

4.) When I hit the send button after filling out the email the application locked up for roughly 20 seconds then crashed. This behavior happens every time when the 'format messages in HTML' box is check in Composer Preferences. If I uncheck this box I'm able to send mail normally. I'm also able to send email if I manually switch to HTML.

Extra Notes:
evolution crashed with signal 5 in g_object_new_valist()

ProblemType: Crash
DistroRelease: Ubuntu 15.10
Package: evolution 3.16.5-1ubuntu1
ProcVersionSignature: Ubuntu 4.2.0-16.19-generic 4.2.3
Uname: Linux 4.2.0-16-generic x86_64
ApportVersion: 2.19.1-0ubuntu2
Architecture: amd64
CrashCounter: 1
CurrentDesktop: Unity
Date: Wed Oct 14 10:27:34 2015
ExecutablePath: /usr/bin/evolution
InstallationDate: Installed on 2015-10-08 (5 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Alpha amd64 (20150924)
ProcCmdline: evolution
ProcEnviron:
 PATH=(custom, user)
 SHELL=/bin/bash
 LANG=en_US.UTF-8
 LANGUAGE=en_US
 XDG_RUNTIME_DIR=<set>
Signal: 5
SourcePackage: evolution
StacktraceTop:
 ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_object_new_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_object_new () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 e_util_ref_settings () from /usr/lib/evolution/libevolution-util.so.0
Title: evolution crashed with signal 5 in g_object_new_valist()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

gonzo22412 (jeanpaul-jarboe) wrote :

StacktraceTop:
 g_settings_set_property (object=0x56443c13f300, prop_id=<optimized out>, value=<optimized out>, pspec=<optimized out>) at /build/glib2.0-3UmwzF/glib2.0-2.46.0/./gio/gsettings.c:590
 object_set_property (nqueue=0x7f46e00032c0, value=<optimized out>, pspec=0x564436a33300, object=0x56443c13f300) at /build/glib2.0-3UmwzF/glib2.0-2.46.0/./gobject/gobject.c:1420
 g_object_new_internal (class=class@entry=0x564436a28370, params=params@entry=0x7ffdc875af90, n_params=n_params@entry=1) at /build/glib2.0-3UmwzF/glib2.0-2.46.0/./gobject/gobject.c:1813
 g_object_new_valist (object_type=object_type@entry=94850974406544, first_property_name=first_property_name@entry=0x7f478d16f877 "schema-id", var_args=var_args@entry=0x7ffdc875b0e0) at /build/glib2.0-3UmwzF/glib2.0-2.46.0/./gobject/gobject.c:2038
 g_object_new (object_type=94850974406544, first_property_name=first_property_name@entry=0x7f478d16f877 "schema-id") at /build/glib2.0-3UmwzF/glib2.0-2.46.0/./gobject/gobject.c:1622

Changed in evolution (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in evolution (Ubuntu):
status: New → Confirmed
information type: Private → Public
Changed in evolution (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evolution - 3.16.5-1ubuntu3

---------------
evolution (3.16.5-1ubuntu3) wily; urgency=medium

  * debian/patches/git_invalid_settings.patch:
    - fix argument order issue which leads to a segfault when sending
      html formatted emails, thanks Denis Gorodnichev (lp: #1506124)

 -- Sebastien Bacher <email address hidden> Mon, 19 Oct 2015 17:31:34 +0200

Changed in evolution (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers