evolution crashed with SIGSEGV in camel_object_cast()

Bug #145458 reported by Patrick Valencia on 2007-09-27
26
Affects Status Importance Assigned to Milestone
Evolution
Fix Released
Critical
Nominated for Head by chantra
evolution (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: evolution

Using Evolution 2.12, whenever I try to download messages for offline use (when using Exchange mode), program crashes. Also, when trying to edit files in offline mode, upon re-connecting, none of my changes are loaded onto the server.

ProblemType: Crash
Architecture: i386
CrashCounter: 1
Date: Thu Sep 27 00:27:06 2007
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/evolution
NonfreeKernelModules: nvidia
Package: evolution 2.12.0-0ubuntu1
PackageArchitecture: i386
ProcCmdline: evolution
ProcCwd: /home/pvalencia
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: evolution
StacktraceTop:
 camel_object_cast () from /usr/lib/libcamel-1.2.so.10
 camel_disco_store_prepare_for_offline ()
 ?? ()
 ?? ()
Title: evolution crashed with SIGSEGV in camel_object_cast()
Uname: Linux PatsUbuntuLaptop 2.6.22-12-generic #1 SMP Sun Sep 23 18:11:30 GMT 2007 i686 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin netdev plugdev powerdev scanner video

Related branches

Patrick Valencia (pvalencia357) wrote :
Patrick Valencia (pvalencia357) wrote :

Also, when I delete something locally, the server keeps a copy of it, and the local machine refuses to download the message. This causes the messages on the server to build up and require me to log on to delete them. This goes against the purpose of having a mail client edit messages on my computer.

StacktraceTop:camel_disco_store_prepare_for_offline (disco_store=0x0, ex=0x867862c) at camel-disco-store.c:415
prepare_offline_do (mm=0x8678610) at mail-ops.c:2371
mail_msg_received (e=0x81c9e00, msg=0x8678610, data=0x0) at mail-mt.c:582
thread_dispatch (din=0x81c9e00) at e-msgport.c:1005
start_thread () from /lib/tls/i686/cmov/libpthread.so.0

Changed in evolution:
importance: Undecided → Medium
Sebastien Bacher (seb128) wrote :

Thank you for your bug. The crash looks similar to http://bugzilla.gnome.org/show_bug.cgi?id=474118

Changed in evolution:
assignee: nobody → desktop-bugs
status: New → Triaged
Changed in evolution:
status: Unknown → New
Patrick Valencia (pvalencia357) wrote :

I believe it is, I'll subscribe to that one too. Thanks.

Changed in evolution:
status: New → Confirmed
chantra (chantra) wrote :

FYI, patches have been released upstream: http://bugzilla.gnome.org/show_bug.cgi?id=474118#c9

 Comment #9 from Bharath Acharya (points: 4)
2007-11-02 06:01 UTC [reply]

Created an attachment (id=98357) [edit]
Patch for bug 474118 in evolution

The crash happened due to assumption of the store being of type DiscoStore.
Thanks to mbarnes for explaining it in detail. attaching the changes to be done
in evolution

Comment #10 from Bharath Acharya (points: 4)
2007-11-02 06:02 UTC [reply]

Created an attachment (id=98358) [edit]
Patch for bug 474118 in evolution-data-server

Changes in eds for the same

Could those being merged? cheers

chantra (chantra) wrote :

I merged patches from http://bugzilla.gnome.org/show_bug.cgi?id=474118#c9
to evolution and evolution-data-server.
evolution-data-server_dl_offline.debdiff and evolution_dl_offline.debdiff

chantra (chantra) wrote :

so far it works :D

LaserJock (laserjock) wrote :

It appears, from the gnome bug report, that perhaps this bug only effects users who are using the Exchange backend. I'm unable to reproduce this bug with a non-Exchange IMAP account.

Changed in evolution:
status: Confirmed → Fix Released
Pedro Villavicencio (pedro) wrote :

The bug has been fixed upstream, thanks you.

Changed in evolution:
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (3.5 KiB)

This bug was fixed in the package evolution - 2.21.5-0ubuntu1

---------------
evolution (2.21.5-0ubuntu1) hardy; urgency=low

  * New upstream version:
    New in 2.21.5:
    Mail errors are now non-intrusive
    RTL fixes - Mail and Addressbook
    Bug fixes:
    - #211353: Allow categories to be assigned to emails
    - #219197: Quit application when session dies
    - #270605: Skip disabled accounts.
    - #300336: Added checkbox for "Enable Search Folders" option
    - #300336: Ensure vfolder is running.
    - #309432: Fix message headers for RTL languages.
    - #317823: Bump GtkHTML requirement to 3.17.5
    - #317823: Save inline pictures embedded into HTML Mails
    - #327965: Fixed multiple password prompts in an exchange account
    - #329692: Get the content size of the MIME part
    - #333695: Print attenddes/roles in the print view
    - #339813: Setting new option
               'e_date_edit_set_twodigit_year_can_future' to FALSE (LP: #48679)
    - #348638: Remove pre-edit buffer cleanly in day view
    - #350932: Enable the use of scrollable tabs in the mail-preferences dialog.
    - #362638: Overhaul the message passing API
    - #364642: New option in Composer tab to preset Request
               Read Receipt in composer (LP: #67683)
    - #375580: Use ISO-8859-1 encoding to store contacts in iPod
    - #448441: Disable "OK" and "Edit Full" buttons if no source is selected.
               Also set always book from combo, do not use the new created
    - #457842: Do not call edit/start editing of the event when double clicked
               on the same component as is actually editing
    - #474118: Check for the right type of store
               and invoke appropriate functions (LP: #145458)
    - #476264: Add mnemonic_widget for default junk plugin
    - #488213: Fix locks when displaying e-mail with large tiff drawing attached
    - #492188: Use the new Tangoized icons
               instead of deprecated icons from gnome-icon-theme.
    - #492702: Just disable the dbus message part of mail notification if dbus
               isn't there. Also remove new-mail-notify plugin
    - #496301: Clean up the schema
    - #496402: Do not synchronize blocked bodies from pidgin
    - #497914: backport changes from the copy/pasted code in imap-headers plugin
    - #498095: Fix mnemonic issues
    - #499145: Follow RFC 3798 to send return receipts.
    - #502303: Plugins configure widgets are not freed correctly
               in plugin-mamager
    - #502783: Restore message states
    - #502914: Do not write NULL into gconf
    - #503954: Accept custom domain names while setting up account (LP: #179512)
    - #504480: Increases the height of the ETaskBar to eliminate
               the constant resizing
    - #504541: Add --with[out]-help option to make it possible to skip building
               and installing user documentation
    - #506772: Not-NULL check for a string array before finding its length
    - #506814: Add the signal only if the view is present (LP: #173485)
    - #507067: Can't save pictures embedded in HTML Mail when picture = link
    - #507311: Submit bugs to the "BugBuddyBugs" Bugzilla component
    - #507363: Al...

Read more...

Changed in evolution:
status: Fix Committed → Fix Released
Changed in evolution:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.