Evolution : On startup unable to connect to POP server

Bug #140460 reported by Stéphane Marguet on 2007-09-17
84
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evolution
Expired
Medium
evolution (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: evolution

When starting evolution, pop-ups windows appears : Unable to connect to POP server.
If I click Cancel on all of them (for each accounts on different pop3 servers) and then click on Send / Receive there is no problems.

evolution : Version : 2.11.92-0ubuntu1

Workaround:
Backup your data first! This workaround should not harm your data but with an backup you are on the save side.
Open Evolution. Move all your mails from the inbox to another folder. Then close Evolution. Goto ~/.evolution/mail/local/ and remove all files beginning with Inbox (in my case there were six files). Now you can start Evolution again and move the mails back to the inbox.

Sebastien Bacher (seb128) wrote :

Thank you for your bug. Is that a new issue? When did it started? Do you have any error if you run evolution from a command line?

Changed in evolution:
assignee: nobody → desktop-bugs
importance: Undecided → Low
Stéphane Marguet (stemp) wrote :

It 's not a really new issue, it started more than one week ago but I forgot to report it.
Here is the result from a command line :

stemp@caderousse:~$ LANG=C evolution
CalDAV Eplugin starting up ...
Loading Bogofilter as the default junk plugin
** (evolution:8275): DEBUG: mailto URL command: evolution %s
** (evolution:8275): DEBUG: mailto URL program: evolution
/bin/sh: /usr/bin/esd: not found

(evolution:8275): camel-CRITICAL **: camel_store_get_folder: assertion `folder_name != NULL' failed

(evolution:8275): camel-CRITICAL **: camel_object_is: assertion `o != NULL' failed

(evolution:8275): evolution-mail-CRITICAL **: mail_tools_folder_to_url: assertion `CAMEL_IS_FOLDER (folder)' failed

(evolution:8275): camel-CRITICAL **: camel_store_get_folder: assertion `folder_name != NULL' failed

(evolution:8275): camel-CRITICAL **: camel_object_is: assertion `o != NULL' failed

(evolution:8275): evolution-mail-CRITICAL **: mail_tools_folder_to_url: assertion `CAMEL_IS_FOLDER (folder)' failed

Stéphane Marguet (stemp) wrote :

This bug appear when I'm on the Inbox folder !
If before quitting I choose another folder, evrything work fine on next startup.

8200 (8200) wrote :

I can confirm that the bug is only when you exit evolution being in the inbox folder and on the next start "Password...." (the bug) appears.

Changed in evolution:
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Could anybody describe easy steps to trigger the bug?

WartHog (tomus-suddenlink) wrote :

I have the bug also, and everything written about it above me is true here also.

WartHog (tomus-suddenlink) wrote :

Forgot to include:
Gutsy as of Oct 4th, Evolution 2.12.0

Sebastien Bacher (seb128) wrote :
Changed in evolution:
status: Confirmed → Triaged
Changed in evolution:
status: Unknown → New

I also have this problem, and nothing seems to be being done at gnome!

lilbudda (cory-meisch-gmail) wrote :

Issue for me as well. Always causes my Exchange backend to crash. Please bump priority.

landoncz (landoncz) wrote :

I have this issue as well. Everything about it described above is true for me as well. Using evolution 2.12.0 on Ubuntu Gusty.

Tien Nguyen (tienhn) wrote :

Don't you think that version 7.10 will be released on Oct-18-2007 is a bit "unmature"?
This is a big bug on the supported software.

Cheers,

pjvolders (pjvolders-gmail) wrote :

I confirm the same bug, the bug does not occur when starting evolution with:
$ evolution --disable-eplugin
and
$ evolution --component=calendar
So I use the last option as a temporary solution , I'm not sure if this helps anybody...
Note that even with "--component=calendar" your mail is being checked on startup!

cheers,
PJ
ps: first post on lauchpad :-)

Tien Nguyen (tienhn) wrote :

I checked out a few more command line options and I found that if I use:
evolution --offline

Then I won't get the POP error message pop up on start up. But the nice thing (may be not by design) is evolution will start as on-line mode anyway and I still be able to get mail later just not at the start up.

Cheers,

Since upgrading to Ubuntu 7.10, Evolution (now 2.12.0) gives a POP password error if it is started in the Inbox. It asks for the POP password, doesn't accept it but works fine if I cancel the error message! It works fine if Evolution starts in another folder.
It also doesn't remember my default account selection.

I've just used my system on a network configured manually, *without* Network-Manager and note that the symptom of repeated asking for password didn't occur.

Could others in this bug check whether they are using network manager and whether *not* using it alleviates the symptom? (I have seen it suggested in a forum post that the problem may be linked with the use of Network-Manager, my single experience appears to confirm this as a possibility.)

As per Neil's disabling of Network Manager, when I disable it the
symptoms also disappear. The only problem is that so does the
Send/Receive button - it greys out. It appears as though disabling
Network Manager also disables Evolution's communications hence no POP
error because it doesn't try.
--
Paul Hambleton
<email address hidden>

Just to clarify my previous post;

I'm away from any network that I have access to, so turned off network manager (using the gui) and then used a dialup modem via GnomePPP to get on to the net.

Under these conditions Evolution seems inclined to start in offline mode. When put online it contacts the mailserver and then asks for password. Under these conditions it asks only once and then works as normal.

What I did is to start evolution with --offline option and that stops
the dialog from popping up.

Cheers,

On Mon, 2007-10-22 at 14:01 +0000, Neil Woolford wrote:

> Just to clarify my previous post;
>
> I'm away from any network that I have access to, so turned off network
> manager (using the gui) and then used a dialup modem via GnomePPP to get
> on to the net.
>
> Under these conditions Evolution seems inclined to start in offline
> mode. When put online it contacts the mailserver and then asks for
> password. Under these conditions it asks only once and then works as
> normal.
>

David Keegel (david-keegel) wrote :

Thanks for the suggestion about being in a non-Inbox folder when you quit evolution.
If my evolution starts in Inbox, I get a popup evolution error:
    Error while Updating Search Folders for '[my account]/Deleted Items'
    Failed sending command to IMAP server [server]: Interrupted system call
    Ok
and evolution does not show how many unread emails are in other folders.

If I start evolution after quitting while in a folder other than Inbox, I don't get the error, and can see
the number of unread emails in my other folders.

I was also getting messages like these in the tty where I launched evolution:
   (evolution:13103): camel-CRITICAL **: camel_store_get_folder: assertion `folder_name != NULL' failed
   (evolution:13103): camel-CRITICAL **: camel_object_is: assertion `o != NULL' failed

Those messages seem to have stopped since I moved most of the old emails from my Inbox into another folder.
But those assertion failure messages are how I found this topic (through google).

My environment is quite different from previous posters -
  Fedora Core 6
  Evolution 2.8.3
  Using IMAP and Scalix accounts (not using any POP3 accounts)

Fabus (fabian-gebert-hh) wrote :

So is there a fix now or what will actually happen about this? It's still present in the final!

Changed in evolution:
status: New → Confirmed

I've now had another look at the possible interaction with Network-Manager.

Basically I removed Network-Manager from my system and manually configured the (wireless ethernet) connection to the internet.

The symptom of asking for for the password and then looping continued to exist. So it looks like Network-Manager is not the culprit.

Using the PPP connection (set up through GnomePPP) and a modem card continues to work properly; Evolution then starts offline; when put online by clicking the connect button it connects and just asks for the password once, going on to work normally.

As others have observed, starting Evolution in a terminal with the --offline option also works. (Although I notice that the camel error messages still appear in the console).

For me what happens here is that when using the --offline switch Evolution still appears to start in online mode; I guess that this means it is detecting the network connection and switching itself to online immediately. Anyway, the password behaviour is then normal, which is at least a fix of the symptom.

I can also confirm that shutting down Evolution in folders other than inbox leads to a clean start.

As a temporary fix of the symptom I've added the --offline switch after --component=mail in the Gnome Panel launcher for Evolution. This seems to work ok for now.

(I also notice that if running in conditions where the password dialogue loops, cancelling the first dialogue before entering a password leads to normal correct operation if mail pickup is initiated manually.)

WartHog (tomus-suddenlink) wrote :

Didn't think to mention I am on an always on cable internet connection.
I have two accounts, (from different servers), that Evolution checks for mail.
When the dialog comes up when starting, I hit cancel. Then, sometimes, but not all the times, since Evolution now has another server to check for mail, I get the message again. Again hitting cancel, and then I will be good to go once I select send/receive.

It is odd that sometimes Evolution only gives me one dialog to cancel, but other times it does it twice, hence, one time for every mail server it needs to access.

rod singleton (rod40cool) wrote :

I too am getting this bug which I logged as bug # 158693 then I found this bug on the forum so so marked mine as a duplicate of this.

Apart from exiting Evolution in a folder other than InBox, I also found that by unticking the check box to automatically check email every xx minutes in the pop3 account preferences and just using the Send/Receive button manually Evolution starts without prompting for a password and send/receive works fine as some of you have mentioned.

rod singleton (rod40cool) wrote :

Woops, the bug I originally logged was bug # 158963

jerryf70 (jfrost1) wrote :

Hiya, same issue here. Occurred after upgrade from Feisty to Gutsy. One thing I've noticed which I've not seen mentioned in previous posts is that this is occurring for only one of the three user logins on my machine. Hope that helps.

Blu (blutack) wrote :

I have one IMAP4 account and two POP3 accounts. If I exit evolution with the "On This Computer" inbox selected it works fine on startup. The dialog boxes only appear if I leave it on the IMAP account inbox.

TimMadden (timmadden) wrote :

I have this nuisance bug as well... Behavior same as above. On Gutsy, but I seem to recall that it happened on Feisty too. Just was never annoying enough to look for a solution.

Never had it on Feisty. Only surfaced on Gutsy for me.
--
Paul H.

Carles Oriol (carlesoriol) wrote :

I had it on Feisty too.

Carles Oriol (carlesoriol) wrote :

I don't know if it could help but I'm connecting by POP to a windows Mdaemon server 8.0.

In my configuration I've set to keep a copy of the mail at the server for 30 days.

I've tried diferent pop validation methods and I get the same error in all them.

I have just applied latest Ubuntu Gutsy updates which include taking Evolotion from version 12.2.0 to 12.2.1 and I still have the same problem. No joy there.

cmnorton (octopusgrabbus) wrote :

I have experienced this on 7.10, but after some recent upgrade in the last few weeks. This did not start happening when I upgraded to Gutsy.

Stéphane Marguet (stemp) wrote :

Tried version 2.21.3 from Tobias Wolf (towolf) PPA.
Same problem.

Aldo Latino (aldolat) wrote :

I confirm this annoying bug: Evolution can't connect to POP3 if it starts up in Inbox folder. All go OK if Evolution starts up in another folder.

Ubuntu 7.10, Italian language, Evolution 2.12.1

Yepp, I confirm:
When starting in any other folder than inbox, evo works correctly!
But when in inbox, this very annoying bug happens.

Am Mittwoch, den 19.12.2007, 10:16 +0000 schrieb Aldo Latino:
> I confirm this annoying bug: Evolution can't connect to POP3 if it
> starts up in Inbox folder. All go OK if Evolution starts up in another
> folder.
>
> Ubuntu 7.10, Italian language, Evolution 2.12.1
>
--
Mit freundlichen Grüßen

Jochen Jansen

*Linux: It's free!*

Benjamin Drung (bdrung) wrote :

I have a workaround:

Move all your mails from the inbox to another folder. Then close Evolution. Goto ~/.evolution/mail/local/ and remove all files beginning with Inbox (in my case there were six files). Now you can start Evolution again and move the mails back to the inbox. The bug disappeared.

Jochen Jansen (jochen-jansen) wrote :

Yes,
I can confirm that! Weird, but this works.
Thank you, this bug was really annoying.

Am Freitag, den 04.01.2008, 01:32 +0000 schrieb Benjamin Drung:
> I have a workaround:
>
> Move all your mails from the inbox to another folder. Then close
> Evolution. Goto ~/.evolution/mail/local/ and remove all files beginning
> with Inbox (in my case there were six files). Now you can start
> Evolution again and move the mails back to the inbox. The bug
> disappeared.
>
--
Mit freundlichen Grüßen

Jochen Jansen

*Linux: It's free!*

Aldo Latino (aldolat) wrote :

Yeah! I confirm that this workaround works very well!

> I have a workaround:
>
> Move all your mails from the inbox to another folder. Then close
> Evolution. Goto ~/.evolution/mail/local/ and remove all files beginning
> with Inbox (in my case there were six files). Now you can start
> Evolution again and move the mails back to the inbox. The bug
> disappeared.

I haven't done anything and the fault has gone away! The version is
still 2.12.1 which had the problem up until yesterday but now each time
I start Evolution it just works.
What happened?
On Fri, 2008-01-04 at 11:57 +0000, Jochen Jansen wrote:
> Yes,
> I can confirm that! Weird, but this works.
> Thank you, this bug was really annoying.
>
> Am Freitag, den 04.01.2008, 01:32 +0000 schrieb Benjamin Drung:
> > I have a workaround:
> >
> > Move all your mails from the inbox to another folder. Then close
> > Evolution. Goto ~/.evolution/mail/local/ and remove all files beginning
> > with Inbox (in my case there were six files). Now you can start
> > Evolution again and move the mails back to the inbox. The bug
> > disappeared.
> >
> --
> Mit freundlichen Grüßen
>
> Jochen Jansen
>
> *Linux: It's free!*
>
--
Paul Hambleton
<email address hidden>

WartHog (tomus-suddenlink) wrote :

I can confirm this "fix" worked!

Benjamin Drung (bdrung) wrote :

I think we can close this bugreport.

Benjamin Drung (bdrung) wrote :

Move all your mails from the inbox to another folder. Then close Evolution. Goto ~/.evolution/mail/local/ and remove all files beginning with Inbox (in my case there were six files). Now you can start Evolution again and move the mails back to the inbox. The bug disappeared.

Changed in evolution:
status: Triaged → Fix Released

Are we sure that moving the emails is necessary. I haven't done anything
at all and the problem disappeared for me at the same time everyone else
started announcing the fix. Maybe one of the non-Evolution Ubuntu
updates fixed it.
Can anyone enlighten us further?
On Mon, 2008-01-07 at 11:58 +0000, Benjamin Drung wrote:
> Move all your mails from the inbox to another folder. Then close
> Evolution. Goto ~/.evolution/mail/local/ and remove all files beginning
> with Inbox (in my case there were six files). Now you can start
> Evolution again and move the mails back to the inbox. The bug
> disappeared.
>
> ** Changed in: evolution (Ubuntu)
> Status: Triaged => Fix Released
>
--
Paul Hambleton
<email address hidden>

I was fully updated with Ubuntu, and still had the problem.
I moved the files back in and out as instructed, and the problem was
resolved.

On Tue, 2008-01-08 at 09:21 +0000, Paul Hambleton wrote:
> Are we sure that moving the emails is necessary. I haven't done anything
> at all and the problem disappeared for me at the same time everyone else
> started announcing the fix. Maybe one of the non-Evolution Ubuntu
> updates fixed it.
> Can anyone enlighten us further?
> On Mon, 2008-01-07 at 11:58 +0000, Benjamin Drung wrote:
> > Move all your mails from the inbox to another folder. Then close
> > Evolution. Goto ~/.evolution/mail/local/ and remove all files beginning
> > with Inbox (in my case there were six files). Now you can start
> > Evolution again and move the mails back to the inbox. The bug
> > disappeared.
> >
> > ** Changed in: evolution (Ubuntu)
> > Status: Triaged => Fix Released
> >
> --
> Paul Hambleton
> <email address hidden>
>

Paul Darby (paul-darby) wrote :

Thanks to Benjamin Drung for the workaround !

It worked fine for me : that damned annoying thing I've had for maybe 4 months has at last gone away !

In response to Paul Hambleton's question, at least one member of the French Ubuntu forum has lost all his incoming mail because he did not remove them from the Inbox ! Post N° 8 for those who read French : http://forum.ubuntu-fr.org/viewtopic.php?pid=1454647#p1454647

To avoid this, I have come up with a ...

French Translation :

Déplacez tous vos mails de votre Boîte de réception vers un autre dossier.** Fermez Evolution. Allez à ~/.evolution/mail/local/ et supprimez tous les fichiers qui commencent par Inbox (six fichiers dans mon cas). Vous pouvez redémarrer Evolution et remettre vos mails dans votre Boite de réception. Le bogue (bug) a disparu.

** NdT : Par exemple Brouillons.

En effet ça marche ... et à condition de déplacer ses mails ailleurs, sans perte !

Thanks to Benjamin Drung! The workaround worked fine for me too (after several months)

Just another happy Evolution (bug fixed) user acknowledging the help and BEAUTY of Open Source!

Thank you Benjamin.

stefangachter (stefan-gachter) wrote :

I had to do the same procedure for Inbox and Outobx to make evolution mail work properly again. Evolution refused to send the emails and asked repetitively for the password. Entering the correct password had no effect however. So, I deleted the Outbox files and after entering once more the password, it worked again.

Is this really the beauty of Open Source? Then, I have a slightly different aesthetic sense...

Jim Devereaux (jdever94671) wrote :

I am having the same problem. I always get the error msg "unable to connect to POP server pop.embarqmail.com.
I am then asked for my password and it always comes back Please enter password for my email. However it will not accept it. I can close the window and go to send/receive and the new email will always be delivered.

Rubeosis (faspie) wrote :

I can confirm this bug.

On http://forum.ubuntuusers.de/topic/159154/?p=1354627#1354627 I could find a possibility to stop that annoying error messages:

First save your old emails.
Then go to the evolution folder and delete all files called "inbox*".
Afterwards move your emails back to the newly created inbox .

Perhaps this solution can help to find the problem.

Adina (a-doell) wrote :

Hallo, reply to Rubeosis 2008-04-21.
I have the same problem, since some month.
What do you mean with "delete all files called inbox"? It is not possible to delete the inbox. Messages deleting of course, but deleting the file inbox file is deactivated.
Thanks!

Benjamin Drung (bdrung) on 2008-09-15
description: updated
Benjamin Drung (bdrung) wrote :

Adina, have a look at the bug description. I have added the workaround to it. Rubeosis describes the same workaround (I have posted my workaround on this bug and on ubuntuusers.de and Rubeosis points to this thread).
"delete all files called inbox" means to delete these files in the file system (not in Evolution).

MiguelETorres (migueletorres) wrote :

Just to inform you that this fix DID NOT work for me.

Liviu Beraru (beraru-liviu) wrote :

Intrepid, latest updates.
I had the same problem with a Google account: Evolution asking me for user name and password at every start up.
I found that I had to unlock captcha for my account here:
https://www.google.com/accounts/DisplayUnlockCaptcha
So in my case there was no problem with Evolution, just with google servers.
I hope this helps somebody.

Trond Husoe (tr-huso) wrote :

I have removed all the Inbox-files but I am getting error messages when starting Evolution.
I also tend to get the storing inbox problem as well.

I have attached a log-file

Changed in evolution (Ubuntu):
status: Fix Released → Triaged
Photon (michael-kogan) wrote :

Still an issue in Lucid! Will try the proposed workaround and report.

Photon (michael-kogan) wrote :

Workaround tested and it worked for me. Still the bug should be fixed since the workaround is a bit hackish...

Changed in evolution:
importance: Unknown → Medium
Changed in evolution:
status: Confirmed → Incomplete
Pedro Villavicencio (pedro) wrote :

Could somebody please try to reproduce this on Oneiric? Thanks.

Changed in evolution (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Triaged → Incomplete
Changed in evolution:
status: Incomplete → Expired
Jörg Frings-Fürst (jff-de) wrote :

change status to Invalid (see gnome-bugs)

Changed in evolution (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.