unable to filter with 'date received before 1 month ago'

Bug #129138 reported by Jerome Haltom on 2007-07-29
4
Affects Status Importance Assigned to Milestone
Evolution
Fix Released
High
evolution (Ubuntu)
High
Ubuntu Desktop Bugs

Bug Description

Binary package hint: evolution

Error while Filtering Selected Messages.

Error executing filter search: Unexpected token encountered: 45: (and

       (match-all (< (get-received-date) (- (get-current-date) 7257600)))

  )

This happens when I have a filter that moves items that have Date Received before 1 month ago. These filters worked a week ago, and no longer work. Probably a recent regression of some sort.

ProblemType: Bug
Architecture: i386
Date: Sun Jul 29 17:08:22 2007
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/evolution
Package: evolution 2.11.5-Oubuntu1
PackageArchitecture: i386
ProcCmdline: evolution --component=mail
ProcCwd: /home/wasabi
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games
 LANG=en_US.UTF-8
SourcePackage: evolution
Uname: Linux kyoto 2.6.22-8-generic #1 SMP Thu Jul 12 15:59:45 GMT 2007 i686 GNU/Linux

Jerome Haltom (wasabi) wrote :
Jerome Haltom (wasabi) wrote :

Marking this critical because it makes a widely used function that worked fine no longer work fine. Releasing Evolution with this bug, at least in my opinion, would not be acceptable.

Changed in evolution:
importance: Undecided → Critical
William Grant (wgrant) on 2007-07-30
Changed in evolution:
importance: Critical → High
Jerome Haltom (wasabi) wrote :

Upstream claims the bug is fixed in the development version. Might be worth backporting.

http://bugzilla.gnome.org/show_bug.cgi?id=457523

Sebastien Bacher (seb128) wrote :

We will not start backporting SVN changes the day of a new tarball, maybe you should use a stable distribution if you can't handle some breakages on the way

Changed in evolution:
assignee: nobody → desktop-bugs
status: New → Fix Committed
Changed in evolution:
status: Unknown → Fix Released
Pedro Villavicencio (pedro) wrote :

Thanks for your report, this is fixed in evolution-data-server 1.11.6 which is already in gutsy since the 31 of July.

Changed in evolution:
status: Fix Committed → Fix Released
Changed in evolution:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.