unable to start evolution as user

Bug #125653 reported by Mathias Uebelacker on 2007-07-12
2
Affects Status Importance Assigned to Milestone
evolution (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Ubuntu 7.04 with the latest updates on a laptop
evolution-2.10

Description
If i try to start evolution as user mathias i get the following error:

mathias@mathias-laptop:~$ evolution-2.10
CalDAV Eplugin starting up ...
Segmentation fault (core dumped)
mathias@mathias-laptop:~$

If i start evolution as user root it works fine.

I've tried to fix the problem with the assistance of the community see question #9472

Here is the copy of the /var/crash/_usr_bin_evolution-2.10.1000.crash:

ProblemType: Crash
Architecture: i386
CrashCounter: 1
Date: Thu Jul 12 22:27:54 2007
DistroRelease: Ubuntu 7.04
ExecutablePath: /usr/bin/evolution-2.10
ProcCmdline: evolution-2.10
ProcCwd: /home/mathias
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 LANGUAGE=en_US:en
Signal: 11
Uname: Linux mathias-laptop 2.6.20-16-generic #2 SMP Thu Jun 7 20:19:32 UTC 2007 i686 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin netdev plugdev powerdev scanner video
CoreDump: base64

C de-Avillez (hggdh2) wrote :

Thank you for your bug report.

Please *never* inline a /var/crash in the bug description. If you want to add it in, please do so as an attachment. The sheer size of a coredump makes it almost impossible to work on the bug.

description: updated
Changed in evolution:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Incomplete
C de-Avillez (hggdh2) wrote :

Please try to obtain a backtrace following the instructions at [WWW] http://wiki.ubuntu.com/DebuggingProgramCrash and attach the file to the bug report. This will greatly help us in tracking down your problem.

ok these is the backtrace.

C de-Avillez (hggdh2) wrote :

Thank you. Unfortunately, the backtrace is unusable -- it does not show the functions.

Please follow the instructions steps 1 and 2 at https://wiki.ubuntu.com/DebuggingProgramCrash. Then run

    sudo apt-get install evolution-dbgsym evolution-data-server-dbgsym

(what I can get from the backtrace suggests the problem is related to libevolution-calendar).

Then rerun gdb. When you get hit by the error, issue:

    thread apply all bt

This gdb command will backtrace all threads. Then attach the gdb output here.

Please bear in mind that the above debugging packages are the minimum minimorum necessary for us to make some sense of the backtrace; we main need more dgbsym packages.

Hello,
here are the new file.

C de-Avillez (hggdh2) wrote :

Mathias, can you please run a 'ls -la' on ~/.evolution, and check if all files and directories are owner by yout user id?

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

hggdh wrote:
> Mathias, can you please run a 'ls -la' on ~/.evolution, and check if all
> files and directories are owner by yout user id?
>
Hello,

yes on all files and directories the owner is mathias

br
Mathias
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFGl7MEZapgManfRh0RAjoiAJoDVzGQPdN+gYAZyV3RWoAfZOTloQCcD7tY
sLHdF4weuhITGwlGl6kjSxU=
=mCZy
-----END PGP SIGNATURE-----

C de-Avillez (hggdh2) wrote :

Mathias, have you ever been able to run Evo as yourself, or only as root?

Hello,

i am not sure, ithink i had used evo one time as user. Today i created a new user and this new user can open evo. The user has the same right as my user account mathias.

C de-Avillez (hggdh2) wrote :

The only thing that comes to my mind right now is that something is hosed under the ~/.evolution directory. You can try two things:

1. rm -rf ~/.evolution/calendar (since it is the calendar init that is failing)

or

2. rm -rf ~.evolution (since this user has not really used Evo so far).

Then run Evo again. I would start with (1) above -- less drastic, and go to (2) if (1) did not do the trick.

Hello,

neither #1 nor #2 works i got the same error.

br
Mathias

C de-Avillez (hggdh2) wrote :

The only option I can see,then, is gconf got hosed for this user... researching.

C de-Avillez (hggdh2) wrote :

Mathias: is this system up-to-date in terms of patches?

i.e., have you run 'sudo apt-get update && apt-get dist-upgrade'?

Also, please run 'dpkg -l evolution\*', and paste the output here.

Sebastien Bacher (seb128) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and don't hesitate to submit bug reports in the future.

Changed in evolution:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions