package evolution failed to install/upgrade:

Bug #125429 reported by jtlb on 2007-07-12
60
Affects Status Importance Assigned to Milestone
evolution (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: evolution

in gutsy, lots upgrades are failing on each updtates

ProblemType: Package
Date: Thu Jul 12 09:13:24 2007
ErrorMessage:
 ErrorMessage: problèmes de dépendances - laissé non configuré
Package: evolution
SourcePackage: evolution

Sebastien Bacher (seb128) wrote :

Thank you for your bug. Could you run "sudo apt-get dist-upgrade" on a command line and copy the log?

Changed in evolution:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Incomplete
jtlb (jt-lb) wrote :
Download full text (6.8 KiB)

jtlb@jtlb-laptop:~/festival/kernel0.1a1/Sources$ sudo apt-get dist-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Reading state information... Fait
Calcul de la mise à jour... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
19 partiellement installés ou enlevés.
Il est nécessaire de prendre 0o dans les archives.
Après dépaquetage, 0o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
Paramétrage de openoffice.org-common (2.2.1-5ubuntu2) ...
Updating OpenOffice.org's dictionary list... done.
bad image index
The generated cache was invalid.
dpkg : erreur de traitement de openoffice.org-common (--configure) :
 le sous-processus post-installation script a retourné une erreur de sortie d'état 1
Paramétrage de apport (0.90) ...
 * Starting automatic crash report generation: apport [ OK ]
bad image index
The generated cache was invalid.
dpkg : erreur de traitement de apport (--configure) :
 le sous-processus post-installation script a retourné une erreur de sortie d'état 1
dpkg : des problèmes de dépendances empêchent la configuration de apport-gtk :
 apport-gtk dépend de apport (>= 0.41) ; cependant :
 Le paquet apport n'est pas encore configuré.
dpkg : erreur de traitement de apport-gtk (--configure) :
 problèmes de dépendances - laissé non configuré
Paramétrage de eog (2.19.4-0ubuntu1) ...
bad image index
The generated cache was invalid.
dpkg : erreur de traitement de eog (--configure) :
 le sous-processus post-installation script a retourné une erreur de sortie d'état 1
Paramétrage de evince (0.9.2-0ubuntu1) ...
bad image index
The generated cache was invalid.
dpkg : erreur de traitement de evince (--configure) :
 le sous-processus post-installation script a retourné une erreur de sortie d'état 1
Paramétrage de evolution-common (2.11.5-Oubuntu1) ...
bad image index
The generated cache was invalid.
dpkg : erreur de traitement de evolution-common (--configure) :
 le sous-processus post-installation script a retourné une erreur de sortie d'état 1
dpkg : des problèmes de dépendances empêchent la configuration de evolution :
 evolution dépend de evolution-common (= 2.11.5-Oubuntu1) ; cependant :
 Le paquet evolution-common n'est pas encore configuré.
dpkg : erreur de traitement de evolution (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de evolution-plugins :
 evolution-plugins dépend de evolution (>= 2.11.5) ; cependant :
 Le paquet evolution n'est pas encore configuré.
dpkg : erreur de traitement de evolution-plugins (--configure) :
 problèmes de dépendances - laissé non configuré
Paramétrage de gnome-panel-data (1:2.19.5-0ubuntu2) ...
bad image index
The generated cache was invalid.
dpkg : erreur de traitement de gnome-panel-data (--configure) :
 le sous-processus post-installation script a retourné une erreur de sortie d'état 1
dpkg : des problèmes de dépendances empêchent la configuration de gnome-panel :
 gnome-panel dépend de gnome-panel-data (>= 1:2.19) ; cependant :
 Le paquet gnome-panel-data n'est pas encore configuré.
 gnome-...

Read more...

Sebastien Bacher (seb128) wrote :

Could you run "sudo gtk-update-icon-cache --force --validate /usr/share/icons/hicolor" and copy the log to the bug?

jtlb (jt-lb) wrote :

jtlb@jtlb-laptop:~$ sudo gtk-update-icon-cache --force --validate /usr/share/icons/hicolor
bad image index
Not a valid icon cache: /usr/share/icons/hicolor/icon-theme.cache

jtlb (jt-lb) wrote :
Sebastien Bacher (seb128) wrote :

Does it work if you remove the broken cache and run the update?

jtlb (jt-lb) wrote :

i'm sorry but i'm not sure to understand what you mean?
removing the cache file or the entire hicolor folder?

C de-Avillez (hggdh2) wrote :

just the bad cache file, jean-Tiare.

jtlb (jt-lb) wrote :
Download full text (15.3 KiB)

sudo gtk-update-icon-cache --force --validate /usr/share/icons/hicolor failes of course
sudo aptitude update
sudo aptitude dist-upgrade definitively doesn't work:

jtlb@jtlb-laptop:~$ sudo aptitude dist-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Reading state information... Fait
Lecture de l'information d'état étendu
Initialisation de l'état des paquets... Fait
Construction de la base de données des étiquettes... Fait
Les paquets suivants seront mis à jour :
  compiz compiz-core compiz-gnome compiz-plugins libdecoration0
5 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 697ko d'archives. Après dépaquetage, 4096o seront utilisés.
Voulez-vous continuer ? [Y/n/?]
Écriture de l'information d'état étendu... Fait
Prendre :1 ftp://ftp.crihan.fr gutsy/main libdecoration0 1:0.5.1+git20070712-0ubuntu1 [45,5kB]
Prendre :2 ftp://ftp.crihan.fr gutsy/main compiz-gnome 1:0.5.1+git20070712-0ubuntu1 [164kB]
Prendre :3 ftp://ftp.crihan.fr gutsy/main compiz-plugins 1:0.5.1+git20070712-0ubuntu1 [275kB]
Prendre :4 ftp://ftp.crihan.fr gutsy/main compiz-core 1:0.5.1+git20070712-0ubuntu1 [184kB]
Prendre :5 ftp://ftp.crihan.fr gutsy/main compiz 1:0.5.1+git20070712-0ubuntu1 [28,9kB]
697ko téléchargés en 5s (118ko/s)
(Lecture de la base de données... 164086 fichiers et répertoires déjà installés.)
Préparation du remplacement de libdecoration0 1:0.5.1+git20070703-0ubuntu3 (en utilisant .../libdecoration0_1%3a0.5.1+git20070712-0ubuntu1_i386.deb) ...
Dépaquetage de la mise à jour de libdecoration0 ...
Préparation du remplacement de compiz-gnome 1:0.5.1+git20070703-0ubuntu3 (en utilisant .../compiz-gnome_1%3a0.5.1+git20070712-0ubuntu1_i386.deb) ...
Dépaquetage de la mise à jour de compiz-gnome ...
Préparation du remplacement de compiz-plugins 1:0.5.1+git20070703-0ubuntu3 (en utilisant .../compiz-plugins_1%3a0.5.1+git20070712-0ubuntu1_i386.deb) ...
Dépaquetage de la mise à jour de compiz-plugins ...
Préparation du remplacement de compiz-core 1:0.5.1+git20070703-0ubuntu3 (en utilisant .../compiz-core_1%3a0.5.1+git20070712-0ubuntu1_i386.deb) ...
Dépaquetage de la mise à jour de compiz-core ...
Préparation du remplacement de compiz 1:0.5.1+git20070703-0ubuntu3 (en utilisant .../compiz_1%3a0.5.1+git20070712-0ubuntu1_all.deb) ...
Dépaquetage de la mise à jour de compiz ...
Paramétrage de openoffice.org-common (2.2.1-5ubuntu2) ...
Updating OpenOffice.org's dictionary list... done.
bad image index
The generated cache was invalid.
dpkg : erreur de traitement de openoffice.org-common (--configure) :
 le sous-processus post-installation script a retourné une erreur de sortie d'état 1
Paramétrage de apport (0.90) ...
 * Starting automatic crash report generation: apport [ OK ]
bad image index
The generated cache was invalid.
dpkg : erreur de traitement de apport (--configure) :
 le sous-processus post-installation script a retourné une erreur de sortie d'état 1
dpkg : des problèmes de dépendances empêchent la configuration de apport-gtk :
 apport-gtk dépend de apport (>= 0.41) ; cependant :
 Le paquet apport n'est pas encore configuré....

C de-Avillez (hggdh2) wrote :

openoffice.common is broken. Please wait for the new package to arrive, and then try again.

jtlb (jt-lb) wrote :

i know, reported a duplicate, but the package hicolor-icon-theme is also broken on my computer, i'm reinstalling it
do you know when the fix for oppenoffice will be in the repos?

C de-Avillez (hggdh2) wrote :

a replacement oo has been made available. Does this error still occurs?

Dyno (dyno-fu) wrote :

donnot know the root cause but, follow the instruction here to remove all autopackage related icon solve the problem. http://forums.fedoraforum.org/forum/showthread.php?t=159111&highlight=bad+image+index

Sebastien Bacher (seb128) wrote :

Do you have any icon in /usr/share/icons/hicolor? Could you run "dpkg -S icon" to know what package provides it? Does removing it and trying to update the cache then?

sorry I don't have that file in /usr/share/icons or anything like that?

Regards

Sebastien Bacher wrote:
> Do you have any icon in /usr/share/icons/hicolor? Could you run "dpkg -S
> icon" to know what package provides it? Does removing it and trying to
> update the cache then?
>
>

macgee7 (e-lcollins) wrote :

I haven't got that file but here is the result of apt-get dist-upgrade log that generated after Iinstall anything as you can see it has save the pkgs but setup/install them

regards

dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of evolution-exchange:
 evolution-exchange depends on evolution (>= 2.11.5); however:
  Package evolution is not configured yet.
dpkg: error processing evolution-exchange (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of evolution-plugins:
 evolution-plugins depends on evolution (>= 2.11.5); however:
  Package evolution is not configured yet.
dpkg: error processing evolution-plugins (--configure):
 dependency problems - leaving unconfigured
Setting up synaptic (0.60ubuntu2) ...
bad image index
The generated cache was invalid.
dpkg: error processing synaptic (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of update-manager:
 update-manager depends on synaptic (>= 0.57.8); however:
  Package synaptic is not configured yet.
dpkg: error processing update-manager (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of update-notifier:
 update-notifier depends on update-manager; however:
  Package update-manager is not configured yet.
dpkg: error processing update-notifier (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ubuntu-desktop:
 ubuntu-desktop depends on eog; however:
  Package eog is not configured yet.
 ubuntu-desktop depends on evince; however:
  Package evince is not configured yet.
 ubuntu-desktop depends on synaptic; however:
  Package synaptic is not configured yet.
 ubuntu-desktop depends on update-notifier; however:
  Package update-notifier is not configured yet.
dpkg: error processing ubuntu-desktop (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 eog
 evince
 evolution-common
 evolution
 evolution-exchange
 evolution-plugins
 synaptic
 update-manager
 update-notifier
 ubuntu-desktop
E: Sub-process /usr/bin/dpkg returned an error code (1)

-- package evince failed to install/upgrade:
https://bugs.launchpad.net/bugs/125444 You received this bug
notification because you are a direct subscriber of the bug.

Sebastien Bacher wrote:
> Do you have any icon in /usr/share/icons/hicolor? Could you run "dpkg -S
> icon" to know what package provides it? Does removing it and trying to
> update the cache then?
>
>

Sebastien Bacher (seb128) wrote :

Could you attach what "ls /usr/share/icons/hicolor" to the bug lists to the bug?

Sebastien Bacher (seb128) wrote :

looks like you used so autopackage that broke your system. Can you run "dpkg -S /usr/share/icons/hicolor/autopackage-installer.png"? Does moving autopackage-installer.png somewhere else fix the issue?

macgee7 (e-lcollins) wrote :

Hi I cganged the icons name instead of moving it and the problem has
resolved itself
Many thanks for your time This is why I am a user of Ubuntu instead of
that ms crap , you give the time and service that ms well it has none

Once again thankyou
Earle

Sebastien Bacher wrote:
> looks like you used so autopackage that broke your system. Can you run
> "dpkg -S /usr/share/icons/hicolor/autopackage-installer.png"? Does
> moving autopackage-installer.png somewhere else fix the issue?
>
>

Sebastien Bacher (seb128) wrote :

likely due to an icon installed incorrectly to the theme directory, closing the bug, feel free to reopen if that's not the case and you still get the issue

Changed in evolution:
status: Incomplete → Invalid
Taufik (tfk252hasan) wrote :

I have this:

taufik@grtk:~$ sudo dpkg --configure -a
dpkg: dependency problems prevent configuration of evolution:
 evolution depends on libfreetype6 (>= 2.3.5); however:
  Package libfreetype6 is not installed.
dpkg: error processing evolution (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 evolution
taufik@grtk:~$ sudo apt-get install libfreetype6
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  evolution: Depends: evolution-common (= 2.12.0-0ubuntu1) but 2.11.92-0ubuntu1 is to be installed
  libc6-dev: Depends: libc6 (= 2.6.1-1ubuntu7) but 2.6.1-1ubuntu5 is to be installed
  libc6-i686: PreDepends: libc6 (= 2.6.1-1ubuntu4) but 2.6.1-1ubuntu5 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
taufik@grtk:~$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  evolution evolution-common libc6 libc6-dev libc6-i686 libfreetype6
Suggested packages:
  evolution-exchange evolution-dbg evolution-plugins-experimental glibc-doc
  manpages-dev libfreetype6-dev
Recommended packages:
  evolution-plugins
The following packages will be upgraded:
  evolution evolution-common libc6 libc6-dev libc6-i686 libfreetype6
6 upgraded, 0 newly installed, 0 to remove and 256 not upgraded.
3 not fully installed or removed.
Need to get 0B/50.0MB of archives.
After unpacking 721kB of additional disk space will be used.
Do you want to continue [Y/n]?
(Reading database ... 231912 files and directories currently installed.)
Preparing to replace libc6-dev 2.6.1-1ubuntu5 (using .../libc6-dev_2.6.1-1ubuntu7_i386.deb) ...
Segmentation fault (core dumped)
taufik@grtk:~$

ELCarrier (rrcandelc) wrote :

Being not computer savey I do not under stand what to do about not being able to download updates.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers