Ubuntu Online Accounts integration broken in Saucy

Bug #1210866 reported by Kelly Hyde on 2013-08-10
72
This bug affects 12 people
Affects Status Importance Assigned to Milestone
evolution (Ubuntu)
High
Unassigned

Bug Description

On Ubuntu 13.10 running Unity, integration with Ubuntu Online Accounts in Evolution is broken. On a fresh install, Evolution doesn't pick up on accounts in UOA at all because the package evolution-data-server-goa is required in addition to evolution-data-server-uoa, but evolution-data-server-goa is not installed by default in Ubuntu. The absence of evolution-data-server-goa also prevents the user from adding an account in Evolution's account setup manager with Google Calendar and Google Contacts support automatically (similar to Bug #1049028). Upon installing evolution-data-server-goa, Evolution picks up on UOA accounts, but demands reauthentication every time the user logs out and logs back in, breaking the accounts in UOA ("Applications are no longer able to use account...").

The temporary workaround is to install evolution-data-server-goa, uninstall evolution-data-server-uoa, and configure all Evolution accounts through Evolution's own account manager.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: evolution 3.8.4-0ubuntu1
ProcVersionSignature: Ubuntu 3.10.0-6.17-generic 3.10.3
Uname: Linux 3.10.0-6-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.12-0ubuntu3
Architecture: amd64
Date: Sat Aug 10 16:58:36 2013
InstallationDate: Installed on 2013-08-02 (8 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130801)
MarkForUpload: True
SourcePackage: evolution
UpgradeStatus: No upgrade log present (probably fresh install)

Kelly Hyde (polarimetric) wrote :
no longer affects: signon-ui (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in evolution (Ubuntu):
status: New → Confirmed
Alberto Mardegan (mardy) wrote :

The authentication prompts are fixed in EDS 3.9.5. From the NEWS file:

============================
Evolution-Data-Server 3.9.5 2013-07-29
--------------------------------------

* E-D-S now uses Google's OAuth2-based CalDAV v2 interface for Google
  accounts added through GNOME Online Accounts or Ubuntu Online Accounts,
  which means no more password prompts.
============================

Changed in evolution (Ubuntu):
importance: Undecided → High
Sebastien Bacher (seb128) wrote :
Changed in evolution (Ubuntu):
status: Confirmed → Fix Released
Arnaud Thevenet (aeromousse) wrote :

The issue is still not resolved in 14.04.
A discussion has started about it here :http://askubuntu.com/questions/511370/applications-can-no-longer-access-your-online-account

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers