evolution crashes on startup

Bug #11910 reported by Steven Ottens on 2005-01-14
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
evolution (Ubuntu)
High
Sebastien Bacher

Bug Description

evolution 2.1.3.2 crashes on start up
It shows the main-window but during checking my secure imap4 account it crashes
with:

(evolution:9022): camel-WARNING **: Invalid root:
'/home/steven/.evolution/mail/local/Drafts.ibex.index'

(evolution:9022): camel-WARNING **: version: TEXT.000 (TEXT.000)

(evolution:9022): camel-WARNING **: block size: 1024 (1024) OK

(evolution:9022): camel-WARNING **: free: 0 (0 add size < 1024) OK

(evolution:9022): camel-WARNING **: last: 6144 (6144 and size: 1024) BAD

(evolution:9022): camel-WARNING **: flags: unSYNC
sending: A00000 CAPABILITY
got A00000 response
sending: A00001 LOGIN **user** **pass**
got A00001 response
sending: A00002 LIST "" ""
got A00002 response
sending: A00003 LIST "" INBOX
got A00003 response
sending: A00004 SELECT INBOX
Encountered unknown flag: NonJunk
Encountered unknown flag: Junk
Encountered unknown flag: $Label1
Encountered unknown flag: $Label2
Encountered unknown flag: $MDNSent
Encountered unknown flag: $Forwarded
Encountered unknown flag: NonJunk
Encountered unknown flag: Junk
Encountered unknown flag: $Label1
Encountered unknown flag: $Label2
Encountered unknown flag: $MDNSent
Encountered unknown flag: $Forwarded
got A00004 response
sending: A00005 FETCH 1:787 (UID FLAGS)
got A00005 response
sending: A00006 LIST "" INBOX.Drafts
got A00006 response

(evolution:9022): camel-WARNING **: Trying to check CLASS
'@\xe8D\u0008\xedD\xa3w' is OBJECT 'CamelOfflineJournal'

(evolution:9022): camel-CRITICAL **: camel_object_class_cast: assertion
`check_magic(k, ctype, CAMEL_OBJECT_CLASS_MAGIC)' failed

http://bugzilla.ximian.com/show_bug.cgi?id=71315: http://bugzilla.ximian.com/show_bug.cgi?id=71315

Sebastien Bacher (seb128) wrote :

Thanks for the bug report. Without a stack trace from the crash it's very hard
to determine what caused the crash. Please see
http://bugzilla.gnome.org/getting-traces.cgi for more information about getting
a useful stack trace.

Steven Ottens (ubuntu-minst) wrote :
Download full text (7.1 KiB)

Backtrace was generated from '/usr/bin/evolution'

(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
`system-supplied DSO at 0xffffe000' has disappeared; keeping its symbols.

(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1228884288 (LWP 9166)]
[New Thread -1261139024 (LWP 9171)]
[New Thread -1252746320 (LWP 9170)]
[New Thread -1244353616 (LWP 9169)]
[New Thread -1235960912 (LWP 9168)]
(no debugging symbols found)

0xffffe410 in __kernel_vsyscall ()
#0 0xffffe410 in __kernel_vsyscall ()
#1 0xb7b7c40b in waitpid () from /lib/tls/i686/cmov/libc.so.6
#2 0xb7918bab in libgnomeui_module_info_get () from /usr/lib/libgnomeui-2.so.0
#3 0x080675b7 in es_menu_hook_get_type ()
#4 <signal handler called>
#5 0xffffe410 in __kernel_vsyscall ()
#6 0xb7ba14d9 in poll () from /lib/tls/i686/cmov/libc.so.6
#7 0xb6c9485a in g_main_loop_get_context () from /usr/lib/libglib-2.0.so.0
#8 0xb6c93ed3 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#9 0xb6c9449a in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#10 0xb741d6d3 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#11 0x08067c87 in main ()

Thread 5 (Thread -1235960912 (LWP 9168)):
#0 0xffffe410 in __kernel_vsyscall ()
No symbol table info available.
#1 0xb6e4400e in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib/tls/i686/cmov/libpthread.so.0
No symbol table info available.
#2 0xb7bb5045 in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
No symbol table info available.
#3 0xb7c5f879 in e_msgport_wait () from /usr/lib/libedataserver-1.2.so.0
No symbol table info available.
#4 0xb7c60063 in e_thread_busy () from /usr/lib/libedataserver-1.2.so.0
No symbol table info available.
#5 0xb6e41ae0 in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
No symbol table info available.
#6 0xb7ba9c2a in clone () from /lib/tls/i686/cmov/libc.so.6
No symbol table info available.

Thread 4 (Thread -1244353616 (LWP 9169)):
#0 0xffffe410 in __kernel_vsyscall ()
No symbol table info available.
#1 0xb6e4400e in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib/tls/i686/cmov/libpthread.so.0
No symbol table info available.
#2 0xb7bb5045 in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
No symbol table info available.
#3 0xb7c5f879 in e_msgport_wait () from /usr/lib/libedataserver-1.2.so.0
No symbol table info available.
#4 0xb7c60063 in e_thread_busy () from /usr/lib/libedataserver-1.2.so.0
No symbol table info available.
#5 0xb6e41ae0 in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
No symbol table info available.
#6 0xb7ba9c2a in clone () from /lib/tls/i686/cmov/libc.so.6
No symbol table info available.

Thread 3 (Thread -1252746320 (LWP 9170)):
#0 0xffffe410 in __kernel_vsyscall ()
No symbol table info available.
#1 0xb6e4400e in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib/tls/i686/cmov/libpthread.so.0
No symbol table info available.
#2 0xb7bb5045 in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
No symbol table info available.
#3 0xb7c5f879 in e_msgport_wait () from /usr/lib/libedataserver-1.2.so.0
No symbol table info available...

Read more...

Sebastien Bacher (seb128) wrote :

I've opened a bug upstream with the details and the backtrace:
http://bugzilla.ximian.com/show_bug.cgi?id=71315

Sebastien Bacher (seb128) wrote :

do you still have this bug ? That should be fixed with the current versions
according to the upstreams.

Steven Ottens (ubuntu-minst) wrote :

it works now

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.