Opening new-window from quicklist static action does not focus the newly opened window

Bug #1164483 reported by Marco Trevisan (Treviño) on 2013-04-04
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Messaging Menu
Fix Released
Medium
Marco Trevisan (Treviño)
Unity
Fix Released
Medium
Marco Trevisan (Treviño)
libindicator
Fix Released
Medium
Marco Trevisan (Treviño)
evolution (Ubuntu)
Undecided
Marco Trevisan (Treviño)
indicator-messages (Ubuntu)
Undecided
Unassigned
libindicator (Ubuntu)
Undecided
Marco Trevisan (Treviño)
Raring
Undecided
Unassigned
nautilus (Ubuntu)
Undecided
Marco Trevisan (Treviño)
unity (Ubuntu)
Undecided
Marco Trevisan (Treviño)

Bug Description

If evolution is opened but not focused, opening the calendar or contacts from the unity quicklist does not bring the newly opened window to focus.

If nautilus is opened but not focused, opening a new window from the unity quicklist does not bring the newly opened window to focus.

Related branches

Changed in evolution (Ubuntu):
status: New → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in libindicator:
status: New → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
importance: Undecided → Medium
Changed in unity:
status: New → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
importance: Undecided → Medium
milestone: none → 7.0.1
status: In Progress → Triaged
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:libindicator/13.04 at revision 483, scheduled for release in libindicator, milestone Unknown

Changed in libindicator:
status: In Progress → Fix Committed
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:libindicator at revision 485, scheduled for release in libindicator, milestone Unknown

Changed in evolution (Ubuntu):
status: In Progress → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libindicator - 12.10.2daily13.04.09-0ubuntu1

---------------
libindicator (12.10.2daily13.04.09-0ubuntu1) raring; urgency=low

  * Automatic snapshot from revision 484

libindicator (12.10.2daily13.04.08-0ubuntu1) raring; urgency=low

  [ Marco Trevisan (Treviño) ]
  * Opening calendar/contacts from quicklist does not focus the new
    window (LP: #1164483)
  * Libindicator should pass platform-data when launching application
    shortcuts (LP: #1164470)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 483
 -- Ubuntu daily release <email address hidden> Tue, 09 Apr 2013 02:02:03 +0000

Changed in libindicator (Ubuntu):
status: New → Fix Released
summary: - Opening calendar/contacts from quicklist does not focus the new window
+ Opening new-window from quicklist static action does not focus the newly
+ opened window
Changed in libindicator (Ubuntu):
status: Fix Released → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in libindicator:
status: Fix Committed → In Progress
description: updated
Changed in nautilus (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: New → Invalid
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:libindicator at revision 486, scheduled for release in libindicator, milestone Unknown

Changed in libindicator:
status: In Progress → Fix Committed
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:libindicator/13.04 at revision 486, scheduled for release in libindicator, milestone Unknown

Changed in unity:
status: Triaged → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision None, scheduled for release in unity, milestone backlog

Changed in unity:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libindicator - 12.10.2daily13.04.10-0ubuntu1

---------------
libindicator (12.10.2daily13.04.10-0ubuntu1) raring; urgency=low

  [ Marco Trevisan (Treviño) ]
  * Libindicator should use startup-notify when launching application
    shortcuts (LP: #1166890)
  * Opening new-window from quicklist static action does not focus the
    newly opened window (LP: #1164483)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 486
 -- Ubuntu daily release <email address hidden> Wed, 10 Apr 2013 02:02:06 +0000

Changed in libindicator (Ubuntu):
status: In Progress → Fix Released
Andrea Azzarone (azzar1) on 2013-04-10
Changed in unity (Ubuntu):
status: New → Fix Committed
Changed in libindicator:
milestone: none → 13.04.1
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.0.0daily13.04.15-0ubuntu1

---------------
unity (7.0.0daily13.04.15-0ubuntu1) raring; urgency=low

  [ Brandon Schaefer ]
  * Command lens does not close when pressing Alt+F2 (LP: #1167466)

  [ Andrea Azzarone ]
  * dash preview animation is slow on high resolution screens (also
    fullscreen mode) (LP: #1055126)

  [ Marco Trevisan (Treviño) ]
  * Unity makes unneeded copies of Nux DrawList (LP: #1167605)
  * Unityshell uses much of his CPU time only to get tray XIDs from
    PanelController (LP: #1167894)
  * Adding Lens results is more expensive than needed (LP: #1168569)
  * Opening new-window from quicklist static action does not focus the
    newly opened window (LP: #1164483)
  * Launcher pre-processes icons also when the icons have not been
    changed since last draw cycle (LP: #1168556)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3300
 -- Ubuntu daily release <email address hidden> Mon, 15 Apr 2013 04:17:42 +0000

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in indicator-messages:
milestone: none → 13.04.0
importance: Undecided → Medium
status: New → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:indicator-messages at revision 341, scheduled for release in indicator-messages, milestone 13.10.0

Changed in indicator-messages:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-messages - 12.10.6daily13.05.02-0ubuntu1

---------------
indicator-messages (12.10.6daily13.05.02-0ubuntu1) saucy; urgency=low

  [ Marco Trevisan (Treviño) ]
  * Opening new-window from quicklist static action does not focus the
    newly opened window (LP: #1164483)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 342
 -- Ubuntu daily release <email address hidden> Thu, 02 May 2013 22:59:03 +0000

Changed in indicator-messages (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libindicator (Ubuntu Raring):
status: New → Confirmed
Stephen M. Webb (bregma) wrote :

Fix released in Unity 7.1.0.

Changed in unity:
milestone: 7.0.1 → none
status: Fix Committed → Fix Released
Ted Gould (ted) on 2013-10-04
Changed in indicator-messages:
status: Fix Committed → Fix Released
Changed in libindicator:
status: Fix Committed → Fix Released
Rolf Leggewie (r0lf) wrote :

raring has seen the end of its life and is no longer receiving any updates. Marking the raring task for this ticket as "Won't Fix".

Changed in libindicator (Ubuntu Raring):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints