Calendar Authentication requests password in Ubuntu 12.10 and 13.10

Bug #1142511 reported by JCortez on 2013-03-03
70
This bug affects 15 people
Affects Status Importance Assigned to Milestone
evolution (Ubuntu)
Undecided
Unassigned

Bug Description

I just upgraded from Ubuntu 12.04 to 12.10. After I restarted with the new version of Ubuntu a window shows up very often asking for a password. The title of the window is "Calendar Authentication Request". The text withing the window says something like "Please enter your password for calendar 'nameofcalendar' user:<email address hidden> host:www.google.com".

I don't remember having configured my gmail calendar to work offline. Maybe I did, I want this message to stop showing up as it is EXTREMELY ANNOYING.

I have uninstall Evolution. I even removed the directory at ~/.local/share/evolution, but the window still shows up.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in evolution (Ubuntu):
status: New → Confirmed
Scott (scott-l-barlow) wrote :

This is extremely annoying. I can't seen to find anything about this on the web. Searching google for:
ubuntu "calendar authentication request" leads to only this bug report...

Is there anything I can do? I think I know what caused this. I used to have the calendar webapp (in 12.04) and then decided to stop using it. I also turned on the gmail settings for two-step verification. Immediately after doing that, I started to get this pop-up every single time I restart my computer! Very annoying.

Even after upgrading to 12.10, this still happens. I even went and re-installed the webapp and connected using the two step verification, but this pop-up still persists...

joshiss (joshiss) wrote :

This is affecting me in ubuntu 13.10 alpha 2, popping up again and again and not allowing any application to be worked on till i cancel it

Am having the same Problem on an up-to-date 13.10

summary: - Calendar Authentication requests password in Ubuntu 12.10
+ Calendar Authentication requests password in Ubuntu 12.10 and 13.10
joshiss (joshiss) wrote :

I found one thread which says following

go to alt-f2
run gconf-editor
go to apps/evolution/calendar/notify

unselect notify with tray

i did this but not yet restarted the computer so the pop ups are still annoying me let me try restarting ubuntu

joshiss (joshiss) wrote :

I am crossing my fingures but no pop up as yet

Scott (scott-l-barlow) wrote :

Hm, I'm on 12.10 and I don't see these options. I search gconf-editor for "notify" and it found nothing. I searched for "calendar" and it found 3 entries, but none had any sort of notify/tray/etc value to set. Maybe I can find something else within gconf-editor though....hm...

Scott (scott-l-barlow) wrote :

Hm...then I remember that one thing I did to try solving the problem before was un-installing evolution. So I re-installed it and now that checkbox IS there. However, after un-checking it and restarting my computer, the notification still comes up :(

Sigh

It never "randomly" comes up for it. It ALWAYS comes up when I restart my computer. After cancelling it, it never comes up again until I restart the computer. That's why I ignored it for so long, but I just can't anymore. Too annoying.

Scott (scott-l-barlow) wrote :

Errr....I don't know why I've kept saying 12.10, I'm actually running 13.04! Sorry for any confusion. Regardless, I still have this problem after trying any other solutions I could come up with tonight

Brian Galey (bkgaley) wrote :

I ran in to this problem as well after a recent upgrade to 13.10. Removing the pertinent calendar config file from ~/.config/evolution/sources/ fixed the issue for me. There are likely multiple configuration files in that directory so you will have to determine which specific calendar is causing the problem for you.

Scott (scott-l-barlow) wrote :

Thank you, Thank you, Thank you! That works! So relieving.

It persists on 13.10 after official release (17.10.13).
rm ~/.config/evolution/sources/* works though after logout/login.

Fix at comment #12 did not work for me.

sudo apt-get purge evolution-data-server did.

Remove all of the unneeded authentication prompts from your
~/.config/evolution/sources/
folder.

That worked for me.

What's putting them in there, in the first place?

What causes this?

I'm fine with Evolution authenticating to my gmail account, I'm just not so thrilled with twenty prompts for my password.

sudo apt-get purge evolution-data-server
worked for me, as well, although it removed some features of gnome3.

zetha (zetha) wrote :

I have Ubuntu 12.04 and this is indeed very annoying.
Run gconf-editor and uncheck notify with tray doesn't work for me.
There is no ~/.config/evolution/sources/ folder to delete.
I don't want to run sudo apt-get purge evolution-data-server because i use Evolution.
Any help please ?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers