Evolution will not remember exchange password

Bug #107974 reported by Stu Miller on 2007-04-20
86
This bug affects 11 people
Affects Status Importance Assigned to Milestone
evolution-data-server
Fix Released
High
evolution (Ubuntu)
Low
Unassigned
evolution-data-server (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Evolution continually asks for the exchange password when sending/replying to an email, opening the calendar, adding an appointment and even when I try to open my contacts, despite having checked the 'remember password' option every time the password request appears. This occurs:

- When sending a new email, or replying to an email (password request for Contacts appears)
- When opening contacts list hosted on an exchange server to view (password request for Contacts appears)
- When opening the calendar hosted on the exchange server to view (password request for Calendar appears)
- When attempting to add an appointment to the calendar (password request for Calendar appears)

Every time, I re-enter the password and make sure the 'remember password' option is checked.

Andrew Frank (frank-geoinfo) wrote :

i have the same problem running gutsy 7.10 tribe 5 updated today.
especially anoying, it requires a password when sending mail to access the global address book, even if completion for this is ticked off,
clicking cancel is enough to continue.

Geoff Shuetrim (geoff-galexy) wrote :

I am not able to get Evolution to remember passwords for any mail accounts for POP or SMTP access or for webcal calendars.

I am using:
Linux dell 2.6.22-14-generic #1 SMP Tue Dec 18 08:02:57 UTC 2007 i686 GNU/Linux

I am using Evolution 2.12.1.

I have moved my evolution data and configuration across from a previous installation of evolution on another machine that is also running Gutsy Gibbon and the same version of Evolution by copying the content of the .evolution .gconf and .gnome2-private directories to the new machine that I am setting up.

I have experimented with deleting mail accounts and setting them up again from scratch (all within the Evolution GUI). I have also experimented with turning the save passwords checkbox on before entering passwords and off before entering passwords. Nothing seems to affect the problem.

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? May you test the same with the evolution version available on Hardy?, thanks in advance!.

Changed in evolution:
status: New → Incomplete

Pedro,

It certainly is a continuing problem.

I will have a look at what is involved in installing the Evolution
version from Hardy and report back on the forum.

It surprises me that the problem is not causing more widespread
consternation. That makes me think it has something to do with the
specifics of how I move data across from a PC running Feisty.

Regards

Geoff Shuetrim

On Thu, 2008-02-07 at 18:18 +0000, Pedro Villavicencio wrote:
> Thank you for taking the time to report this bug and helping to make
> Ubuntu better. You reported this bug a while ago and there hasn't been
> any activity in it recently. We were wondering is this still an issue
> for you? May you test the same with the evolution version available on
> Hardy?, thanks in advance!.
>
> ** Changed in: evolution (Ubuntu)
> Status: New => Incomplete
>

Geoff Shuetrim (geoff-galexy) wrote :

Pedro,

I am trying to determine the best way to upgrade evolution to the hard
version without doing an upgrade of the rest of the system. Is this
straightfoward and if so, can you point me to a link giving directions
on how to do it?

If not, I will hang tight till April (or hopefully shortly thereafter)
and then let you know if Hardy fixes the problem.

Cheers

Geoff Shuetrim

On Thu, 2008-02-07 at 18:18 +0000, Pedro Villavicencio wrote:
> Thank you for taking the time to report this bug and helping to make
> Ubuntu better. You reported this bug a while ago and there hasn't been
> any activity in it recently. We were wondering is this still an issue
> for you? May you test the same with the evolution version available on
> Hardy?, thanks in advance!.
>
> ** Changed in: evolution (Ubuntu)
> Status: New => Incomplete
>

Geoff Shuetrim (geoff-galexy) wrote :

This was not fixed in the latest update to Evolution (2.12.1)

Regards

Geoff Shuetrim

On Thu, 2008-02-07 at 18:18 +0000, Pedro Villavicencio wrote:
> Thank you for taking the time to report this bug and helping to make
> Ubuntu better. You reported this bug a while ago and there hasn't been
> any activity in it recently. We were wondering is this still an issue
> for you? May you test the same with the evolution version available on
> Hardy?, thanks in advance!.
>
> ** Changed in: evolution (Ubuntu)
> Status: New => Incomplete
>

Jens Fursund (dlai) wrote :

My problem is probably related, I am running hardy and the password is only forgotten on reboot. Logging out and in again remembers the password. The first password dialog which appears does not seem to work though. So essentially I have to start evolution twice everytime I reboot my computer. First time the password dialog won't work, second time it works. Hope this helps to identify the problem. This is probably a problem which should be fixed upstream...

Jens Fursund (dlai) wrote :

Well the day I decide to make a bug report... the problem seems to have gone. So just ignore more posting above (8 hours ago). Open source is fantastic!

Guido Conaldi (guido-conaldi) wrote :

On my hardy 64bit evolution still asks for my exchange password every time I launch it or I go through the calendar

Steven Willis (onlynone) wrote :

Every time I start Evolution it asks for my Exchange password, and every time I enter it with the remember box checked. I think this was a problem for me in the past, but then it went away. I'm now using a fresh install of Hardy and it's back. I've tried deleting my ~/.gconf2/keyrings directory and starting fresh, but the it always asks for my password.

The weird thing is that I'm also subscribed to my Google Calendar and Evolution does remember my password for that just fine.

If I start Evolution up from a console, I get this error message:

e-data-server-ui-Message: Unable to find password(s) in keyring (Keyring reports: No matching results)
e-data-server-ui-Message: Key file does not have group 'Passwords-Exchange'

I got the same error message for my Google calendar (though the missing group was 'Passwords-google' instead of 'Passwords-Exchange') when I cleared out the keyring. But after I entered my password for it the one time, it never prompted me again.

If I run 'Application' -> 'Accessories' -> 'Passwords and Encryption Keys' (/usr/bin/seahorse), after I enter my Exchange password into Evolution, it shows a password entry with name: "exchange://myusername;<email address hidden>/", and it has the correct password saved. Even if I close Evolution, this password entry still shows up in seahorse. However, if I start evolution back up again, the password is removed from seahorse (until I respond to the password prompt, at which point it show back up in seahorse). The Google Calendar password never disappears from seahorse.

I did a fresh install of intrepid (either alpha1 or alpha 2, can't remember now) and I'm still getting asked for IMAP and SMTP passwords when I first check or send mail after starting evolution (2.23.4-0ubuntu1). The password dialogue only provides an option to "Remember this password for the remainder of this session", and that does indeed happen so strictly speaking this isn't a bug so far.

However I also have "Remember password" checked in the mail account preferences, for both IMAP and SMTP. I guess that's supposed to make it remember the password across sessions? It certainly seems to me that there ought to be a way to avoid having to type the password in every session.

D. Grady (fehknt) wrote :

Hm. I'm using ubuntu64, Evolution 2.22.3.1, and I have a similar issue. One of my IMAP logins is remembered all the time. My second IMAP and my SMTP passwords aren't remembered (unless it does. Sorry, unhelpful I know, but 5-10% of the time it works.).

Console report:
e-data-server-ui-Message: Unable to find password(s) in keyring (Keyring reports: No matching results)
e-data-server-ui-Message: Key file does not have group 'Passwords-Mail'

I'm not sure what server the failing one is, but the working one is a dovecot server on debian etch. it doesn't seem likely that it's a communication problem, but... more info can't hurt, right?

D. Grady (fehknt) wrote :

hm, just an update as i work with it more - it's not just one is remembered and the other isn't, it's randomly one or the other or both or neither. I thought it might be because the SSL certs were considered bat but I forced an exception and now it's happy with that and still not working. Not sure if this is an Evolution problem or keyring problem - probably Evolution because all the other passwords/certs are remembered correctly. If any devs have anything that they want tried out let me know and I should be able to try it out within a day (or maybe two if I'm really busy that day).

james v. jones (jjones233) wrote :

Thank you so much for taking the time to answer my e-mail. With your
help I was able to solve my problem. I had a "broken pipe" for awhile
until a friend of mine fixed it. Evolution works just fine now, and I
don't have anymore problems. You are good at what you do and I
appreciate you. THANK YOU!!!

john_s (lists-john) wrote :

Hello James,

Could you or or friend post the fix here? I am having the same trouble as well, perhaps this apparently long standing problem can get fixed with your help.

Thanks!

John

Andy Barr (ajbarr) wrote :

I'm seeing the same problem on a fresh Hardy 64 bit install using latest Evolution with Exchange. If James could post his fix that would be great.
Thanks,
Andy

Andy Barr (ajbarr) wrote :

I found a solution to my problem. Hopefully it works for other people too. I started evolution from a command prompt and was getting messages these messages,

e-data-server-ui-Message: Unable to find password(s) in keyring (Keyring reports: No matching results)
e-data-server-ui-Message: Key file does not have group 'Passwords-Exchange'

A quick internet search and I found a solution. I had specified my OWA URL: under the Receiving Email tab in account setup using an ip address, ie https://204.26.234.200/.

If I changed the OWA URL: to the actual domain name, ie https://trexchange/ then my password is remembered and everything works. I have added "trexchange" to my /etc/hosts/ file. Seems like this is some sort of bug in the program that stores the passwords.
Thanks,
Andy

Sebastien Bacher (seb128) wrote :

could you look in searhose if you have a password for the correspond account? did you find a GNOME bug while searching?

Sebastien Bacher (seb128) wrote :

the issue doesn't seem to be an evolution one

Changed in evolution:
importance: Undecided → Low
status: Incomplete → Invalid
Changed in evolution-data-server:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Incomplete
Andy Barr (ajbarr) wrote :

I had some strange items listed in seahorse such as this, 204.26.234.200trexchange where it seemed to be referencing both the ip address and the domain name. So I delete all references to this from seahorse and the changed my OWA back to the IP address in the exchange account that I had setup.
Then my account would not work at all. It kept asking for my password but never connecting at all. So I tried to go back to the server name, trexchange, that worked before and it still would not connect. I had to delete the account and recreate it using the server name and then it worked. There still seems to be some sort of Evolution issue if you can't change your server name and end up having to delete the account to fix it.

So I went back again deleted the account that worked and set it up again using the IP address. Now it seems to be working fine. I looked in Seahorse the reference to the server is correct and only has the IP address. I will continue to use it and report back if I have any issues. This is very strange.

Thanks,
Andy

D. Grady (fehknt) wrote :

Also strange: I have a laptop and a desktop, both set up almost identically, except that the desktop is running 64-bit, and the laptop 32-bit. The laptop had no problems at all with this issue, while the desktop did, using names for both setups. I'll try to remove accounts and keyring entries, then re-setup the accounts when I get home to see if that helps at all...

Andy Barr (ajbarr) wrote :

I wanted to follow up that using the IP address for the account is still working fine for me. As I said before, the fix for constantly getting the request for your password seems to be to delete your exchange account in Evolution and delete and references to the server in Seahorse. Then recreate the exchange account in Evolution.

The settings in Evolution that work for me are on the Receiving Email tab,

username (without the domain) i.e. "andy" not "engr\andy"

https://server ip address/

then click Authenticate and your mailbox name is filled in automatically. For Authentication Type, I'm using, "Plaintext Password".

On the receiving options tab, I have checked the following,
"Check for new messages every 10 minutes"
"Password Expiry Warning period:7"
"Automatically synchronize account locally"
"Apply filters to new messages in Inbox on this server" - > this is important if you have filters you want to run to move mail to certain folders

The rest of the tabs in the exchange setup use the defaults.

Hopefully this helps someone.
Thanks,
Andy

Sebastien Bacher (seb128) wrote :

would be nice if somebody having the issue could open a bug on bugzilla.gnome.org where people writting the code can comment since they will probably have a better idea about the issue

Changed in evolution-data-server:
status: Incomplete → New
James Lamb (admin-oranged) wrote :

Hi

In our organisation we currently have a password policy which means we need to update our passwords very frequently. (every two weeks). Traditionally the policy caused no issues with evolution as we could update the password using our webmail account and then shutdown evolution, restart it. Once the system was restarted it would prompt for a password and it would all work. Now when I update the password evolution consistently fails to authenticate. If I use my details against the OWA url directly they work every time first time. When I run evolution from the command prompt I get the following debug

e-data-server-ui-Message: Unable to find password(s) in keyring (Keyring reports: No matching results)
e-data-server-ui-Message: Key file does not have group 'Passwords-Exchange'
e-data-server-ui-Message: Unable to find password(s) in keyring (Keyring reports: No matching results)
e-data-server-ui-Message: Key file does not have group 'Passwords-Exchange'
(evolution:9661): evolution-mail-WARNING **: Error occurred while existing dialogue active:
Could not authenticate to server. (Password incorrect?)

Even though I know the password is right (i typed it in kate, then copied and pasted it into OWA, that worked no problems. Then did the same for evolution and it failed to authenticate. I have checked with tcpdump against the OWA server and in each time it does appear to be trying to authenticate. I also find this strange as if it was failing the account would become locked out as a part of our default password policy (to stop brute force attacks). I have deleted the gnome keyring and reset it all up, rebooted the server, tried the "forget passwords" option in evolution and none of these options have had any effect on the problem.

James Lamb (admin-oranged) wrote :

I have reported this bug to the gnome community as requested. Bug ID 552324

Changed in evolution-data-server:
status: New → Triaged
Changed in evolution-data-server:
status: Unknown → New

I confirm this for Ubuntu Intrepid as of today and Evolution 2.24.0.

Am I getting this right: It took a year until this information got to the actual developers because there is no automatic information handover between Launchpad and Bugzilla?

Sebastien Bacher (seb128) wrote :

no there is no automatic bug forwarding because that would not be a good idea to send all the incomplete bugs there, only confirmed bugs should be sent upstream when then have enough informations, in this case few bug triagers have acces to an exchange server so it was waiting for somebody who has the issue to open the bug there

----
Sebastien Bacher wrote on 2008-08-21:

would be nice if somebody having the issue could open a bug on bugzilla.gnome.org where people writting the code can comment since they will probably have a better idea about the issue
----

Means that it is probably quite useless if we keep on commenting this issue here.

Apart from the bug report itself which has been opened upstream on September 15th, there is no response activity there at all (cf http://bugzilla.gnome.org/show_bug.cgi?id=552324). I wonder how a software which performs as buggy as Evolution can be a part of Ubuntu. Wouldn't it be better and more fair to tell users: "Ubuntu offers no usuable Exchange server support. If you need an OS for professional, company use which includes the use of an Exchange 2003 server, you'd better use another OS"?

Changed in evolution-data-server:
status: New → Confirmed
Chow Loong Jin (hyperair) wrote :

I have no such issue, and I am using an Exchange account. Just because you have issues, it doesn't mean that the entire software is buggy and cannot be used. Please do not be so negative. Why don't you post debug logs with environment variable E2K_DEBUG=<1-5>? The higher the number the better, but keep in mind that 5 will expose your username and password in the log. Usually level 4 should be good enough.

Chow Loong Jin (hyperair) wrote :

It's also worth mentioning that it's not that Evolution doesn't remember your password, it's that the Exchange server is blocking the first authentication attempt, so Evolution assumes that your password may be wrong and prompts you for it. If your password was indeed wrong, it would be pointless to keep trying.

me too(tm)

Evolution won't save contacts/calendar passwords. Seahorse doesn't list the
contacts/calendar passwords, but it does list imap and other passwords as
"imap://...." It doesn't list my google calendar password (and that doesn't
work) -- I haven't setup google mail.

I'm trying to find out if I can add a manual entry to seahorse.

Changed in evolution-data-server:
status: Confirmed → Incomplete
Sebastien Bacher (seb128) wrote :

could you try if that's still an issue in jaunty?

Changed in evolution-data-server (Ubuntu):
status: Triaged → Incomplete
D. Grady (fehknt) wrote :

I had this problem on and off but I haven't had it recently. It may be my upgrade to Jaunty, it may be that I changed my SMTP password to match my IMAP password on the same server.

rah003 (rah-atlas) wrote :

I have this problem right now on Jaunty, in case you want some more info or specific tests to be performed.

had@ace2:~$ uname -a
Linux ace2 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:58:03 UTC 2009 x86_64 GNU/Linux

Whity (x-launchpad-whity-ch) wrote :

Also had this problem for a very very long time (on Ubuntu and Fedora). But because i did not have to use Exchange a lot i did not cared about it. Today morning i thought i really have to fix that.

The solution worked for me was to change the Authentication Type from Basic to "Secure password". (Also deleted the entry in seahorse first)

It doesn't only happen with Exchange. It also happens using a *dav server. Not matter of using a calendar or contacts.
As soon as you open Evoltution and click on calendar, tasks or contacts tab, it shows a password prompt.
The annoying thing is, that you can't see any contacts (i.e. when you write a new mail) as long as you haven't clicked on the contacts tab and entered the password first.

br
HPS

Chow Loong Jin (hyperair) wrote :

On Sat, 2009-06-20 at 07:17 +0000, Hans-Peter Schadler wrote:
> It doesn't only happen with Exchange. It also happens using a *dav server. Not matter of using a calendar or contacts.
> As soon as you open Evoltution and click on calendar, tasks or contacts tab, it shows a password prompt.
> The annoying thing is, that you can't see any contacts (i.e. when you write a new mail) as long as you haven't clicked on the contacts tab and entered the password first.
>
> br
> HPS
>

I think it's more like authentication always fails the first time. I
noticed that Evolution doesn't show the difference between a failed
authentication and not remembering the password.

--
Regards,
Chow Loong Jin

Changed in evolution-data-server:
status: Incomplete → Fix Released
Sebastien Bacher (seb128) wrote :

the issue should be fixed in current version

Changed in evolution-data-server (Ubuntu):
status: Incomplete → Fix Released
wmccarty (wdmlist) wrote :

Bump!

The fix for whatever reason has not been released for my installation of Evolution. I have 8 email accounts and it is extremely annoying to constantly have to enter the passwords even though I clicked 'remember' password.

Please consider this bug incomplete. I am using Kubuntu 9.04 Jaunty and evolution 2.26.1 with AMD64.

I'm was this issue with one server I use. I fixed this by asking for the supported server options. It then gave me either PASSWORD or GSSAPI. I changed to GSSAPI, then restarted. This failed completely. (I suspect a half-configured setup on the server side - they probably tried to get GSSAPI set up but it never really worked and they left it marked as a supported option.) I then converted back to PASSWORD and restarted. It now seems to have successfully saved my password!

Oh happy day!

Textureglitch (textureglitch) wrote :

I had this problem too on Ubuntu Karmic trying to sync with google calendar.

The error in the terminal was:
e-data-server-ui-Message: Unable to find password(s) in keyring (Keyring reports: No matching results)
e-data-server-ui-Message: Key file does not have group 'Passwords-Calendar'
(evolution:14134): e-data-server-ui-WARNING **: Unable to find password(s) in keyring (Keyring reports: No matching results)

My workaround was to delete the .evolution folder in the home directory (it will be recreated automatically), delete the relevant login keys in seahorse, and run 'evolution --force-shutdown' in the terminal.

Jendos (jendoss) wrote :

Passwords resets (i think) every time when the Evolution is experiencing difficulties with access to POP-server (long ping, temporary unaccessibility, connection problems), perhaps perceiving it as a wrong password. Please, make a "remember password" settings true!

Tom (t-vanengeland) wrote :

Hi,

A quick response on the exchange password issue (cfr. post of Andy from 2008-08-12). I apologize if this is too straightforward for some or most of you, but I'm only an end-user and it was a detail that was certainly not obvious to me.

I indeed used the domain name but it did not seem to work. (https://domain.name/exhange). After a while I noticed that there was a / at the back in Andy's post. After adding the / (https://domain.name/exchange/) Evolution remembered my password.

Perhaps it is of some importance to someone....

Tom

I am still experiencing this bug in Evolution 2.28.3 / Lucid

Changed in evolution-data-server (Ubuntu):
status: Fix Released → Incomplete
Changed in evolution-data-server:
importance: Unknown → High
sunbird (sunbird) wrote :

I'm still experiencing this bug on a fresh Lucid x64 install. I never had this problem on my prior Lucid install.

If this bug is incomplete, please let me know what information you need so I can provide it as it is quite frustrating.

This is not a server-side problem as I never experienced it before on my prior Lucid install (i.e. from May 2010 until just recently, same server settings).

This problem still occurs in Precise, exactly as described in the description.

xstaticxgpx (optimum-reflex) wrote :

Just started having this exact issue with my EWS exchange account AND my gmail account (which I use 2factor for so it was driving me insane)

What I did was go into seahorse and just clear all my saved logins. After doing that and then re-entering my login info once more it seems to have saved the logins to my keyring persistently. Atleast between evolution restarts, haven't tried a reboot though

Mahdi Fattahi (mfat) wrote :

The problem persists in Ubuntu 14.04

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.