Ubuntu

Adressbook entries not visible after selection "To:" email field

Reported by Stefan Czinczoll on 2012-10-28
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evolution
Expired
Medium
evolution (Arch Linux)
New
Undecided
Unassigned
evolution (Ubuntu)
Undecided
Unassigned

Bug Description

Hi there,

I've been using evolution with address book quite long. When inserting adresses manually into the recipient field, entries are correctly recommended by evolution after typing the first letters. But it's not possible to select one or several adresses after clicking on the "To:" field when composing a new mail. The main contact list, every category chosen is simply empty, none of my addressbook entries is shown. So I'm unable to add or remove contacts to or from the "To:", "CC:" or "BCC:" lists.

I wonder wether this behaviour is due to evolution or evolution-data-server and would appreciate any help.

Kind regards,

Stefan

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: evolution 3.6.0-0ubuntu3
ProcVersionSignature: Ubuntu 3.5.0-18.29-generic 3.5.7
Uname: Linux 3.5.0-18-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.6.1-0ubuntu6
Architecture: amd64
Date: Sun Oct 28 20:44:01 2012
InstallationDate: Installed on 2012-08-16 (72 days ago)
InstallationMedia: Xubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120815)
MarkForUpload: True
SourcePackage: evolution
UpgradeStatus: No upgrade log present (probably fresh install)

I just tried to test with a fresh installation of evolution inside a new virtual machine (for raring ringtail testing purpose). Evolution has still the same version:

$ apt-cache policy evolution
evolution:
  Installiert: 3.6.0-0ubuntu3
  Kandidat: 3.6.0-0ubuntu3
  Versionstabelle:
 *** 3.6.0-0ubuntu3 0
        500 http://archive.ubuntu.com/ubuntu/ raring/main amd64 Packages
        100 /var/lib/dpkg/status

I entered one addressbook entry and voila: Selecting the address after clicking the Receiver field is not possible. The list is empty as in my production environment!

HTH,

Stefan

Just made a test with a fresh compilation from source with evolution stable version 3.6.2: The bug is still here, so I'm eagerly awaiting current unstable version 3.7.1.

As version 3.6.2 is now in the repos, I was able to test them. I'm adding the output of the following command to the bug:

CAMEL_DEBUG=all WEBDAV_DEBUG=1 evolution >& evo.log

HTH,

Stefan

I could verify now that the bug is not present in evolution version 3.4.4 (tested on Sabayon), so it's most probably come up with 3.6 versions.

Changed in evolution:
importance: Undecided → Unknown
status: New → Unknown
Changed in evolution:
importance: Unknown → Medium
status: Unknown → Incomplete

Developer Milan Crha fixed the code for evolution-data-server 3.6.3 and 3.7.3. Please see http://bugzilla.gnome.org/show_bug.cgi?id=688479.

Changed in evolution:
status: Incomplete → Expired

Hello Stefan, or anyone else affected,

Accepted evolution-data-server into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/evolution-data-server/3.6.4-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed

The fix for this bug has been awaiting testing feedback in the -proposed repository for quantal for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now, the package will be removed from the -proposed repository.

tags: added: removal-candidate
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.