Ubuntu

Some translation templates are not in sync with upstream

Reported by Pierre Slamich on 2012-09-27
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Medium
Unassigned
evolution (Ubuntu)
Undecided
Unassigned

Bug Description

French for instance is fully translated upstream and has 500+ strings remaining in Ubuntu
http://l10n.gnome.org/vertimus/evolution/gnome-3-6/po/fr

Wondering whether it might affect other GNOME packages and even other kind of packages.
Despite our best effort to educate about duplication and upstream contribution, people are redoing the work on LP, so a proper and frequent sync is essential (now and for the next cycle)

tags: added: translation
Gabor Kelemen (kelemeng) on 2012-09-28
Changed in ubuntu-translations:
status: New → Confirmed
importance: Undecided → High
tags: added: l10n
removed: translation
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in evolution (Ubuntu):
status: New → Confirmed

Al 28/09/12 19:53, En/na Pierre Slamich ha escrit:
> Sorry to keep raising questions like this on the list, but I didn't
> manage to assign the bug to Ubuntu-translators.
> To sum up what's below, Evolution translations are not in sync with
> Gnome, leading to duplication of effort.
>
> https://bugs.launchpad.net/bugs/1057767
>
> Is it working as intended or is there something going wrong ?
>

Hi Pierre,

Sorry for the delay in replying, I just found some time to look into
this issue.

Evolution is set to use bzr imports from the upstream GNOME branch. This
way, the PO files are imported directly from bzr and shared with Ubuntu,
which makes (in theory) new translations be imported daily.

However, there seems to be something wrong with the upstream bzr import,
as it's creating 3 versioned translatable templates, which means
translations from the branch are not imported.

For now, I've disabled upstream sharing for the evolution template, and
translations should be imported using the traditional package upload
mechanism.

Cheers,
David.

 status triaged
 importance low

> ---------- Forwarded message ----------
> From: *Pierre Slamich* <<email address hidden>
> <mailto:<email address hidden>>>
> Date: Thu, Sep 27, 2012 at 10:55 PM
> Subject: [Bug 1057767] [NEW] Translations are not in sync with Gnome,
> leading to duplication of effort
> To: <email address hidden> <mailto:<email address hidden>>
>
>
> Public bug reported:
>
> French for instance is fully translated upstream and has 500+ strings
> remaining in Ubuntu
> http://l10n.gnome.org/vertimus/evolution/gnome-3-6/po/fr
>
> Wondering whether it might affect other GNOME packages and even other
> kind of packages.
> Despite our best effort to educate about duplication and upstream
> contribution, people are redoing the work on LP, so a proper and
> frequent sync is essential (now and for the next cycle)
>
> ** Affects: evolution (Ubuntu)
> Importance: Undecided
> Status: New
>
>
> ** Tags: translation
>
> ** Tags added: translation
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1057767
>
> Title:
> Translations are not in sync with Gnome, leading to duplication of
> effort
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/evolution/+bug/1057767/+subscriptions
>
>
>
> --
> Pierre Slamich
> <email address hidden> <mailto:<email address hidden>>
> (00 33) 6 02 13 14 57
>
>

--
David Planella
Ubuntu Translations Coordinator
www.ubuntu.com / www.davidplanella.wordpress.com
www.identi.ca/dplanella / www.twitter.com/dplanella

Changed in ubuntu-translations:
importance: High → Low
status: Confirmed → Triaged

Looking at it in more detail, it seems that there is not much we can do with Evolution, other than disabling upstream message sharing and going back to the traditional way of importing translations with package uploads. This is due to the upstream template name being versioned [1].

However, there might be a bug in the Orca import [2], which shows an invalid template name.

[1] https://translations.launchpad.net/ubuntu/quantal/+source/evolution/+sharing-details
[2] https://translations.launchpad.net/ubuntu/quantal/+source/orca/+sharing-details

Hendrik Knackstedt (hennekn) wrote :

I'm pretty sure there are more packages affected then just Evolution and Orca. For example I see this issue with »gtk-3.0-properties« [1]. This is fully translated to German upstream in version 3.0 as well as in later versions.

[1] https://translations.launchpad.net/ubuntu/quantal/+source/gtk+3.0/+sharing-details

summary: - Translations are not in sync with Gnome, leading to duplication of
- effort
+ Translations are not in sync with Gnome

So after some investigation, I've found out that this is related to upstream sharing.

- For evolution, the issue is that upstream uses a versioned template name (e.g. evolution-3.6.pot), whereas in Ubuntu, to benefit from message sharing across distro releases, we use an unversioned template name (i.e. evolution). This means that upstream sharing will not work for Evolution, as the two templates (upstream/downstream) need to have the same name. I've disabled upstream sharing for Evolution for now, so that translations are imported from packages as they used to do.

- For Orca, the upstream template name was ac-package-name, which points to a bug in upstream sharing. I've now corrected it manually to orca, which means upstream translations should now be imported, but we'll see if the name stays when the next byr import happens.

- For GTK+, the issue was that the template names (upstream/downstream) didn't match. I've now edited the upstream template name to match the Ubuntu one, so that sharing happens.

- For evolution-data-server, the problem was that the upstream bzr import was still set to SVN. I've corrected it to be for git, but we're having the same issue as Evolution with versioned template names.

summary: - Translations are not in sync with Gnome
+ Some translation templates are not in sync with upstream
Changed in ubuntu-translations:
importance: Low → Medium
Changed in evolution (Ubuntu):
status: Confirmed → Invalid
Pierre Slamich (pierre-slamich) wrote :

I have the feeling it could affect templates such as network manager where there are an awful lot of "suggestions" from upstream I suspect to be the actual translations.

https://translations.launchpad.net/ubuntu/quantal/+source/network-manager/+pots/networkmanager/fr/+translate?memo=9&show=untranslated&start=9

Al 12/10/12 01:50, En/na Pierre Slamich ha escrit:
> I have the feeling it could affect templates such as network manager
> where there are an awful lot of "suggestions" from upstream I suspect to
> be the actual translations.
>
>
> https://translations.launchpad.net/ubuntu/quantal/+source/network-manager/+pots/networkmanager/fr/+translate?memo=9&show=untranslated&start=9
>

I don't see Mathieu listed as an upstream translator on
http://l10n.gnome.org/teams/fr/

Are these not simply suggestions he did on Launchpad?

It might also be that he got assigned to him during an upload where
there wasn't any Last-Translator set on the PO file. Are all these
strings translated upstream?

Pierre, could you look into the questions above? They should help us
figuring out if there's anything wrong with the networkmanager import.

Thanks.

Cheers,
David.

--
David Planella
Ubuntu Translations Coordinator
www.ubuntu.com / www.davidplanella.wordpress.com
www.identi.ca/dplanella / www.twitter.com/dplanella

Al 12/10/12 13:21, En/na David Planella ha escrit:
> Al 12/10/12 01:50, En/na Pierre Slamich ha escrit:
>> I have the feeling it could affect templates such as network manager
>> where there are an awful lot of "suggestions" from upstream I suspect to
>> be the actual translations.
>>
>>
>> https://translations.launchpad.net/ubuntu/quantal/+source/network-manager/+pots/networkmanager/fr/+translate?memo=9&show=untranslated&start=9
>>
>
> I don't see Mathieu listed as an upstream translator on
> http://l10n.gnome.org/teams/fr/
>
> Are these not simply suggestions he did on Launchpad?
>
> It might also be that he got assigned to him during an upload where
> there wasn't any Last-Translator set on the PO file. Are all these
> strings translated upstream?
>
> Pierre, could you look into the questions above? They should help us
> figuring out if there's anything wrong with the networkmanager import.
>
> Thanks.
>
> Cheers,
> David.
>

Actually, NetworkManager translations come from Freedesktop.org, and it
seems that upstream translations are not complete:

http://cgit.freedesktop.org/NetworkManager/NetworkManager/tree/

So the importer works fine for this particular one.

Cheers,
David.

--
David Planella
Ubuntu Translations Coordinator
www.ubuntu.com / www.davidplanella.wordpress.com
www.identi.ca/dplanella / www.twitter.com/dplanella

Pierre Slamich (pierre-slamich) wrote :

Indeed. Was too quick on that one.
I was wondering how to proceed to import the Evolution strings.
I've just uploaded a po file from GNOME, but I'm not sure if it's the right one:
http://l10n.gnome.org/languages/fr/gnome-3-6/ui/
given that this page mentions: "po/evolution-3.0-fr.po in evolution in Ubuntu Quantal" and that my file is 3.6
https://translations.launchpad.net/ubuntu/quantal/+source/evolution/+imports

Hendrik Knackstedt (hennekn) wrote :

Will translations for evolution be updated automatically now or do we have to upload the po file to get updated translations?

Al 15/10/12 11:40, En/na Hendrik Knackstedt ha escrit:
> Will translations for evolution be updated automatically now or do we
> have to upload the po file to get updated translations?
>

They should now be imported with every upload of the Evolution package.
The last upload was on the 28th September for 3.6.0 [1], and I imagine
there will be another upload when 3.6.1 is released.

Feel free to upload translations manually if you don't want to wait for
the next upload. In any case, translations will be included in the first
post-release language pack.

Cheers,
David.

[1] https://launchpad.net/ubuntu/+source/evolution/+publishinghistory

--
David Planella
Ubuntu Translations Coordinator
www.ubuntu.com / www.davidplanella.wordpress.com
www.identi.ca/dplanella / www.twitter.com/dplanella

Changed in ubuntu-translations:
status: Triaged → Fix Released

Is there a lesson we can draw from this ? Do we have a risk it might happen
again ?

Pierre Slamich
<email address hidden>

On Thu, May 23, 2013 at 10:04 AM, Hendrik Knackstedt <
<email address hidden>> wrote:

> ** Changed in: ubuntu-translations
> Status: Triaged => Fix Released
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1057767
>
> Title:
> Some translation templates are not in sync with upstream
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu-translations/+bug/1057767/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers