Ubuntu

evolution takes forever to retrieve new messages

Reported by ais523 on 2012-05-26
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
evolution (Ubuntu)
Undecided
Unassigned

Bug Description

Evolution, when I click on "send/receive" messages, or automatically when I view a particular IMAP mailbox (which is set to make messages available offline, which might or might not be relevant), spends forever (several hours so far, and I have no reason to think it will end) with "Retrieving message '19464' from INBOX" (twice), "Retrieving message '18840' from INBOX", "Refreshing folder INBOX", and "Checking for new mail" as progress items in the status bar. That particular mailbox lists messages it contains but just displays "Retrieving message '19464'" in the place where the email itself is normally displayed when I try to view the most recent email when clicking on it (and adds another copy of "Retrieving message '19464' from INBOX" to the status bar); the rest of the interface, and other mailboxes, work correctly. Evolution is also using an appreciable proportion of my CPU power.

This happens consistently each time I load the program and navigate to that email. Evolution cannot be closed normally while the progress messages are shown; they just get stuck at "(cancelling)" and it doesn't close, not with the normal close button nor with SIGTERM (I have to resort to SIGKILL).

I don't know whether or not the IMAP server I'm trying to connect to is having issues, and it seems likely that it is, given that my other IMAP mailboxes work fine. Nonetheless, Evolution should not be unresponsive in this way no matter how the server it's connecting to responds.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: evolution 3.2.3-0ubuntu6
ProcVersionSignature: Ubuntu 3.2.0-24.38-generic 3.2.16
Uname: Linux 3.2.0-24-generic i686
ApportVersion: 2.0.1-0ubuntu7
Architecture: i386
Date: Sat May 26 23:37:36 2012
ExecutablePath: /usr/bin/evolution
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: evolution
UpgradeStatus: Upgraded to precise on 2012-04-26 (30 days ago)

ais523 (ais523) wrote :
ais523 (ais523) wrote :

Oh, and just checked: the list of emails shown in the problematic mailbox is the list as of the last time the mailbox worked, it doesn't account for emails received since. (Emails related to this bug are going into that mailbox; that's how I noticed.)

I can also access the mailbox in question via a web browser, so I should still be able to communicate about the bug.

ais523 (ais523) wrote :

One more experiment: if I reboot the system and then load Evolution and give it no input, nor switch to the offending mailbox, it's left with one "Checking for new mail" in the status bar. (There were originally four; I have four mailboxes. But three of them disappeared.)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in evolution (Ubuntu):
status: New → Confirmed
ais523 (ais523) wrote :

Can no longer reproduce, presumably because the offending IMAP server has started working again.

This bug may well require access to a broken IMAP server for testing; I'm not entirely sure where I could get one, though.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers