evolution-scalix FTBFS with current evolution

Bug #193764 reported by Steve Langasek on 2008-02-20
12
Affects Status Importance Assigned to Milestone
gvfs
Invalid
Undecided
Unassigned
evolution-scalix (Ubuntu)
High
Unassigned
Hardy
High
Unassigned

Bug Description

Binary package hint: evolution-scalix

evolution-scalix fails to build from source in hardy for two reasons: first, the .pc files have been renamed (again) for evolution 2.22 so configure fails to detect them; and once that's fixed, the plugin fails to compile because it uses a structure that has been made opaque in 2.22.

I have a patch for the first issue, but the second issue probably should be referred upstream.

Steve Langasek (vorlon) wrote :
Steve Langasek (vorlon) wrote :

Here's the build failure trying to build against the evolution 2.22 headers:

scalix-account-synch.c: At top level:
scalix-account-synch.c:577: error: field 'msg' has incomplete type
scalix-account-synch.c:1016: error: variable 'account_synch_op' has initializer but incomplete type
scalix-account-synch.c:1017: warning: excess elements in struct initializer
scalix-account-synch.c:1017: warning: (near initialization for 'account_synch_op')
scalix-account-synch.c:1018: warning: excess elements in struct initializer
scalix-account-synch.c:1018: warning: (near initialization for 'account_synch_op')
scalix-account-synch.c:1019: warning: excess elements in struct initializer
scalix-account-synch.c:1019: warning: (near initialization for 'account_synch_op')
scalix-account-synch.c:1020: warning: excess elements in struct initializer
scalix-account-synch.c:1020: warning: (near initialization for 'account_synch_op')
scalix-account-synch.c: In function 'scalix_account_synch_run':
scalix-account-synch.c:1043: warning: passing argument 1 of 'mail_msg_new' from incompatible pointer type
scalix-account-synch.c:1043: error: too many arguments to function 'mail_msg_new'
scalix-account-synch.c:1055: error: 'mail_thread_new' undeclared (first use in this function)
scalix-account-synch.c:1055: error: (Each undeclared identifier is reported only once
scalix-account-synch.c:1055: error: for each function it appears in.)
make[3]: *** [scalix-account-synch.lo] Error 1

Changed in evolution-scalix:
importance: Undecided → High
status: New → Confirmed
Daniel Holbach (dholbach) wrote :

Christian: any idea how to fix it?

Christian Kellner (gicmo) wrote :

I have a preliminary patch attached to GNOME's bugzilla. It would need some more love and check if we are affected by upstream's ical memory changes. No time since I am busy doing gvfs work, but that should compile and according to Gren also work.

Changed in gvfs:
status: Unknown → Confirmed
Michael Vogt (mvo) wrote :

This bug breaks dapper->hardy upgrades if evolution-scalix is installed on dapper. The way breaks currently works, is that they try to upgrade the package and if that fails, the resolver fails. We either need to make evolution-scalix installable or we need to change the breaks into a conflicts.

Changed in evolution-scalix:
milestone: none → ubuntu-8.04
Daniel Holbach (dholbach) wrote :

Christian: can you please help me assembling the patch for 10.0.1.1-0ubuntu2? It seems that evo+eds changed again and neither your upstream changes (svn plus patch in gnome-bug 523013) nor Steve's patch are solving the issue right now.

Steve Langasek (vorlon) wrote :

At this point I think removing the package for hardy looks like a reasonable option; is there a reason not to go ahead with removal now?

Daniel Holbach (dholbach) wrote :

Steve: I think that's OK.

Michael: where do we need to introduce the 'Conflicts'?

Steve Langasek (vorlon) wrote :

Ok, evolution-scalix has been removed from hardy:

2008-04-16 09:19:11 INFO creating lockfile
2008-04-16 09:19:15 INFO Removing candidates:
2008-04-16 09:19:15 INFO evolution-scalix 10.0.1.1-0ubuntu2 in hardy
2008-04-16 09:19:15 INFO Removed-by: Steve Langasek
2008-04-16 09:19:15 INFO Comment: FTBFS with current evolution; LP: #193764
2008-04-16 09:19:15 INFO 1 package successfully removed.
2008-04-16 09:19:15 INFO Transaction committed.
2008-04-16 09:19:15 INFO The archive will be updated in the next publishing cycle.

Can be readded for intrepid when a version is available that builds against current e-d-s.

Changed in evolution-scalix:
status: Confirmed → Fix Released
Changed in gvfs:
status: New → Invalid
Changed in evolution-scalix:
status: Unknown → Confirmed
Pasi Kärkkäinen (pasik) wrote :

Any news about evolution-scalix? Anyone working with it?

I'd need evolution-scalix for hardy so I'd like to help :)

Pasi Kärkkäinen (pasik) wrote :

Actually this link has an example how to build the current evolution-scalix connector on hardy:

http://www.scalix.com/forums/viewtopic.php?p=48393

Pasi Kärkkäinen (pasik) wrote :

Actually the correct thread link is this:

http://www.scalix.com/forums/viewtopic.php?t=10356

Daniel Holbach (dholbach) wrote :

I'm happy to help with reviewing it and uploading it to Intrepid, but I won't have the time to do this myself or to maintain the package any further right now.

Pasi Kärkkäinen (pasik) wrote :

http://www.scalix.com/forums/viewtopic.php?t=10399

8.04 LTS (Hardy) - Evolution 2.22.1
For i386: http://www.petersfood.com/ubuntu/8.04/evolution-scalix_11.2.1.0-1_i386_hardy.deb

Author of that .deb is currently looking into packaging the newest evolution-scalix connector coming with scalix 11.4 for ubuntu 8.04 LTS.

Changed in evolution-scalix:
status: Confirmed → Fix Released
Pat Suwalski (pat-suwalski) wrote :

I just released a new version of evolution-scalix that is Evolution 2.22-compatible. Please see:

ftp://ftp.gnome.org/pub/gnome/sources/evolution-scalix/11.4/

The only strange thing is that I have to clear LDFLAGS to have the plugin load properly in Evolution. Hardy's dpkg-buildpackage puts some strange flags in there.

Pasi Kärkkäinen (pasik) wrote :

evolution-scalix-11.4.1.0.tar.gz connector compiled from source on 8.04 LTS hardy heron seems to work fine!

Pasi Kärkkäinen (pasik) wrote :

And here's a link to an unofficial .deb of evolution-scalix connector (v11.4.1) for Ubuntu 8.04 LTS (hardy heron):

http://www.scalix.com/forums/viewtopic.php?p=47279#47279

Pasi Kärkkäinen (pasik) wrote :

Does someone want to re-upload evolution-scalix connector to ubuntu?

New v11.4.1.0 compiles and works out of the box with Evolution 2.22.

Changed in evolution-scalix:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.