evolution-rss not installable: dependency problems

Bug #873943 reported by Frederik Elwert on 2011-10-14
100
This bug affects 17 people
Affects Status Importance Assigned to Milestone
evolution-rss (Ubuntu)
Undecided
Unassigned
Oneiric
High
Bartosz Kosiorek

Bug Description

The package evolution-rss is not installable. It depends on evolution < 3.2, which obviously is not available.

[ Impact ]
Package is uninstallable in Oneiric for all users.

[ Development Fix ]
Fixed in Precise by pulling version 0.2.90~20111111-1 from Debian experimental. That version depends on evolution (>= 3.2), evolution (<< 3.3).

[ Stable Fix ]
According to upstream git log [1], there's only one commit related to changes in evolution [2] between 2011-08-22 (date of Oneiric snapshot) and 2011-11-11 (date of Precise snapshot). That commit only has effect for evolution >= 3.3.1. So there's no code changes we need to backport from Precise version. The fix is just relaxing binary dependency from << 3.2 to << 3.3.

[ Test Case ]
Run in terminal:

$ sudo apt-get install evolution-rss

Result:

The following packages have unmet dependencies:
 evolution-rss : Depends: evolution (< 3.2) but 3.2.1-0ubuntu1 is to be installed
E: Unable to correct problems, you have held broken packages.

Expected result: successful installation.

[ Regression Potential ]
Once the package is installable, bugs in it may become visible.

[1] http://git.gnome.org/browse/evolution-rss/log/
[2] http://git.gnome.org/browse/evolution-rss/commit/?id=f9f0880e2fc56ce69d0a25359c31cfcaac93050f

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: evolution-rss (not installed)
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
ApportVersion: 1.23-0ubuntu3
Architecture: i386
Date: Fri Oct 14 10:13:25 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110803.1)
SourcePackage: evolution-rss
UpgradeStatus: No upgrade log present (probably fresh install)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in evolution-rss (Ubuntu):
status: New → Confirmed
Mino (raccuia) wrote :

Same problem!!

The following packages have unmet dependencies:
 evolution-rss : Depends: evolution (< 3.2) but 3.2.0-0ubuntu2 is to be installed
E: Unable to correct problems, you have held broken packages.

Michael Seifert (michseif) wrote :

For me it looks like this (taken from the Software Center output):

Die folgenden Pakete haben nicht erfüllte Abhängigkeiten:

evolution-rss: Depends: libc6 (>= 2.4) aber 2.13-20ubuntu5 soll installiert werden
               Depends: libedataserver1.2-15 (>= 3.1.5) aber 3.2.1-0ubuntu1 soll installiert werden
               Depends: libgconf2-4 (>= 2.31.1) aber 3.2.3-0ubuntu0.1 soll installiert werden
               Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) aber 2.24.0-1ubuntu1 soll installiert werden
               Depends: libglib2.0-0 (>= 2.26.0) aber 2.30.0-0ubuntu4 soll installiert werden
               Depends: libgtk-3-0 (>= 3.0.0) aber 3.2.0-0ubuntu3 soll installiert werden
               Depends: libgtkhtml-editor-4.0-0 (>= 4.0) aber 4.1.92-0ubuntu1 soll installiert werden
               Depends: libsoup-gnome2.4-1 (>= 2.27.4) aber 2.36.0-0ubuntu1 soll installiert werden
               Depends: libsoup2.4-1 (>= 2.26.1) aber 2.36.0-0ubuntu1 soll installiert werden
               Depends: libwebkitgtk-3.0-0 (>= 1.3.10) aber 1.4.3-0ubuntu3 soll installiert werden
               Depends: libxml2 (>= 2.7.4) aber 2.7.8.dfsg-4 soll installiert werden
               Depends: gconf2 (>= 2.28.1-2) aber 3.2.3-0ubuntu0.1 soll installiert werden
               Depends: evolution (>= 3.1) aber 3.2.1-0ubuntu1 soll installiert werden
               Depends: evolution-data-server (>= 3.0) aber 3.2.1-0ubuntu1 soll installiert werden

This is quite confusing, since all requirements seem to be met, and still the package won't install...

Alexander E. Fischer (aef-v) wrote :

I'm experiencing this too. The package needs evolution >= 3.1 and evolution < 3.2. Either remove it completely from the repository or make it work with the available evolution 3.2.

Changed in evolution-rss (Ubuntu Oneiric):
status: New → Triaged
importance: Undecided → High
Changed in evolution-rss (Ubuntu):
status: Confirmed → Fix Released
description: updated
Ilya Barygin (randomaction) wrote :

Uploaded to oneiric-proposed.

Hello Frederik, or anyone else affected,

Accepted evolution-rss into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in evolution-rss (Ubuntu Oneiric):
status: Triaged → Fix Committed
tags: added: verification-needed
Bartosz Kosiorek (gang65) wrote :

I have also problem with installation evolution-rss.
During installation I have an error:

Następujące pakiety mają niespełnione zależności:
 evolution-rss : Wymaga: evolution (< 3.2) ale 3.2.2-0ubuntu0.1 ma zostać zainstalowany
W: Duplicate sources.list entry http://security.ubuntu.com/ubuntu/ oneiric-security/universe i386 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_oneiric-security_universe_binary-i386_Packages)
W: Duplicate sources.list entry http://security.ubuntu.com/ubuntu/ oneiric-security/multiverse i386 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_oneiric-security_multiverse_binary-i386_Packages)
W: Należy uruchomić apt-get update aby naprawić te problemy.
E: Nie udało się naprawić problemów, zatrzymano pakiety z niespełnionymi zależnościami.

After enable -proposed, evolution-rss installed successfuly.

Verification finished with success.

tags: added: verification-done
removed: verification-needed
Changed in evolution-rss (Ubuntu Oneiric):
assignee: nobody → Bartosz Kosiorek (gang65)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evolution-rss - 0.2.90~20110822-0ubuntu1.1

---------------
evolution-rss (0.2.90~20110822-0ubuntu1.1) oneiric-proposed; urgency=low

  * Relax binary dependency on evolution to << 3.3 (LP: #873943).
 -- Ilya Barygin <email address hidden> Sun, 11 Dec 2011 19:54:00 +0400

Changed in evolution-rss (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments