inline images do not go out when sending emails in evolution

Bug #452874 reported by phillamg on 2009-10-16
38
This bug affects 4 people
Affects Status Importance Assigned to Milestone
evolution-rss (Ubuntu)
Low
Unassigned
Lucid
Low
Unassigned

Bug Description

Binary package hint: evolution

Using Evolution 2.28.0-0ubuntu4 in Karmic on 16/10/9

Steps to reproduce:
-------------------------
Compose a new email, make sure the type is set to HTML. In the body type:
"Hello

Goodbye"

On the blank line go to Insert and Images and select any image (preferably JPG or PNG, with no spaces in the filename or path). In my case the file the file was dot0.jpg. Send the email.

Expected result:
--------------------
Recipient sees Image inline.

Actual result:
-----------------
Image is not in the message as it wasn't sent as part of the email. If you go into the Sent folder and look at the source of the email you will see the following:

--=-8CEnx4CokdqB8sI3Kewb
Content-Type: text/plain
Content-Transfer-Encoding: 7bit

Hello

Goodbye

--=-8CEnx4CokdqB8sI3Kewb
Content-Type: text/html; charset="utf-8"
Content-Transfer-Encoding: 7bit

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 TRANSITIONAL//EN">
<HTML>
<HEAD>
  <META HTTP-EQUIV="Content-Type" CONTENT="text/html; CHARSET=UTF-8">
  <META NAME="GENERATOR" CONTENT="GtkHTML/3.28.0">
</HEAD>
<BODY>
Hello<BR>
<IMG SRC="" ALIGN="bottom" BORDER="0"><BR>
Goodbye<BR>
<BR>
</BODY>
</HTML>

--=-8CEnx4CokdqB8sI3Kewb--

The image holder is tagged like an external image but there is nothing in the source field. For emails sent from Gmail you would see something like src="cid:ii_12457b63379b47d9" and then an additional part of the email to encode the image with the same content-id (i.e. --0016e6d566adb835cc0475f6a2b9 Content-Type: image/png; name="dots_black.png"
Content-Transfer-Encoding: base64 Content-ID: <ii_12457b63379b47d9> X-Attachment-Id: ii_12457b63379b47d9)

In actual fact the email doesn't even have to go externally. If you alter your smtp settings so it will fail to send then you can view the source in your outbox and it will be missing the image info.

Surely being able to insert an image is a basic feature that should have been working years ago?

BTW I have verified this on a two different machines and a variety of new and old user accounts.

Changed in evolution (Ubuntu):
importance: Undecided → Low
phillamg (me-phillg) wrote :

This seems to be a regression related to Ubuntu. I've just tried OpenSuse 11.2 alpha (milestone 8) which has Evolution 2.28 in it and this bug is not present. Composing a message with an image in works as expected.

phillamg (me-phillg) wrote :

I've narrowed it down a bit further. If you compose a message and save it as draft, then go into the draft folder and view the source of it, you'll see the image is encoded properly and attached as a multi-part email. However once the email goes from draft to Outbox that attached image is removed as explained above. Does that mean it is not an issue with Gtkhml, instead the sending mechanism with Ubuntu's Evolution?

phillamg (me-phillg) wrote :

Finally, I've tracked it down and have a work-around!

The problem comes from the fact that I also have evolution-rss installed. Something in there, possibly due to gtkhtml / webkit rendering, stops Evolution from sending emails with inline images or embedded images. Removing this package and completely restarting evolution (using --force-shutdown) means it now works as expected.

Should be flagged as a bug in evolution-rss package then, even though it affects the functionality of Evolution?

affects: evolution (Ubuntu) → evolution-rss (Ubuntu)
Jeremy Visser (jeremy-visser) wrote :

I confirm this bug, as well as confirming that removing evolution-rss ‘fixes’ the bug.

Changed in evolution-rss (Ubuntu):
status: New → Confirmed
Antoine RODRIGUEZ (connetport) wrote :

I also confirm,

I made my own evolution-rss plugin with all patches : work great

Please apply all the mainstream patches present in the project page : http://gnome.eu.org/evo/index.php/Evolution_RSS_Reader_Plugin

don't forget to do an autoreconf before doing ./configure

Best regards,

Antoine RODRIGUEZ (connetport) wrote :

If someone can explain me how to convert it as a deb I'm more than available to do it so and post it here.

Best regards,

Jeremy Visser (jeremy-visser) wrote :

antoiner: thanks for the link to the patch. It is pretty much the responsibility for the package maintainer to simply apply the patch. (It is as simple as running 'apt-get source evolution-rss', adding the patch to debian/patches, and uploading the source package.)

I'm familiar with building packages for myself, but not participating in proper package maintenance. So here's a debdiff for Lucid which contains the patch — not sure if it will be useful or not. I can also provide one for Karmic on request, but again — I don't know whether making them is a wasted effort or not.

Antoine RODRIGUEZ (connetport) wrote :

I've made a duplicate of this bug ........ 574475 (I forgot that it already exist here)

I've applied as you mentioned the patches and build a tentative deb. They are available in the duplicate.

The bug impact lucid too .....

Changed in evolution-rss (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Andrew Starr-Bochicchio (andrewsomething)

This is fixed in the upstream snapshot in Maverick.

Attached debdiff has been uploaded to lucid-proposed queue. It resolves both this and LP: #571105. Opening Lucid task and subscribing ubuntu-sru for an ACK.

evolution-rss (0.1.4-6ubuntu0.1) lucid-proposed; urgency=low

  [ Jeremy Visser ]
  * 04_inline-images.patch: fix bug where inline images in HTML e-mails
    would go MIA when evolution-rss is installed. (LP: #452874)

  [ Andrew Starr-Bochicchio ]
  * 05_status-icon.patch: Patch from upstream fixing a crash on
    updating the status icon. (LP: #571105) Thanks to Antoine Pairet.

 -- Andrew Starr-Bochicchio <email address hidden> Wed, 16 Jun 2010 15:46:27 -0400

Changed in evolution-rss (Ubuntu):
status: In Progress → Fix Released
assignee: Andrew Starr-Bochicchio (andrewsomething) → nobody
Changed in evolution-rss (Ubuntu Lucid):
status: New → Confirmed
importance: Undecided → Low
tags: added: patch-accepted-upstream

Accepted evolution-rss into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in evolution-rss (Ubuntu Lucid):
status: Confirmed → Fix Committed
tags: added: verification-needed
Pedro Villavicencio (pedro) wrote :

I've been using this package for more than a week now and did not noticed any regression so far. Marking this as verification done so it can go trough the updates, thanks all.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evolution-rss - 0.1.4-6ubuntu0.1

---------------
evolution-rss (0.1.4-6ubuntu0.1) lucid-proposed; urgency=low

  [ Jeremy Visser ]
  * 04_inline-images.patch: fix bug where inline images in HTML e-mails
    would go MIA when evolution-rss is installed. (LP: #452874)

  [ Andrew Starr-Bochicchio ]
  * 05_status-icon.patch: Patch from upstream fixing a crash on
    updating the status icon. (LP: #571105) Thanks to Antoine Pairet.
 -- Andrew Starr-Bochicchio <email address hidden> Wed, 16 Jun 2010 15:46:27 -0400

Changed in evolution-rss (Ubuntu Lucid):
status: Fix Committed → Fix Released

Was this patch ever applied? I'm seeing the same problem with Ubuntu 11.04, 64-bit, and the latest Evolution. The "evolution-rss" is listed as 0.2.2-0ubuntu1. It's causing the same problem. If I remove this package, inline pictures work again.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers